Opened 5 years ago

Last modified 5 years ago

#15796 new defect

After reconnecting account after connection drop, unable to join room.

Reported by: slip Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.7 Keywords: disconnected auto-join room
Cc:

Description

Hello,

I have searched through the ticket database and performed various Google searches but was unsuccessful in finding this problem. Our VPN has been unstable lately so it has become somewhat annoying. I apologise in advance if this is a problem

We have an Openfire server set up and are using Pidgin with the XMPP protocol. I am running Pidgin 2.10.7 on Windows 7 64bit.

I connect to the server through a VPN connection and have multiple rooms set to auto-join and persistent (these setting do not seem to affect the issue though).

If the VPN connection drops, Pidgin correctly detects the connection has been lost and displays the notification in the buddy list window as well as with a message in each chat window and room windows.

After re-establishing the VPN connection and reconnecting with Pidgin, I am no longer able to chat in the rooms I have set up. I am given the message that I have left the room and do not display in the participants list. I am unable to re-join the room. I have tried:

  • Re-joining the the room from my buddy.
  • Closing the chat and selecting join from the buddy list.
  • Selecting Conversation from a chat window and joining a room by entering the room details in the list (I have tried this multiple times with the handle I had when I was disconnected as well as a different handle)

In order to re-enter the room and be a participant I must restart Pidgin.

I have tried various combinations of the persistent and auto-join options.

Looking through the debug log after I have re-established a VPN connection and reconnected with the server, I notice the following (I can easily re-produce by manually disconnecting the VPN).

(14:47:32) jabber: attempt to send presence before roster retrieved

I also see a number of:

(14:47:33) jabber: Recv (ssl)(86): <iq type="result" id="purpleeadf5c4b" from="myusername@domain" to="myusername@domain/f082196b"/>
(14:47:33) jabber: Unhandled IQ with id purpleeadf5c4b

Steps to reproduce:

  1. Connect to an XMPP server (Openfire in this case).
  2. Create/join a room and add it to your buddy list.
  3. Join and participate in the room (participation is not necessary but you should at least have joined the room).
  4. Disconnect your VPN or disable the network interface (it is unknown whether or not the VPN contributes to the problem, see below).
  5. Re-establish the connection.
  6. Re-activate/connect your pidgin account
  7. Attempt to chat in the room (window should still be open), at this point you will already have or will shortly be given a message that you left the room.
  8. Attempt to re-join the room etc.

Extra information: That is my experience above from outside the network over the VPN. A friend who operates on the same network as the server (with the same client and pc set up) tested the issue by disabling the network interface. His experience was very similar except he was able to chat in the room until he was given the message that he left the room.

This suggests to me that the connection is still established and Pidgin has miss-tracked the session in the room.

Change History (1)

comment:1 Changed 5 years ago by mrtnmueller

I just wanted to open the same ticket. I have exactly the same issue here. I also have openfire as a server and Pidgin 2.10.7 as a client. I don't use any proxy or VPN. So it seems the issue is related to the connection dropping at all, not to anything about the VPN.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!