Opened 4 years ago

Closed 2 years ago

#15815 closed enhancement (out of date)

Facebook XMPP shows "has come online" notifications for online people

Reported by: computergeoffrey@… Owned by:
Milestone: Component: Facebook
Version: 2.10.7 Keywords: notifications facebook xmpp
Cc:

Description (last modified by computergeoffrey@…)

When you have a lot of online friends in your list (let's say 20) it is very disturbing to see so many people coming online. Facebook XMPP needs to check if a user is online before displaying notifications - now it displays notifications for people who were already online - which is weird! I suspect it has something to do with how Pidgin handles XMPP Facebook traffic - don't trust what they say (I mean, the XMPP traffic) about online people, but instead look in the list if they WERE already online and then decide whether to show a notification for that particular user.

Sorry if you don't understand what I mean. I've attached a screenshot for cleariness.

Edit: By the way, this can also be caused by an unstable internet connection. But it doesn't matter, the user always thought they were online. Instead, a message "you are offline" could be showed to the user.

Attachments (1)

peopleonline.png (29.7 KB) - added by computergeoffrey@… 4 years ago.
Too many notifications

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by computergeoffrey@…

Too many notifications

comment:1 in reply to: ↑ description Changed 4 years ago by computergeoffrey@…

  • Description modified (diff)

Made edit above

Last edited 4 years ago by computergeoffrey@… (previous) (diff)

comment:2 Changed 2 years ago by computergeoffrey@…

  • Resolution set to out of date
  • Status changed from new to closed

XMPP support is discontinued.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!