Opened 12 years ago

Closed 12 years ago

#1584 closed defect (fixed)

Strange Logging Duplicate Incident with HTML links.

Reported by: BNut83 Owned by:
Milestone: 2.2.0 Component: pidgin (gtk)
Version: 2.0.1 Keywords: logging html duplicate same retain
Cc:

Description

Was sent multiple HTML links in a conversation. All from a marketplace site, so they were 99% similar except for the item codes.

After closing the conservation, and opening up the history, for some reason, Pidgin retained the first HTML link, and displayed that same address for all instances of HTML links in the convo.

I was unable to reproduce this.

Attachments (1)

2007-06-07.153109-0400EDT.txt (1.6 KB) - added by BNut83 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by BNut83

comment:1 Changed 12 years ago by BNut83

I noticed 1 of the links in the log is unique, while all the others are duplicates for some odd reason.

In the convo, all links were unique.

comment:2 Changed 12 years ago by BNut83

Actually, after looking at it again.. Its just throwing a random link after every line that the other person chatted... For no apparent reason.

comment:3 in reply to: ↑ description Changed 12 years ago by BNut83

Replying to BNut83:

Was sent multiple HTML links in a conversation. All from a marketplace site, so they were 99% similar except for the item codes.

After closing the conservation, and opening up the history, for some reason, Pidgin retained the first HTML link, and displayed that same address for all instances of HTML links in the convo.

I was unable to reproduce this.

Weird. I just realized its not replacing links, its just taking a past link and putting it at the end of sentences in parentheses for no good reason.

comment:4 follow-up: Changed 12 years ago by rlaager

  • Milestone set to 2.0.2
  • pending changed from 0 to 1

Can you boil this down into a set of steps? Basically, what has to be written into the conversation? Then, what do you get as actual results? What is the expected result? Can you attach a log file with the wrong results?

comment:5 in reply to: ↑ 4 Changed 12 years ago by BNut83

  • pending changed from 1 to 0

The log file is attached. See all the URLs?? Notice how (http://www2.victoriassecret.com/commerce/application/prodDisplay/?namespace=productDisplay&origin=onlineProductDisplay.jsp&event=display&prnbr=ZP-210749&page=2&cgname=OSCLOSXYZZZ&rfnbr=3367) is appended to each line sent by HMommy? That was a link sent by HMommy before this log started. For some reason, Pidgin decided to append that to each line she sent afterward.

At 3:32:02.. a different URL was sent to me in a message, and Pidgin still appended another URL to the line.

comment:6 Changed 12 years ago by seanegan

  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #2445 which was fixed in 2.1.1

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!