Opened 5 years ago

Closed 5 years ago

#15886 closed defect (duplicate)

XMMP chat broken for PerfectWorld / Cryptic Studios games in Pidgin 2.10.8

Reported by: mynamesthedoctor Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.8 Keywords: XMMP, Star Trek Online, STO, Champions Online, Neverwinter, Perfect World, PWE, Percet World Entertainment, chat channels, STO, Star Trek
Cc: missmikeyshelly@…, mynamesthedoctor@…

Description

Hello,

In release 2.10.8 of Pidgin, (no 3rd party plug-ins) XMMP chat is also broken for Star Trek Online, Champions Online, and Neverwinter chat channels (these MMO games are run by Cryptic Studios / Perfect World Entertainment).

See: http://sto-forum.perfectworld.com/showthread.php?t=159864 to see what I'm talking about. It's not possible to sign into the game XMMP service, as well as the related chat channels connected to the game with Pidgin 2.10.8 at all. Yet the same thing works fine in Pidgin 2.10.7. Changes in 2.10.8 seem to have caused the problem. This problem only exists in 2.10.8 but not in previous releases of Pidgin.

Please investigate and do anything you can to help fix this in the next Pidgin release. I and many others appreciate it greatly. Thank you!

Attachments (2)

debug-pidgin-2_10_7.log (140.9 KB) - added by mynamesthedoctor 5 years ago.
Debug from Pidgin 2.10.7 - works
debug-pidgin-2_10_8.log (337.1 KB) - added by mynamesthedoctor 5 years ago.
Debug from Pidgin 2.10.8 - doesn't work

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by datallah

  • Milestone 2.10.9 deleted
  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
This is probably the same type of issue as #15879, but a debug log will be necessary to know for sure.

comment:2 Changed 5 years ago by mynamesthedoctor

  • Status changed from pending to new

Attachment (debug-pidgin-2_10_7.log) added by ticket reporter.

Changed 5 years ago by mynamesthedoctor

Debug from Pidgin 2.10.7 - works

comment:3 Changed 5 years ago by mynamesthedoctor

Uploaded the debug log from 2.10.7 as well as 2.10.8 to this ticket as requested.

comment:4 Changed 5 years ago by mynamesthedoctor

debug-pidgin-2_10_8.log​ reflects Pidgin 2.10.8 which does not work.

debug-pidgin-2_10_7.log​ reflects Pidgin 2.10.7 which does work.

Last edited 5 years ago by mynamesthedoctor (previous) (diff)

Changed 5 years ago by mynamesthedoctor

Debug from Pidgin 2.10.8 - doesn't work

comment:5 Changed 5 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15879.
Thanks for getting a debug log - this is the same issue as #15879:

(09:32:27) jabber: Sending (ssl) (username@CrypticSpace.com/Foo): <iq type='set' id='purple6a8667bf'><bind xmlns='urn:ietf:params:xml:ns:xmpp-bind'><resource>Foo</resource></bind></iq>
(09:32:28) jabber: Recv (ssl)(159): <iq from='crypticspace.com' type='result' id='purple6a8667bf'><bind xmlns='urn:ietf:params:xml:ns:xmpp-bind'><jid>username@crypticspace.com/Kiana</jid></bind></iq>
(09:32:28) jabber: Got a result iq with id purple6a8667bf from crypticspace.com instead of expected username@crypticspace.com!
(09:32:28) jabber: Unhandled IQ with id purple6a8667bf
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!