Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16408 closed defect (fixed)

Text Replacement plugin not using dict file

Reported by: rageboy Owned by:
Milestone: 2.10.11 Component: plugins
Version: 2.10.10 Keywords:
Cc:

Description

The text replacement plugin in the 2.10.10 release of pidgin on Windows 7 does not read the dict file. I keep seeing the default list of text replacements. Changes I make get saved to the dict file as expected, but upon quitting and reopening pidgin, the default list is loaded.

Attachments (2)

purple-debug.log (87.5 KB) - added by rageboy 5 years ago.
Log for opening pidgin while the plugin is loaded, making changes to the text replacement plugin dictionary, and closing pidgin
purple-debug-load.log (75.8 KB) - added by rageboy 5 years ago.
Log for opening pidgin while the plugin is loaded after having made changes to the dict file. The default dictionary was loaded rather than the changes that were made

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

Changed 5 years ago by rageboy

Log for opening pidgin while the plugin is loaded, making changes to the text replacement plugin dictionary, and closing pidgin

comment:2 Changed 5 years ago by rageboy

  • Status changed from pending to new

Attachment (purple-debug.log) added by ticket reporter.

Changed 5 years ago by rageboy

Log for opening pidgin while the plugin is loaded after having made changes to the dict file. The default dictionary was loaded rather than the changes that were made

comment:3 Changed 5 years ago by rageboy

Logs have been uploaded for making the changes to dict, closing pidgin, and reopening pidgin and finding that the new dict wasn't loaded

comment:4 Changed 5 years ago by datallah

I've uploaded a fixed plugin dll to https://pidgin.im/~datallah/spellchk.dll

comment:5 Changed 5 years ago by Daniel Atallah <datallah@…>

  • Milestone set to 2.10.11
  • Resolution set to fixed
  • Status changed from new to closed

(In [94ef6e02c72d]):
Fix loading the text replacement plugin's dict file, which was broken by e6937e52930b. Fixes #16408

comment:6 Changed 5 years ago by datallah

Ticket #16433 has been marked as a duplicate of this ticket.

comment:7 Changed 5 years ago by datallah

Ticket #16438 has been marked as a duplicate of this ticket.

comment:8 Changed 5 years ago by QuLogic

Ticket #16465 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!