Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#16432 closed defect (invalid)

Pidgin freezes when generating new OTR private key

Reported by: rubo77 Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.9 Keywords: otr keygeneration
Cc:

Description (last modified by rubo77)

On Ubuntu 14.04 when I enable the pidgin-otr plugin (off the record) and attempt to generate a new private key, Pidgin pops up a dialog box telling me that a new private key is being generated. However, key generation never completes and eventually I receive a notification that Pidgin or "Generating Private Key" is not responding.

Only after I installed the tool "haveged" to have enough /dev/random "content" I could create the key in a short time.

Some people say typing random text in a text field also works as a workaround. Nevertheless, a hint for the user on what to do would be helpful.

I refer to this bug report at https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/303862

Change History (5)

comment:1 Changed 5 years ago by rubo77

  • Description modified (diff)

comment:2 Changed 5 years ago by datallah

  • Resolution set to invalid
  • Status changed from new to closed

This issue is caused by a third party plugin. We have no control over these plugins. Please report this problem to the authors of this third party plugin.
OTR is a third party plugin.

comment:3 Changed 5 years ago by rubo77

Since OTR is the most important Plugin and nearly accepted to be implemented by default (#15513) you should link to the bugtracking site of otr: https://bugs.otr.im/projects/pidgin-otr/issues?set_filter=1&tracker_id=1

Last edited 5 years ago by rubo77 (previous) (diff)

comment:4 Changed 5 years ago by rubo77

I submitted this here: https://bugs.otr.im/issues/63

comment:5 Changed 4 years ago by rubo77

You should add the packages pidgin-otr and haveged to the suggested packages

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!