Opened 5 years ago

Closed 5 years ago

#16450 closed defect (fixed)

2.10.10 Build not working / NSIS Script Error?

Reported by: kumpa Owned by: EionRobb
Milestone: Component: unclassified
Version: 2.10.10 Keywords: build-pidgin winpidgin build crosscompile
Cc:

Description

Hello pidgin-community.

I've trying to compile the offline installer of pidgin on windows following your winpidgin-guide (https://developer.pidgin.im/wiki/BuildingWinPidgin). I've tried this on ubuntu/debian, xubuntu/debian and windows (cygwin32 and 64, native and virtual) multiple times. I can't figure out my mistake on this. Dependencies are checked multiple times too, also setup the build environment multiple times. I hope someone can give me an advice.

Best regards

(Cygwin output attached as text-file including a screenshot of the error-files)

Attachments (2)

lastfail.errlog.txt (92.1 KB) - added by kumpa 5 years ago.
Cygwins Output
errFiles.png (173.6 KB) - added by kumpa 5 years ago.
Errorfiles as Screenshot

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by kumpa

Cygwins Output

Changed 5 years ago by kumpa

Errorfiles as Screenshot

comment:1 Changed 5 years ago by kumpa

Someone has an idea? Or maybe you need more Information?

comment:2 Changed 5 years ago by datallah

Does the file that NSIS is complaining about actually exist?

File: failed opening file "..\..\..\./pidgin-2.10.10-win32bin\ca-certs\AOL_Member_CA.pem"

This is relative to the pidgin/win32/nsis directory.

I see these permissions errors in your log, which are probably the root cause of the problem:

C:\devel\pidgin-devel\win32-dev\mingw-4.7.2\bin\strip.exe:./pidgin-2.10.10-win32bin/plugins/autoaccept.dll: Permission denied

comment:3 Changed 5 years ago by kumpa

Thank you for your reply datallah - I've solved the problem yesterday: You're right - strip.exe / binary of gcc compiler suite has got a permission problem. The "PidginDevRoot?" Folder (parent folder of pidgin-2.10.10 and win32-dev) was at the path C:\devel\ like the BuildingWinPidgin-howto told me. But that's a problem at windows7 (I think it's because window's User Account Control?). The solution is to change the "PidginDevRoot?" Folder to your User-Account for example (e.g. C:\Users\myUserAccount\PidginDevRoot?\...). NSIS, Cygwin, Perl goes to C:\. Worked fine for me!

best regards and thank you very much

comment:4 Changed 5 years ago by kumpa

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!