Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#16451 closed patch (fixed)

MSN login broken due to blocked Application ID (patch attached)

Reported by: dx Owned by: QuLogic
Milestone: 2.10.11 Component: MSN
Version: 2.10.10 Keywords:
Cc:

Description

The error is:

msn: Retrieving contact list failed: Invalid Application Header Application ID is either not defined in database or blocked from access.

TReKiE on IRC pointed out that the Application IDs from WLM 2009 and 2012 still work correctly. The one that is being used in pidgin is from WLM 2008 (8.5)

Attaching a patch to switch it to the Application ID of WLM 2012, which 'fixes' login. At least until they block something else.

Attachments (1)

update-msn-application-id.patch (462 bytes) - added by dx 2 years ago.
Update MSN Application ID to the one used by WLM 2012

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by dx

Update MSN Application ID to the one used by WLM 2012

comment:1 Changed 2 years ago by QuLogic

  • Milestone set to 2.10.11
  • Resolution set to fixed
  • Status changed from new to closed

I've already applied this patch in f6a91e6c77a4.

comment:2 Changed 2 years ago by dx

I made a generic binary patcher for those too lazy to recompile pidgin/libpurple:

https://gist.github.com/dequis/77b478f35f93f64ac640

comment:3 Changed 2 years ago by QuLogic

Ticket #16454 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!