Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#16455 closed defect (fixed)

Pidgin does not connect since upgrade to 2.10.10

Reported by: gereri Owned by: QuLogic
Milestone: 2.10.11 Component: MSN
Version: 2.10.10 Keywords:
Cc: libricoleur

Description (last modified by gereri)

Hello Pidgin was working perfectly until the last upgrade to 2.10.10 for a couple of days now I have a permanent 'Available - connection on going' message at the bottom of the screen few days before I got unable to connect, I was able to send pidgin messages, but not able at all to receive any...

I am using a MSN userid with MSN protocol. I changed nothing in the settings by upgrading to 2.10.10 What shall I do to be able to use pidgin again? Thanks for advice and support Update from Nov 14: Please consider the memory used by Pidgin (attached screenshot)

Attachments (4)

Capture 3.JPG (29.1 KB) - added by gereri 2 years ago.
Capture 1.JPG (20.1 KB) - added by gereri 2 years ago.
Capture2.JPG (20.6 KB) - added by gereri 2 years ago.
Task Manager.JPG (31.2 KB) - added by gereri 2 years ago.

Download all attachments as: .zip

Change History (23)

Changed 2 years ago by gereri

Changed 2 years ago by gereri

Changed 2 years ago by gereri

comment:1 Changed 2 years ago by Varonth

Having the same problem, using Windows 8.1

Ressource monitor shows two TCP connections while Piding is trying to connect. One of them is going to the URL: "local-bay.contacts.msn.com.akadns.net" , which is using about 15kb/s upstream and 8kb/s downstream for hours if I let the client run in the background.

Meanwhile Pidgin does not have any filehandler open at the same time, so it does not appear to write or read something on the HDD.

Memory usage appears to rise at a very slow rate.

comment:2 Changed 2 years ago by Robby

  • Component changed from unclassified to MSN
  • Owner changed from EionRobb to QuLogic
  • Summary changed from Pidgin does not connect since upgrate to 2.10.10 to Pidgin does not connect since upgrade to 2.10.10

comment:3 Changed 2 years ago by gereri

still same issue today and can confirm that pidgin is also using significant memory see screenshot attached of the task manager

Changed 2 years ago by gereri

comment:4 Changed 2 years ago by gereri

  • Description modified (diff)

comment:5 Changed 2 years ago by Mwd4d0P

Having the exact same problem with memory-hogging whenever any of the multiple MSN/Hotmail accounts are seemingly connected for days on end--only one visibly refuses to connect to MSN with a persistent "Unable to authenticate Authentication Failure" message. (The exception could be a non-Pidgin issue that I need to look into later.)

However, earlier, when the relevant "seemingly connected" accounts were auto-connected, their icons in the Accounts' drop-down menu and the "Manage Accounts" window both showed that they are fully connected (not greyed out), but the global status icon shows that one or multiple accounts were disconnected ("unplugged"). "Seemingly connected" means also that none of the contacts showed up on the lists despite seeing the colored "connected" icons.

Logging in now, in any form, is impossible after the manual, individual disconnects; the remaining accounts that "connected" earlier still show no error messages, but do continue to transfer via the aforementioned TCP connection, e.g., the remote address being 65.55.246.85 in my case. All icons remain grey, and the global icon is still "disconnected".) But the point is that it was surprising to see the virtual size of the app skyrocket to ~1.8G after a few days. (Not a problem on a new W7 machine with obscene amounts of RAM, but troublesome for older, far less robust systems.)

Also tried rolling back to v2.10.8, but the problem with all MSN/Hotmail connections/progressive RAM-consumption still persist. i.e., *most* of the same problems as those stated in the previous comments.

An obvious fix is to simply disconnect all MSN/Hotmail accounts (which has been done for the time being), but that won't be possible for the long-term with accts required for immediate work purposes.

A stable workaround or patch would be much appreciated!

Last edited 2 years ago by Mwd4d0P (previous) (diff)

comment:6 Changed 2 years ago by mcarrera

Experiencing the same problem connecting to MSN. After the upgrade to 2.10.10, Pidgin worked fine. Over the last few days, I have been getting the same symptoms described above. The problem occurs on 3 machines: one runs Ubuntu 14.04, one Windows 7 64 bit and one Windows 7 32 bit. I run Wireshark and I see http traffic going on between me and local-bay.contacts.msn.com.akadns.net but no sign of life in the interface.

Currently using Pidgin with a Yahoo account on the aforementioned machine, it works fine but it's not as convenient for if I log in in one machine, the others will be disconnected.

Last edited 2 years ago by mcarrera (previous) (diff)

comment:7 Changed 2 years ago by QuLogic

You will need to disable the MSN account until 2.10.11 is released, or if you're able, apply the patch in the linked ticket.

comment:8 Changed 2 years ago by Mwd4d0P

Thanks for the reply, QuLogic, but I've been monitoring this patch/link, too:

https://gist.github.com/dequis/77b478f35f93f64ac640

Appears to be a hit or miss fix in general... so do you think this MSN/Hotmail issue is prevalent enough to warrant a push for an earlier 2.10.11 release?

(Will be trying the patch regardless of the answer since work will be taking a hit with services down.)

comment:9 Changed 2 years ago by QuLogic

As noted in that patch, there are issues with buddy visibility. So releasing early would just warrant another release rather quickly once that is fixed.

comment:10 Changed 2 years ago by Mwd4d0P

Quick semi-related update: after some futzing with various accounts, it seems that MS has perhaps reverted to old database information and certain settings. In lieu of whatever new assbackward changes, who knows... but it's obnoxious.

If there are still authentication fails during the pidgin login like I've had, try using the previously used password for that account.

Haven't attempted the patch yet, but will try later this weekend.

comment:11 Changed 2 years ago by QuLogic

Ticket #16462 has been marked as a duplicate of this ticket.

comment:12 Changed 2 years ago by pedromt

I followed the steps to install the patch, and the problem was fixed in Windows XP Sp3! Thank you! Ah! Just so you know ... with python 3.4 will not work for me. It worked fine with version 2.7.

comment:13 Changed 2 years ago by Mwd4d0P

Delayed update: got the patch working, too, but it took a lot more troubleshooting to figure out what was going on the MSN account-side with all of their new and stupid changes. Too many pointless headaches.

Love Pidgin, the ongoing, (super patient!) dev support, and community.

Many thanks!

comment:14 Changed 2 years ago by QuLogic

Ticket #16464 has been marked as a duplicate of this ticket.

comment:15 Changed 2 years ago by novasource

Confirming that the memory leak is true. Pidgin had gobbled up over 1 GB of RAM (per Windows 8.1's Task Manager) before I caught it. This appears related to this issue's core MSN problem as the leak is not apparent when I disable my MSN account.

comment:16 Changed 2 years ago by datallah

Ticket #16472 has been marked as a duplicate of this ticket.

comment:17 Changed 2 years ago by QuLogic

  • Milestone set to 2.10.11
  • Resolution set to fixed
  • Status changed from new to closed

Huh, why is this still open? See #16451 and ee51d84aacbf.

comment:18 Changed 2 years ago by novasource

This was fixed only briefly in 2.10.11. It's breaking again.

comment:19 Changed 2 years ago by novasource

The 2.10.11 problem is addressed in #16489.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!