Opened 5 years ago

Closed 2 years ago

#16475 closed defect (out of date)

New release 2.10.11 STILL won't connect MSN accounts

Reported by: Chronia Owned by: QuLogic
Milestone: Component: MSN
Version: 2.10.11 Keywords: connection MSN
Cc: l_bratch, omega13a

Description

I had this problem with 2.10.10 and was told it would be fixed for version 2.10.11. The update notes even say it has been fixed, but it hasn't! I updated to 2.10.11 and signed in. One of my MSN accounts appeared to be online but it only showed one of my contacts online. My husband WAS online on his pidgin at the time but was NOT showing as online on my end (he has also updated to the newest version). Having sent a test message to him anyway he did NOT receive it. So while on my end I appeared to be signed in and connected I actually was not. As for my other MSN account it just plain didn't connect in anyway shape or form, it didn't even look like it was connected, it was offline from my end. I tried this yesterday. Today when I tried again, neither msn account would connect at all or even look like they had connected as the one had yesterday. Please can you actually fix this? I can't stand using skype for an MSN chat client! Not only that but half my contacts are not ON skype. Please fix this soon.

Attachments (3)

debug.log (351.1 KB) - added by Chronia 5 years ago.
Pidgin debug log file
purple-debug_WO-HTTP.log (1.7 KB) - added by spacegato 4 years ago.
purple-debug.log (1.7 KB) - added by spacegato 4 years ago.

Download all attachments as: .zip

Change History (30)

comment:1 follow-up: Changed 5 years ago by QuLogic

  • Milestone 2.10.12 deleted
  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:2 Changed 5 years ago by Mwd4d0P

Man, the tone of the OP... a lot more details, and possibly more rigorous testing, are required before anyone can begin to tackle the problems.

However, I do want to add this to the pile of MSN bugs:

While manually updating the MSN DLL for v2.10.10 fixed my non-Skype-enabled MSN/Hotmail accounts, the update to v2.10.11 showed one new change: the only account that had zero account issues (of the non-Pidgin variety) after patching, is now the only account that's not showing up on any of the other MSN contact lists. (I'll call it "X" starting now.)

Rolling back to v2.10.10 (with the manual patch) showed no change, so it seems like an MSN problem, i.e., non-Pidgin. I know the Outlook servers have been pretty bad about account setting changes with crazy delays, WTF outputs, and security BS, so this could very well be some kind of idiotic account data propagation lag.

But what made X show up again on a couple of the other contact lists (only my own) while properly displaying the other online contacts (my own, again), was to remove and re-add the contacts/accounts on both ends, i.e., X's list other accts' lists. This resulted in the reappearance of X as an "online" contact, however, the name associated with X was automatically changed to the "first name"-only on other lists... so again, this looks to be an MSN issue.

At this point, I won't remove and re-add X's many other contacts that showed up regularly only days before, or the rest of my accounts; only the absolute essentials for work. This way, if it's really a server-side MS issue (hopefully just propagation lag or something equally slow and stupid), then it'll be easy to detect when that one account shows up again.

Incidentally, the results are the same on XP(x86) and W7(x64) machines.

comment:3 Changed 5 years ago by Chronia

  • Status changed from pending to new

I did not submit a debug log as pidgin is not crashing. MSN simply is not launching. I DID look at the bug submission instructions and steps one through three for bug submission do not list needing to submit a debug log. Below steps one through three "What to do if Pidgin Crashes" lists a debug log required. As pidgin is not crashing, I did not submit one. Please read your own directions. It was not listed under submitting a bug report as pidgin is not crashing therefore no debug is required as per your "instructions". The problem is that MSN accounts are STILL not connecting (but not crashing pidgin). If a debug log is required it should be listed in steps one through three or a new step four under "Steps fo bug report submission". As it is not, it was implied to not be required.

As you are requesting a debug log I will post one shortly, but please think on rewording your instructions so that they make sense. If it is not mentioned under the bug submission instructions clearly (in the subheading section related) most people will believe one is not required.

Last edited 5 years ago by Chronia (previous) (diff)

Changed 5 years ago by Chronia

Pidgin debug log file

comment:4 Changed 5 years ago by Chronia

Attached the debug file with all plugins disabled so as not to create extra noise in the log file. I did test pidgin with all plugins disabled and MSN accounts still do not connect so it is not being caused by a plugin.

comment:5 Changed 5 years ago by QuLogic

You have more than one MSN account enabled; which one is having problems? Who is supposed to be online that isn't?

comment:6 Changed 5 years ago by Chronia

I have two MSN accounts, neither is working. They are not even looking as signed in. They show enabled in my account list, but do not show up in any way, shape or form on my contact lists. The only account that is working is my icq, so it shows my account "Chronia (ICQ): followed by my contacts. However I do not even get a listing of my MSN accounts as such on the list. it used to show (prior to Microsoft mucking around) "Chronia (ICQ)" followed by contacts, then "Chronia (MSN)" followed by contacts, then "Tiana (MSN)" followed by contacts. Now it is only showing the ICQ account, which is functioning normally. Hope that all makes sense.

comment:7 Changed 5 years ago by pedromt

I have a similar problem. I have a single account MSN. When I start a conversation and write them to my contacts do not get my messages. Only when I speak sometimes I get your messages, but anytime the connection and no receipt is short and does not reach the messages sent to them. And sometimes pidgin throw an error with the MSN account. Informa "The server reported an error reading"

comment:8 Changed 5 years ago by Mwd4d0P

Wanted to update on my bizarre situation:

There was no such server lag or whatever since the last post, so all of the contacts that weren't manually re-added never showed up in the X account, i.e., "...the only account that had zero issues (of the non-Pidgin variety) after patching...", later becoming "...the only account not showing up on any of the other MSN contact lists" post 2.10.11 update.

Yesterday, a single account (not X) went offline with the message: "Connection error from Notification server: Connection refused."

It refused to connect for over 24 hours. Using multiple computers and also logging into the webmail side for troubleshooting yielded nothing. (Incidentally, this manually added personal account only shows up in X via the webmail interface when the IM section is toggled to the "available" status. Invisible and Available both make the account come online and offline in X's Pidgin list, but that's it.)

After all that, about half an hour ago, I noticed that the rest of the accounts (also not X) went offline and gave the the same error message. (Troubleshooting via the webmail interface does nothing other than allow feckless toggling of the status; no contact list is displayed there when Available.)

What's weird now is that X is the only account that can successfully connect to the MSN server and show a stunted contact list of sorts (where only anything re-added manually appears).

Not sure if X will disconnect in the near future, but this is looking grim...


6 hours later...

X is now refusing to connect. Therefore not a single MSN account is able to login.

Last edited 5 years ago by Mwd4d0P (previous) (diff)

comment:9 Changed 5 years ago by QuLogic

@Chronia: Your accounts are online, but Pidgin is not requesting presence from all of your contacts (because MS decided to send two different and inconsistent lists for some reason). We can work around that, but I don't know about the Yahoo contacts. If you look at your debug log, there are 3 @yahoo.com addresses that are "from network 0"; do you know whether they really are supposed to work?

@pedromt: That seems unrelated to this ticket.

@Mwd4d0P: Some of your issues are related to this ticket. The fact that you can't connect now can be fixed by setting the accounts to use HTTP method.

comment:10 Changed 5 years ago by Mwd4d0P

Great! That worked out, however, should the http method not be considered a long-term solution? In all of the years of using Pidgin (and Gaim--if it had it?), I've never had to make use of that option.

Also, X is still showing no original contacts online; only the manually re-added folk. Do you think this is a unknown MS variable and completely unrelated to Pidgin? If so, I'll cease bringing it up.

Thank you so much, again, QuLogic!

Version 0, edited 5 years ago by Mwd4d0P (next)

comment:11 Changed 5 years ago by Chronia

@QuLogic: Don't recognize the email address for one of them (I mostly know my contacts by their screen names, not emails) but I do know the other two worked.

When I logged pidgin on to check neither msn account was connecting even as much as it had been and I was getting the "Connection errors from Notification Server. Connection refused" with the option buttons to "Modify account" or "Reconnect". When I click reconnect it is just comes up with the same error no matter how many times I click reconnect it pops up again, for both accounts.

Last edited 4 years ago by Chronia (previous) (diff)

comment:12 in reply to: ↑ 1 Changed 4 years ago by rjratnip

Replying to QuLogic:

Please follow the instructions to get a debug log and attach it to this ticket.

I as well as my friends have also had the same issue since installing 2.10.11. Is this issue being worked on?

comment:13 follow-up: Changed 4 years ago by spacegato

I am having the same problem with connecting to MSN as Chronia. I am using version 2.10.11. When I try to connect to MSN I receive the message "Connection error from Notification server: Connection refused." I've read through this thread and, unless I missed something (I tend to do that), the connection problem doesn't seem to have been resolved. I've attached two my debug files one with HTTP method and the other without. I hope this helps.

Changed 4 years ago by spacegato

Changed 4 years ago by spacegato

comment:14 in reply to: ↑ 13 Changed 4 years ago by Chronia

Replying to spacegato:

I am having the same problem with connecting to MSN as Chronia. I am using version 2.10.11. When I try to connect to MSN I receive the message "Connection error from Notification server: Connection refused." I've read through this thread and, unless I missed something (I tend to do that), the connection problem doesn't seem to have been resolved. I've attached two my debug files one with HTTP method and the other without. I hope this helps.


No, you didn't miss anything, the problem has not yet been resolved.

comment:15 follow-ups: Changed 4 years ago by Mwd4d0P

Getting a little tiresome when folks aren't particularly proactive about troubleshooting things on their own.

This solves a lot of basic problems:

http://ismsndeadyet.com/

And it solves spacegato's problem in both logs. Read that site and try to determine what isn't Pidgin before laying the blame solely on this great piece of software.

comment:16 in reply to: ↑ 15 Changed 4 years ago by Yhoni

Replying to Mwd4d0P:

Getting a little tiresome when folks aren't particularly proactive about troubleshooting things on their own.

This solves a lot of basic problems:

http://ismsndeadyet.com/

And it solves spacegato's problem in both logs. Read that site and try to determine what isn't Pidgin before laying the blame solely on this great piece of software.

Hi, I've been able to connect with Outlook account using your solution.

Thank you.

Last edited 4 years ago by Yhoni (previous) (diff)

comment:17 in reply to: ↑ 15 ; follow-up: Changed 4 years ago by Chronia

Replying to Mwd4d0P:

Getting a little tiresome when folks aren't particularly proactive about troubleshooting things on their own.

This solves a lot of basic problems:

http://ismsndeadyet.com/

And it solves spacegato's problem in both logs. Read that site and try to determine what isn't Pidgin before laying the blame solely on this great piece of software.

I've done all the trouble shooting I know how to do. Don't be rude. People post here when they need help with a problem, usually because they aren't knowledgeable enough to fix it on their own, such as myself. The problem is with pidgin's connection to msn accounts, otherwise it works fine. I understand that it has to do with ports being used, but that is as much as I know and I don't know how to change it. Your link was not a solution for me as while the accounts look like they connect on the UI (except none of the contacts show up online) but then after about a minute or two the same connection error re-appears. I have tried several of the ip addresses from the list in the link that they claim are working. Also using outlook is not a solution. I want to use pidgin as my chat client not a hotmail web client.

Last edited 4 years ago by Chronia (previous) (diff)

comment:18 Changed 4 years ago by dk273

Can I add - me too!

Please fix. Pidgin 2.10.11 on Windows 8.1 Pro 64-bit.

comment:19 in reply to: ↑ 17 Changed 4 years ago by Mwd4d0P

Um, clearly you don't have much personal experience serving as tech support; and do you seriously not recall your OP? You know, the horrible screaming and grossly whiny tone all crammed into one humongous paragraph?

The acronym PEBKAC was created for similar instances. You have no leg to stand on when you yell and demand (almost unreasonable) assistance from already helpful devs that are spending their free time and effort to create a wonderfully free piece of software.

Judging by QuLogic's responses in this thread and another (16455), it's clear that there is perhaps something other than Pidgin at the root of your issues. That could be just one reason (of however many) why he is silent despite having already done as much as he could--short of accessing your computer directly--by reviewing your debug log. Perhaps he's busy with other things and your problem is very unique, and thus, an isolated case.

But no one can know anything for sure based on your responses.

If you don't bother to do more troubleshooting on your own--which could very well entail a thing called "research" on the internet--or at least state new conditions for your problem in some clear, logical manner (minus the attitude), you can probably expect more silence. Or maybe you could try overpriced, bloated commercial alternatives like Trillian and bitch to their tech support whenever things don't function for MSN; you'd certainly have the right there because you would have PAID for the software.

Pidgin is free, remember?

Here's a fitting Russian proverb for you: "There is no shame in not knowing; the shame lies in not finding out."

And there is always something to be said for folks who come to an open support thread and don't bother reviewing any of the history prior to RE-posting about an issue already covered, i.e., demanding personal attention and immediate service: Lazy.

Replying to Chronia:

I've done all the trouble shooting I know how to do. Don't be rude. People post here when they need help with a problem, usually because they aren't knowledgeable enough to fix it on their own, such as myself. The problem is with pidgin's connection to msn accounts, otherwise it works fine. BLAHBLAHBLAH...

comment:20 Changed 4 years ago by spacegato

Last edited 4 years ago by spacegato (previous) (diff)

comment:21 Changed 4 years ago by omega13a

http://ismsndeadyet.com/ now shows all servers don't support the MSNP18 protocol which means we can't use Pidgin to connect to our MSN accounts until support for the MSNP21 protocol is added. :(

comment:22 Changed 3 years ago by dx

Ticket #16489 has been marked as a duplicate of this ticket.

comment:23 Changed 3 years ago by dx

Ticket #16512 has been marked as a duplicate of this ticket.

comment:24 Changed 3 years ago by dx

Ticket #16527 has been marked as a duplicate of this ticket.

comment:25 Changed 3 years ago by dx

Ticket #16732 has been marked as a duplicate of this ticket.

comment:26 Changed 3 years ago by dx

Ticket #16430 has been marked as a duplicate of this ticket.

comment:27 Changed 2 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all MSN tickets, since it has been removed in pidgin 2.12.0 after being broken for a couple of years (see http://ismsndeadyet.com/). The skypeweb plugin can be used as an alternative (yes, it supports MSN logins too)

If this issue is still present in any other protocols supported by pidgin, please leave a comment and we will reopen it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!