Opened 5 years ago

Closed 4 years ago

#16487 closed defect

NSS Preferences

Reported by: jdantzler Owned by: datallah
Milestone: Component: plugins
Version: 2.10.11 Keywords:
Cc:

Description

The SSL Failed Handshake error that occurred when trying to connect to an XMPP server has somewhat been fixed in the latest pidgin (2.10.11) via the NSS Preferences Plugin. However, the plugin feels very unstable and sometimes it does not work correctly and we get the SSL Failed Handshake error again. I found out if we just randomly change the maximum and minimum versions and restart pidgin sometimes it will connect. It seems to work for some and not others. It is not very consistent at all. Eventually, if we play around with it long enough we can normally connect. We all have the right ciphers checks so I'm not sure what the issue is. I believe there is a bug in the plugin somewhere that is causing these random issues.

Previous Ticket: https://developer.pidgin.im/ticket/16410

Change History (4)

comment:1 Changed 5 years ago by jdantzler

  • Component changed from unclassified to plugins

comment:2 Changed 5 years ago by Robby

  • Owner changed from EionRobb to datallah

comment:3 Changed 5 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
It's going to be hard to guess what's happening without more information. A debug log from when it's working and not working will be helpful.

If you are on Windows, there's a bug which causes the plugin not get loaded at startup, which could explain the inconsistent behavior.

comment:4 Changed 4 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!