Opened 4 years ago

Closed 3 years ago

#16489 closed defect (duplicate)

MSN connection problem

Reported by: scottbrod Owned by: QuLogic
Milestone: Component: MSN
Version: 2.10.11 Keywords:
Cc: novasource, McCabre1

Description

For the last few days I can't use my Hotmail account with MSN. I keep getting : Connection error from Notification server: Connection refused.

I just tried with the msn messenger and trillian and they both work fine from my PC. Any suggestions on how to resolve this

I have 2.10.11 I am running on a WIN7 machine, and this has work for a long time until a few days ago. My settings are standard

Server is : messenger.hotmail.com Port is 1863

Http Method is unchecked the next three checkboxes are all checked Proxy is use global proxy Settings

Change History (18)

comment:1 Changed 4 years ago by QuLogic

  • Status changed from new to pending

You need to turn on the HTTP Method.

http://ismsndeadyet.com/

comment:2 Changed 4 years ago by scottbrod

  • Status changed from pending to new

That worked, but I have never needed that before, what changed?

comment:3 Changed 4 years ago by Robby

Did you visit the page QuLogic linked to?

comment:4 Changed 4 years ago by scottbrod

Thanks,

The HTTP method worked and thanks to QuLogic for the input

comment:5 Changed 4 years ago by novasource

This need to be set by default for MSN or added to the UI's error message.

comment:6 Changed 4 years ago by scottbrod

changing to the http method worked for a while, I am not getting the same issue with the HTTP options checked... any suggestions? Trillian and Messenger are working fine

comment:7 Changed 4 years ago by snelson

I'm having the same issue too.

Going to http://ismsndeadyet.com/ suggests picking a random IP to connect to but I've tried a handful and it's the same thing.

Is MSN support going to be completely dead for Pidgin?

comment:8 Changed 4 years ago by McCabre1

The current issue with Pigdin and MSN should be surrounding the fact that Microsoft has disabled HTTP Method and now requires HTTPS Method (TLS on 443).

From my understanding and research of the problem pigdin simply should be required to be told to connect securely when the (http method is checked - which should now be the default option). This in theory should be a very trivial change.

comment:9 Changed 4 years ago by gereri

I have the same problem since for a couple of days... Is there a short term workarround? Can you help and/or advice?

comment:10 Changed 4 years ago by McCabre1

I created ticket https://developer.pidgin.im/ticket/16512 for the specific issue of MSN and HTTPS. There are two links to people who are monitoring and maintain some tools for Reviver. They mention that there are "a few" IM clients that support HTTPS method. If you are brave and want to take some time to peruse the blog and comments you may find something that might work in the short term.

comment:11 Changed 4 years ago by snelson

Modify MSN Account > Advanced > HTTP Method Server: 157.56.126.33

That IP is working for me for now, make sure to have HTTP Method check-box ticked.

comment:12 Changed 4 years ago by gereri

I confirm that this change works for me as well. Thanks for your advice.

comment:13 Changed 4 years ago by novasource

That change does not work for me.

comment:14 Changed 4 years ago by snelson

It's working for me to login, but message delivery from contacts aren't working reliably.

I'll ask a contact what's up and they respond but I never receive the message, essentially thinking they are ignoring me and hate me. I have to ask if they responded and they did but Pidgin never receives this.

What could be the issue there? Has someone already created a ticket regarding this?

comment:15 Changed 4 years ago by gereri

Same issue for me. Now that I can connect back, I can send messages but I never receive any answer. I thought it was related to some filtering on the sender side. But as I am not the only person having this problem i am wondering if there is not another ticket open for this issue. If yes , which one is it? Should I open one?

comment:16 Changed 4 years ago by McCabre1

It probably has to do with the connection to the notification server. There have been several tickets in the past (some around the time of the initial banning of App IDs and shutting off of port 1863) reporting this issue with a few weird workarounds.

I am guessing, as long as people are connecting through NON HTTPS (because Microsoft is slowly switching this off on all servers slowly) that this will continue being a persistent issue.

I created a ticket https://developer.pidgin.im/ticket/16512 for this, however it seems to not be public/visible.

comment:17 Changed 4 years ago by gereri

After the change of Method, I can send messages, but never receive any. Any idea on what needs to be corrected or changed to get messages from 3rd parties to Pidgin? Thanks

comment:18 Changed 3 years ago by dx

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #16475.
Duplicate of #16475.

Also, use the skypeweb plugin instead.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!