Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#16512 closed defect (duplicate)

Option (or Force) MSN to use HTTPS (port 443 + TLS)

Reported by: McCabre1 Owned by: QuLogic
Milestone: Component: MSN
Version: 2.10.11 Keywords: MSN HTTP_Method HTTPS_Method
Cc: den90, l_bratch, drzraf

Description

Per http://ismsndeadyet.com/ and http://messengergeek.wordpress.com/2014/12/05/microsoft-appears-to-be-pushing-messenger-to-http/ Microsoft has turned off port 80.

The HTTP Method which (was) previously required to connect to the MSN Services after they shut down port 1863 (most likely) now needs to instead connect to port 443 via HTTPS.

Change History (6)

comment:1 Changed 4 years ago by snelson

Really wish this could be pushed out sooner. Any estimates when 2.10.12 will be released so I can use Pidgin with MSN again? I'm using Trillian right now and hating it..

I've tried multiple IP addresses from ismsndeadyet.com with no success in connecting. Is there another patch from somewhere I can apply to get me back to Pidgin with MSN in the meantime?

Thanks!

comment:2 Changed 4 years ago by den90

There's no need to change the messenger. It's still one server (64.4.45.62) available that has port 80 open. You only have to set up Pidgin to use that one. But it would be great if the next version would support HTTPS.

http://ismsndeadyet.com/#status

comment:3 Changed 4 years ago by snelson

Thanks for your response.

When I fill out the MSN connection details for that IP, it still fails to connect.

Here is a screenshot of my account settings: http://i.imgur.com/zZhDrkb.png

comment:4 Changed 4 years ago by tmcmahon2

Is Pidgin going to support any recent MSN protocols? It appears MSNP21 or higher is going to work and even that might not last for much longer. If not, it might be time to pull MSN support entirely. (Or I'm missing something ...)

comment:5 Changed 3 years ago by dx

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #16475.
Also, use the skypeweb plugin instead.

comment:6 Changed 3 years ago by Robby

  • Milestone 2.10.12 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!