Opened 5 years ago

Closed 4 years ago

#16532 closed defect (cantfix)

gtalk (XMPP) message read status not sync between Pidgin and Hangouts

Reported by: rouen_sk Owned by: darkrain42
Milestone: Component: Google Talk
Version: 2.10.11 Keywords:
Cc:

Description

When I use the same gtalk (hangouts) account on my phone and on desktop with pidgin, there seems to be bad sync about read status of messages. Typical scenario: somebody write me message, I dont read it right that moments, so notification arrives on my phone. Then I read it with pidgin (an answer even), but notification on my phone wont disappear. So later when I chcek my phone, there are notifications about messages I read hours ago and are not relevant anymore. I think this is pidgin fault (not reporting read status to server correctly or something), because when I open message in google+ website, notification on phone immediately disappear, so this functionality IS implemented in protocol and android client obviously.

Change History (3)

comment:1 in reply to: ↑ description Changed 4 years ago by Fausto_Lioncourt

Replying to rouen_sk:

When I use the same gtalk (hangouts) account on my phone and on desktop with pidgin, there seems to be bad sync about read status of messages. Typical scenario: somebody write me message, I dont read it right that moments, so notification arrives on my phone. Then I read it with pidgin (an answer even), but notification on my phone wont disappear. So later when I chcek my phone, there are notifications about messages I read hours ago and are not relevant anymore. I think this is pidgin fault (not reporting read status to server correctly or something), because when I open message in google+ website, notification on phone immediately disappear, so this functionality IS implemented in protocol and android client obviously.

I just checked out this, and what I did trying to reproduce it was this: Got a message on gtalk, so I got the notification, then I saw it on the chat provided by gmail, and the notification on my phone took like 4-5 minutes on disappearing. Then I tried the same thing with pidgin, and it resulted the same thing (I am using pidgin 3), the notification on my phone also disappeared like in 4 minutes, so I am not pretty sure that this is pidgin fault.

comment:2 Changed 4 years ago by rouen_sk

4-5 minutes no matter what? That does not seem like proper behaviour. Please try this: get gtalk message and wait for notification on your phone to appear. Then read the message on your Google Plus (not gmail) web page. In this case, my notification disappear immediately (with gmail not, so obviously even Google cant get it right everywhere). On my phone (nexus 5, android 5.0.1., newest Hangouts) notifications dont disappear after few minutes, nor ever, until I remove them manually - or read the chat in Google Plus.

comment:3 Changed 4 years ago by datallah

  • Resolution set to cantfix
  • Status changed from new to closed

The gtalk XMPP interface doesn't support doing this.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!