Opened 4 years ago

Last modified 4 years ago

#16619 new defect

Pidgin Crashing when opened

Reported by: vauran Owned by: deryni
Milestone: Component: XMPP
Version: 2.10.11 Keywords:
Cc:

Description

Hey All,

One of my users is having issues with their Pidgin. When they try to open it, it crashes with "Program has stopped working". I have attached the debug.log file to this ticket.

Can you advise on what is wrong? I took a look through the debug but I don't know how to read it correctly to find the main issue.

Attachments (2)

debug.log (15.1 KB) - added by vauran 4 years ago.
debug.log file
pidgin.RPT (37.5 KB) - added by vauran 4 years ago.
pidgin.rpt file

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by vauran

debug.log file

comment:1 Changed 4 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

comment:2 Changed 4 years ago by vauran

  • Status changed from pending to new

This is on a Windows 7 machine. The documentation you linked me to shows me going to the TipsForBugReports page, which tells me to get the debug.log file, which I have attached to this ticket.

comment:3 Changed 4 years ago by datallah

  • Status changed from new to pending

You need to get a crash report (the What to do if Pidgin crashes section on that page).

Changed 4 years ago by vauran

pidgin.rpt file

comment:4 Changed 4 years ago by vauran

  • Status changed from pending to new

Attachment (pidgin.RPT) added by ticket reporter.

comment:5 Changed 4 years ago by vauran

Included the pidgin.rpt crash file. All dumps in it are the same and from today. Let me know what you find!

comment:6 Changed 4 years ago by vauran

Sorry - I lied. I just noticed it has multiple days in there. User said he only started having issues today.

comment:7 Changed 4 years ago by datallah

  • Status changed from new to pending

The crash is happening when the account disconnects, and by the looks of the crash report file, it's been happening for quite some time.

I haven't had a chance to dig into the code to try to track down the crash, but I think the new part of the behavior is likely because it's disconnecting immediately. Based on the debug log, my guess is that the immediate disconnection is related to the "Idle" settings (Tools->Preferences->Status/Idle).

comment:8 Changed 4 years ago by vauran

  • Status changed from pending to new

Hey,

Thanks for the help. Would there be a way to change that setting without using the GUI? It'll be hard to change it when it just crashes. We've tried reinstalling Pidgin multiple times. Would there be a file on the users PC that would be setting it to Idle that I need to remove before re-installing?

comment:9 Changed 4 years ago by datallah

You can use the "-n" command line argument to prevent automatic login on startup.

comment:10 Changed 4 years ago by vauran

Thanks, datallah.

Wonderful news! I was able to open pidgin with that command and navigate to Tools>Preferences>status/idle.

The user had "Status at Startup" checked with "Status to apply at startup:" set to offline. I'm assuming that this caused a loop with the bug you mentioned where it crashes when disconnecting. The user would log on, have their status set to offline, and would crash due to that.

I have since unchecked the Status at Startup option for the user and confirmed they can open and close Pidgin and connect to their account successfully.

Thanks for the quick help on this. Happy user = happy me :).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!