Opened 4 years ago

Closed 3 years ago

#16701 closed defect (cantfix)

Can't Connect to Facebook Account Any Longer

Reported by: rwb7868 Owned by:
Milestone: Component: Facebook
Version: 2.10.11 Keywords: connect
Cc: fainec, mattofe

Description

I'm unable to connect Pidgin to my Facebook account. It use to work fine, but in the last couple of days, it's stopped working entirely. When I got it working the first time, I used these instructions (http://www.howtogeek.com/howto/12527/easily-add-facebook-chat-to-pidgin/). I can't find anything using google that pertains to setting options changing.

Change History (11)

comment:1 Changed 4 years ago by mmcco

Facebook dropped XMPP support, which breaks our implementation. So, unless I'm missing another potential problem, this is expected.

That said, the new Facebook protocol is being (very diligently) implemented as a GSoC project, and it's already usable.

Last edited 4 years ago by mmcco (previous) (diff)

comment:2 Changed 4 years ago by jgeboski

While the GSoC project is only for purple3 as purple2 is maintenance only, I have back ported it as a third party plugin.

See: https://github.com/jgeboski/purple-facebook

comment:3 Changed 4 years ago by rwb7868

mmcco/jgeboski, thanks for the reply!

I'm not sure what is meant by 'purple3' and purple2' :-). Sorry, I'm still pretty new to pidgin. From the link posted, will I want to follow the instructions for 'building' on Windows or 'Installing' on Windows? Thanks ahead of time!

comment:4 Changed 4 years ago by jgeboski

Since you are asking, you will only want to follow the installation instructions. The build instructions are more geared towards developers.

comment:5 Changed 4 years ago by Guardian

I have opened an issue on GitHub? (https://github.com/jgeboski/purple-facebook/issues/11) but wanted to let you know that it keeps coming back with the error: Invalid HTTP response code (500)

comment:6 Changed 4 years ago by rwb7868

Followed the instructions, reopened Pidgin, and reconnected using Facebook (without XMPP). It worked. Thanks!

Last edited 4 years ago by rwb7868 (previous) (diff)

comment:7 Changed 4 years ago by Guardian

I am not sure why its working for some and not others but this morning after the error I already reported, I decided to click on re-enable after the error and it came with this: Error validating access token: Session does not match current stored session. This may be because the user changed the password since the time the session was created or Facebook has changed the session for security reasons. (452) which makes no sense given that the password is right and this is the first time I am setting it up, so there should be no conflict.

comment:8 Changed 4 years ago by virgo

#16712 has an error,that actually occurs.

comment:9 Changed 4 years ago by virgo

Anyway, it looks, that XMPP is still working, but Facebook server is responding in unexpected way.

comment:10 Changed 4 years ago by Robby

Ticket #16717 has been marked as a duplicate of this ticket.

comment:11 Changed 3 years ago by dx

  • Resolution set to cantfix
  • Status changed from new to closed

As of a few weeks ago it also fails in other non-libpurple clients. Can't do anything about that, closing.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!