Opened 4 years ago

Closed 3 years ago

#16806 closed defect (duplicate)

Please add Let's Encrypt root certificates

Reported by: Kromey Owned by: EionRobb
Milestone: Component: unclassified
Version: 2.10.11 Keywords:
Cc:

Description

Let's Encrypt is a new CA offering free, automated SSL certificates; the relative ease of their process (compared to, say, StartSSL's free certificates) means they should be seeing a lot of rapid growth.

Their root and intermediate certificates can be found here: https://letsencrypt.org/certificates/

(Note: This request is related to #16805, as IdenTrust currently cross-signs Let's Encrypt's intermediate certificates to make early adoption easier, however ultimately Let's Encrypt should stand on their own like any other CA.)

Change History (1)

comment:1 Changed 3 years ago by dx

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #16835.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!