Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#1776 closed enhancement (wontfix)

Irc enhancements

Reported by: roberth Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.0.2 Keywords:
Cc:

Description

I would like the ability prohibit pidgin from displaying irc messages, and the ability to make irc channel messages to with strong text or coloured. It would also be nice to see the ability to right click on users to do ops operations like kicking the user etc. The ability to see more info about the user on irc than the current info, information about the operating system(distro, kernel if linux or *BSD if *nix like os's is used by the user) hardware etc. this feature can be found on XChat for info.

Change History (6)

comment:1 Changed 12 years ago by elb

  • Resolution set to wontfix
  • Status changed from new to closed

There are a large number of individual issues here; I will attempt to address them to the best of my understanding.

  1. Prohibit Pidgin from displaying IRC messages.

I have no idea what this means.

  1. The ability to format IRC messages.

You can view bold, italics, colors, and underline with Pidgin IRC. Sending is not possible, and probably will not be; formatting on IRC is very poorly defined and not to be encouraged.

  1. Right-click to perform channel operations.

This is a duplicate of #264.

  1. Display various non-WHOIS information about the user in the user info display.

This requires support in the remote user's client, and (presumably) extended CTCP commands. We will not be adding this to the user info dialog; if you want particular CTCP commands, identify them and file a ticket. We have not concentrated on providing CTCP functionality as, again, it is a poorly designed and somewhat undesirable (from a cleanliness point of view) feature of IRC.

comment:2 Changed 12 years ago by roberth

  1. Prohibit Pidgin from displaying IRC messages.

Thats the messages that the irc servers are providing me when i log on to them.

  1. The ability to format IRC messages.

With this I mean to for example display the messages when user joins or leaves the channels with bold text, so it's easier to seperate those meesages from messages that other users in the chanell are sending to the channel, and other kinds of those messages etc.

  1. Display various non-WHOIS information about the user in the user info display.

What about take some code from XChat?

comment:3 Changed 12 years ago by elb

  1. Look at the IRC Helper plugin in the Purple Plugins pack from http://plugins.guifications.org/trac/downloads -- I think it will do what you want.
  1. They should already be bold.
  1. It's not about finding the code, it's about whether or not it's a good idea -- and it isn't.

comment:4 Changed 11 years ago by dandv

  1. It's not about finding the code, it's about whether or not it's a good idea -- and it isn't.

?? And what's wrong with enabling things like /ctcp <nick> time?

comment:5 Changed 11 years ago by rekkanoryo

CTCP is a poorly defined "protocol" and is not something we desire to implement fully. We implement only the absolute bare minimum we need to.

Anyone so inclined to implement CTCP support can do so in a plugin, as IRC is one of the few protocols on which plugins can inject data and read responses. This still remains as a "wontfix" ticket.

comment:6 Changed 11 years ago by elb

Also, note that this ticket isn't even about CTCP, and that I said specifically that if you want a specific CTCP command, you should file a ticket for it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!