Opened 10 years ago

Closed 10 years ago

Last modified 2 months ago

#19 closed task (fixed)

Rename libgaim to libpurple

Reported by: rlaager Owned by: elb
Milestone: 2.0.0 Component: libpurple
Version: 2.0 Keywords:
Cc: raifyy

Description (last modified by lschiere)

I suspect this is largely done at this point.

One thing that quite clearly remains: we install prpl plugins to $prefix/lib/libpurple/ but do not probe there.

Sean, are you able to look at this soon?

Change History (11)

comment:1 Changed 10 years ago by seanegan

  • Component changed from pidgin (gtk) to libpurple

comment:2 Changed 10 years ago by lschiere

  • Description modified (diff)
  • Owner changed from rlaager to seanegan

comment:3 Changed 10 years ago by seanegan

That doesn't sound right.

We've been installing and probing libpurple for weeks now. If you tested it this morning, you may have been hit by the fact that I changed the #define to PURPLE_PLUGINS but configure.ac was still defining GAIM_PLUGINS.

This was fixed with my commit where I was surprised --disable-plugins still worked.

comment:4 Changed 10 years ago by lschiere

my fault for jumping to false conclusions. It works now. I'd guessed that the libpurple directory was new because I found it there when I started trying to figure out why my prpls were not loading.

comment:5 Changed 10 years ago by bjoernv

There are still some filenames with "Gaim".

In the source tree:

$ find . -name '*gaim*'
./gaim-uninstalled.pc.in
./libpurple/gaim-compat.h
./libpurple/dbus-gaim.service
./pidgin/plugins/gaiminc.c
./gaim.pc.in
./gaim.service.in

In the install tree:

$ find . -name '*gaim*'
./include/libpurple/gaim-compat.h
./lib/gaim
./share/dbus-1/services/gaim.service
./share/pixmaps/gaim

comment:6 Changed 10 years ago by elb

Also, tcl stuff.

comment:7 Changed 10 years ago by seanegan

  • Owner changed from seanegan to elb

Ethan, is tcl fixed?

comment:8 Changed 10 years ago by elb

  • Resolution set to fixed
  • Status changed from new to closed

Looks like it is. I'm going to close this! :-)

comment:9 Changed 10 years ago by datallah

What about gaim.pc.in and gaim-uninstalled.pc.in?

comment:10 Changed 10 years ago by seanegan

Those are for compatibility. Old Gaim plugins that will depend on the gaim-compat headers can locate them with gaim.pc

-s.

comment:11 in reply to: ↑ description Changed 2 months ago by damiannosgda

Replying to rlaager:

I suspect this is largely done at this point.

One thing that quite clearly remains: we install prpl plugins to $prefix/lib/libpurple/ but do not probe there.

Sean, are you able to look at this soon?

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!