Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#1996 closed defect (fixed)

msimprpl 0.7 crashes when logging in with invalid email address, invalid cast from GtkEventBox to GtkButton

Reported by: jeff Owned by: jeff
Milestone: Component: libpurple
Version: 2.0.2 Keywords: msimprpl
Cc: john.l.sandmeyer@…

Description

From John Sandmeyer:

I have discovered an error in the MySpaceIM protocol library involving logging in. The sending of an invalid e-mail address (I just changed mine, but forgot to change it in Pidgin) causes Pidgin to crash due to an invalid cast from GtkEventBox? to GtkButton?. I have attached a screenshot of the debug window after Pidgin crashed (sorry it's faded, Vista does that). I'm not sure if you already know about this, I'm still getting used to Pidgin's new website.

Attachments (1)

msimfail.JPG (76.3 KB) - added by jeff 9 years ago.
crash debug log on Vista from John Sandmeyer, obscured email

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by jeff

crash debug log on Vista from John Sandmeyer, obscured email

comment:1 Changed 9 years ago by jeff

  • Status changed from new to assigned

Might be a duplicate of #1990.

comment:2 Changed 9 years ago by jeff

  • pending changed from 1 to 0

comment:3 Changed 9 years ago by jeff

  • pending changed from 1 to 0

comment:4 Changed 9 years ago by jeff

I fixed a couple of bugs in msimprpl on Windows (tested on XP). John, does 0.9 from http://msimprpl.darkthoughts.net/ still exhibit this bug on Vista?

comment:5 Changed 9 years ago by jeff

  • pending changed from 0 to 1
  • Resolution set to fixed
  • Status changed from assigned to closed

Haven't had any reports about this in >1 month, closing as fixed with the new changes to msimprpl. Feel free to re-open if you still experience this problem.

comment:6 Changed 5 years ago by Robby

  • Milestone 3.0.0 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!