Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#2113 closed defect (worksforme)

Scrolling using the mouse wheel doesnt work

Reported by: dave1g Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.0.2 Keywords: scroll
Cc:

Description

Attempting to scroll a conversation window using the mouse wheel or the scroll section of a touch pad doesn't work, though with the touch pad you are shown the icon that says scrolling should be occurring. Tried to screenshot it, but the icon doesn't appear in the screenshot.

Change History (7)

comment:1 Changed 12 years ago by datallah

A "real" scroll wheel should work just fine, there have been a few reports of "fake" scrollwheels (like the scroll section of a touch pad) not working. According to a recent email to the development mailing list, this happens with all GTK+ programs, not just Pidgin.

That said, when I just tested this on my laptop it worked fine.

comment:2 Changed 12 years ago by dave1g

hmm yeah, i assumed it was all scroll wheels, but i have only tested with my laptop touchpad.

comment:3 Changed 12 years ago by datallah

  • Resolution set to worksforme
  • Status changed from new to closed

This isn't something that pidgin itself handles, either GTK+ or the driver is to blame.

comment:4 Changed 12 years ago by dave1g

ok, filed a bug report with GTK+ team

http://bugzilla.gnome.org/show_bug.cgi?id=480477

comment:5 Changed 11 years ago by datallah

Ticket #7069 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by tahonermann

I finally discovered that the Synaptic driver can be configured to send different types of messages depending on the class name of the target window. The file for configuring this is named 'tp4table.dat' (perhaps 'tp4scrol.dat' depending on the version of the driver). On my system, this file is installed in 'C:\Program Files\Synaptics\SynTP'. To determine the installation location, open 'Device Manager', right click on 'ThinkPad? UltraNav? Pointing Device', and select 'Properties'. Click on the 'Driver' tab and select 'Driver Details...'

I added the following lines to my 'tp4table.dat' file:

; GTK+ *,*,*,gdkWindowTopLevel,*,gdkWindowChild,WheelStd?,0,9

A reboot is required for the changes to take affect (or, you can terminate the 'SynTPEnh.exe' process in Task Manager and restart it from the installation location)

Scrolling now works for me - most of the time anyway. Sometimes, I need to drag the scroll bar briefly before scrolling with the touchpad/trackpoint works correctly - I'm not sure why, seems to me likely to be a problem in Pidgin or GTK+ (I'm using GTK+ 2.12.6 - ancient, I know)

comment:7 Changed 8 years ago by mindelirium88

Under Windows the Synaptics Driver can emulate a scroll wheel by things like a scroll bar at side or double finger scroll depending on which driver is being used. This does not however seem to work under Pidgin even though a small graphic indicating scrolling pops up. While searching for a similar problem with a different program I came across this solution which seems to be a fix for Pidgin as well.

"the Synaptics touchpad driver which is very common; so most laptop users probably do as well. The problem is with the actually little graphic that pops up that shows the "scrolling" graphic. For some reason, certain programs don't play well with the Synaptics drivers when they pop up that little graphic and therefore they do not scroll (pretty ironic, isn't it).

To turn off this graphic (and fix scrolling) do this:

Edit the registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor??"=dword:00000000

Just add this to registry. Either copy-paste the above text into Notepad, save it as a

.reg file and run it, or manually add it using RegEdit?? (on my system, this value didn't exist, so I had to create it manually). Afterwards, restart SynTPEnh.exe and SynTPHelper.exe (use TaskManager?? to kill them, then restart them from the Synaptics installation folder, which is usualy

C:\Program Files\Synaptics\SynTP). Or simply restart your system.

Problem solved and even better it gets rid of the annoying graphic that pops up every time you scroll."

So basically you open up RegEdit??, travel to "HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh" in the left tree and once there right-click and select New>DWORD (32-bit) Value and name it UseScrollCursor??.

Then right-click the new key, select modify, and enter the value 00000000 making sure that Hexademical is selected as the base data.

Bring up the task manager (ctrl+alt+del) and end the process SynTPEnh.exe and SynTPHelper.exe. Then restart SynTPEnh.exe which should be located under C:\Program Files\Synaptics\SynTP (Alternatively to entire paragraph, you can just restart the computer)

Scrolling by touchpad should now function though the graphic that indicates/gives a visual cue of scrolling is now disabled.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!