Opened 12 years ago

Closed 11 years ago

#2285 closed defect

Crashes on clicking on a hyperlink in RHEL4

Reported by: snesreviews Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.0.2 Keywords: pango_default_break
Cc:

Description

Nice software but...

Compiled from source, 2.02, start up in debug mode and when I click on a hyperlink, it crashes with this error. This also happened in previous versions including going back to the gaim days:

(14:10:30) g_log: file break.c: line 780 (pango_default_break): assertion failed: (IN_BREAK_TABLE (break_type)) Aborted

Cheers, Frank

Change History (3)

comment:1 Changed 11 years ago by jjoyce

I hit this same bug on version 2.3.1 which I just compiled from source using all the defaults. The problem is not with clicking on a link. It appears to be a tooltip problem.

If I hover over the URL for more than about 0.5 second, it crashes with the pango message previously mentioned. If I quickly move over the URL and click and then quickly move off, the URL opens in the browser and it doesn't crash. If I click on the URL and then hover there, it crashes (presumably when it would have opened the tooltip).

I tried setting tooltip_delay to a huge value in the prefs.xml but that didn't seem to help. The problem happens both in IRC and Y!M sessions. It also happens when I run older versions of pidgin and gaim.

strace output from right before the crash:

stat64("/usr/lib/pango/1.4.0/modules/pango-hangul-fc.so", {st_mode=S_IFREG|0755, st_size=11696, ...}) = 0 open("/usr/lib/pango/1.4.0/modules/pango-hangul-fc.so", O_RDONLY) = 11 read(11, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240\n\0"..., 512) = 512 fstat64(11, {st_mode=S_IFREG|0755, st_size=11696, ...}) = 0 mmap2(NULL, 10216, PROT_READ|PROT_EXEC, MAP_PRIVATE, 11, 0) = 0xb67d2000 mmap2(0xb67d4000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 11, 0x2) = 0xb67d4000 close(11) = 0 mmap2(NULL, 233472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb6799000 munmap(0xb6799000, 233472) = 0 write(2, "\nPango-ERROR : file break.c: l"..., 123) = 123 rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0 kill(11502, SIGABRT) = 0 --- SIGABRT (Aborted) @ 0 (0) ---

I'm on gentoo version... uh... I'm on gentoo.

/JJ

comment:2 Changed 11 years ago by datallah

  • pending changed from 0 to 1

This is a pango issue.

If you GetABacktrace, we might be able to make a suggestion.

comment:3 Changed 11 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!