Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2367 closed defect (wontfix)

UI spaces wasted with duplicated information

Reported by: andrixnet Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.1.0 Keywords: duplicate information UI design
Cc: Dawudd

Description

The new Pidgin 2.1.0 shows a different arrangement of the conversation window.

IMHO, it was a less inspired design choice.

Let me explain, and refer to the attachement screenshot.

  • Area [1a] is the tab which displays the buddy name and an icon related to his/her availability. Perfect.
  • Area [1b] is a waste of screen area, repeating the exact same information as the tab button, with some (more or less needed/welcome) additions, that is the status text (which can be seen in the buddy list, and IMHO, it being displayed in the conversation window should be the job of a plugin) and the buddy icon, displayed very small.

One thing that I liked about GAIM/PIDGIN was that the buddy icon was shown in it's full size in a very well designed place, no clutter in the conversation window. It was really good. Not any more in 2.1.0.

  • Area 2: the buddy icon. it is displayed small. too small. I can't make it be shown full size. (I do not count the tooltip that shows the image full size, since the tooltip is not permanently displayed).

Also, related:

  • while hovering the mouse over the area [1b] (anywhere in it's width) I get a tooltip which shows, ... again ... the same information. Only the avatar is full size and the protocol icon is shown.
  • while hovering the mouse over the area [1b], the said tooltip is shown, BUT NOT if the mouse is right over the avatar image in the far right.

Please, restore the Pidgin conversation window UI. The placement of the avatar, full size, on the side of the text entry area was a superb choice.

Attachments (2)

ui.jpg (39.3 KB) - added by andrixnet 12 years ago.
pidgin201gui.jpg (113.5 KB) - added by Apewall 12 years ago.
Pidgin 2.0.1 GUI

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by andrixnet

comment:1 Changed 12 years ago by seanegan

  • Resolution set to wontfix
  • Status changed from new to closed

There is no screenshot attached, but I can use my imagination ;)

1a. I preferred there not to be a status icon in the tab, as it allows you to fit more tabs in a window. See http://pidgin.im/~seanegan/images/infopane2.png I was vetoed as being a freak who keeps too many conversations open.

1b. You can turn it off if you feel the information is a waste; many people will disagree with you. It shows slightly different information, more information, and in a more consistent way. I find the status message to be useful there.

  1. The buddy icon previously was shown too large in a very poorly designed place. It took room away from the entry area, and generally forced it to be larger than you would typically want it. It would overlap off the screen when you sized things yourself. It was inconsistent and ugly. I see little reason to take up to 96 pixels square to persistantly show someone's buddy icon; I'd consider *that* a waste of UI space.

You are correct that the tooltip should be shown when hovering over the buddy icon; that's a bug that will be fixed for 2.1.1.

Your complaint seems to boil down to the fact that you prefer 96 pixels (I assume you're a Yahoo or MSN user where 96px is the standard size, as you think 32px is too small) to occupy room at the bottom-left instead of 32px in the upper right. This seems largely a matter of preference.

Pidgin users are not hesitant to complain about UI changes, and that these changes have allowed me to close more bugs about the old UI than have spawned new bugs about the new UI indicates to me that they are a net positive.

comment:2 Changed 12 years ago by andrixnet

The screenshot is there, but it took about 2 retries because Trac complained about timeout connecting to the database. So it probably got uploaded after you read the report.

I agree, http://pidgin.im/~seanegan/images/infopane2.png IMHO is indeed better. (the single status icon really makes a difference).

1b. Please, how can I turn it off? I explored all the options in the menu and in the context menu and found nothing. If it's in the prefs, sorry, I can't find it, Pidgin crashes opening the prefs and the suggested workaround doesn't work. :(

  1. actually, I loved gaim/pidgin for showing the full size 96 pixel avatar on Yahoo. (yes, i mainly use Yahoo). I also loved the place where it was displayed, as for me, it occupied the least amount of space. I often write multiline messages, so the large text entry area is an advantage also.

I'd like to request a way of selecting how the avatar is shown. The official Yahoo client offeres an option to show the avatar small or full size (96x96). For me, it gives more personality to the buddy I am talking to. Please. (and I admit, mainly because of this, I will be reverting back to 2.0.2, for now...)

comment:3 Changed 12 years ago by seanegan

Tools > Preferences > Conversations > Show Buddy Details

comment:4 Changed 12 years ago by andrixnet

Now that I got the prefs working (thanks, Daniel), I found it.

But with that details bar goes the avatar as well :(

Changed 12 years ago by Apewall

Pidgin 2.0.1 GUI

comment:5 Changed 12 years ago by Apewall

I've uploaded an example at http://developer.pidgin.im/attachment/ticket/2367/pidgin201gui.jpg to explain my own concerns relative to this ticket's description.

Mainly it seems like there is much concern lately with different GUI features.

As I explained in the uploaded image, there are many unused spaces now, and the "shortening" of the toolbar buttons I believe could have been avoided by better utilization of the space(Removing the text and replacing them with the old/more icons to do various functions.)

While it is easy to say that "People who use large icons such as 96x96 will ofcourse complain." the icons have been sized down much too far to make out what the pictures are supposed to represent.

There is little need to display a notice showing that a user you are talking to is online, when clearly the tab already displays that information in the same panel.

I would much prefer having options to control the GUI of pidgin, but that currently is not the development design, each user has their own depiction of what they believe their gui should be.

comment:6 Changed 12 years ago by seanegan

Thank you, Apewall.

First, it's a guy with a gun pointing at the camera.

If you couldn't tell that, you could hover over the pane to see a full-sized image. I'm a bit concerned that you feel a need to constantly have an at-least 64x64 pixel gun pointed at your face. :)

The icon was chosen to be the same size as it is in the buddy list. In fact, you'll note the entire new infopane was modeled to exactly resemble the buddy list entry. Clever!

Second, the areas marked "wasted space" are wasted only because you've stretched the window wider than it needs to go. The menu bar at top and the toolbar are approximately the same size, by design. This sets a reasonable minimum/default window width. *Lots* of people do indeed like their window that narrow; something that was near impossible with the previous design.

You're correct that the icon is redundant. My solution was to remove the status icon from tabs, which has the added bonus of making room for more tabs (see the above-posted link). People yelled bitterly at me. It's not a huge deal, and people who don't use tabs benefit from it (it's not redundant to them).

I'm not sure why the descriptions would be better in tooltips. Tooltips are an extra step (which new-toolbar haters claim is bad) AND more wasted space.

If you wish to continue this debate, please move it to devel@… as this ticket has been closed and is not an appropriate place to debate UI.

comment:7 Changed 12 years ago by brettalton

Just noting that I made a GUI suggestion here: http://developer.pidgin.im/ticket/3135 relating to using 96px avatars and it was rejected as well.

It was also said that my ticket was similar to this ticket's complaint: http://developer.pidgin.im/ticket/2478

I'll join the devel mailing list and discuss it there.

Thank you.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!