Opened 12 years ago

Closed 12 years ago

#2380 closed enhancement (duplicate)

don't like current conversation window

Reported by: biji Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.1.0 Keywords: buddy icon
Cc:

Description

Hi! just compiled 2.1.0, i love it

but I don't like current conversation window because buddy icon is small.. I like previous one with buddy icon displayed big in bottom left

Attachments (1)

297537870.jpg (1.2 KB) - added by dino 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by fpletz

seconded, 2.1.0 is nice, but the new conversation window looks strange

comment:2 in reply to: ↑ description Changed 12 years ago by dino

Replying to biji:

Hi! just compiled 2.1.0, i love it

but I don't like current conversation window because buddy icon is small.. I like previous one with buddy icon displayed big in bottom left

ack. IMO the place is ok but its a bit small, indeed.

Just some /dev/urandom thoughts (on the new window):

  • Replace the second/new status icon with a protocol icon
  • maybe merge the "send to" menu with the new display
  • If only one tab is open don't show it at all. With the new display of the nick (maybe add the alias then) imo its not necessary

comment:3 follow-up: Changed 12 years ago by deryni

1) I believe that was discussed and that a display of the protocol icon was intended, I'm not sure what happened to that. 2) Also discussed and was actually sort of done, the infopane right-click menu does include the Send To menu, but as long as the infopane is optional the menubar Send To item sort of has to stay (and no having it appear and disappear isn't really a good idea, though we could entertain disabling it when the infopane is active but I think that would be confusing). 3) This was done in the development code for a while, most of us found the jumping around of the widgets in the window too annoying, also it meant you couldn't continue clicking the tab X to close all the tabs (something I do on occasion).

So A+ for effort and for being willing to discuss but unfortunately not of much use in the end.

As to the size of the buddy icon, I am really amazed that people think it is too small to identify, I never would have guessed people really wanted 96x96 (give or take) icons staring at them all the time. I'm not sure if the size will change but the new conversation window isn't set in stone yet.

comment:4 in reply to: ↑ 3 Changed 12 years ago by dino

Replying to deryni:

1) I believe that was discussed and that a display of the protocol icon was intended, I'm not sure what happened to that.

Would be interesting to know 0:-)

2) Also discussed and was actually sort of done, the infopane right-click menu does include the Send To menu [...]

Hm, maybe right-clicking could shortcut this? :)

3) This was done in the development code for a while, most of us found the jumping around of the widgets in the window too annoying, also it meant you couldn't continue clicking the tab X to close all the tabs (something I do on occasion).

I cant do this anyway, since the tab size changes with every tab added or deleted! (would be nice if they would stay the same size ... yes)

As to the size of the buddy icon, I am really amazed that people think it is too small to identify, I never would have guessed people really wanted 96x96 (give or take) icons staring at them all the time. I'm not sure if the size will change but the new conversation window isn't set in stone yet.

Since some protocols allow much bigger once some think much more detail is possible to recognize. Especially xmpp (may be server depended?) seems to allow bigger images than others. I'll attach some examples :p Maybe there could be some mouse hover effects, but it would be ugly if the hole infopane resizes and overlapping widgets aren't to easy to create with gtk IIRC.

Changed 12 years ago by dino

comment:5 follow-up: Changed 12 years ago by deryni

The infopane already has a right-click menu, making Send To the left-click action was discussed and might happen but some people have felt that would be confusing.

With side tabs the close tab button location doesn't change, and with full width tabs it doesn't much either assuming you are closing from the end (though it does now with the single unstretched tab stuff).

Hovering over the infopane does show you the full-size icon I believe (the fact that hovering over the icon itself doesn't is a bug and will be fixed).

Have I missed or failed to cover any of your comments/criticisms?

comment:6 Changed 12 years ago by sturmfeder

Hey, I like the new layout, especially the dropdowns for Font etc.

I would love to be able to see a bigger buddy icon, it's not just for identifying, but for seeing pictures in a quick way "see, this is what I look like now" (especially with friends on different continents, when you don't always want to send pictures as files but just take a short look) It doesn't matter to me where, but I would prefer down below where you enter the text so it doesn't create a larger blank space area.

Keep up the good work, thanks :)

comment:7 in reply to: ↑ 5 Changed 12 years ago by rageboy

Replying to deryni:

<snip>

Hovering over the infopane does show you the full-size icon I believe (the fact that hovering over the icon itself doesn't is a bug and will be fixed).

I just noticed something about this. For animated buddy icons, the only place they animate is in the infopane, which means no one can ever see a full sized animation. I'm willing to say icons should animate in mouseovers, but I don't know how possible this is.

Have I missed or failed to cover any of your comments/criticisms?

comment:8 Changed 12 years ago by seanegan

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #2478

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!