Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2467 closed defect (duplicate)

Message Window Resizes Horizontally and Vertically

Reported by: inko9nito Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.1.0 Keywords: im message window resize horizontally vertically
Cc:

Description

I like to make my IM windows as small as possible to save space on my desktop, but since I installed the new version of pidgin, it makes the windows grow Both - vertically and horizontally.

The horizontal resize happens when the buddy starts typing back to you. The window needs more space to display the "buddy is typing" icon.

So, is there a way to squeeze the "conversation," "options," and "send to" menus so that the "buddy is typing" icon appears without resizing the window? Or just make that icon smaller?

The vertical resize happens when you type a lot in the input box. It resizes the window first, and then if you keep typing it adds the scroll bars.

Why can't it just show the scroll bar from the beginning when your message exceeds 3 lines instead of growing the window first, and then showing the scrollbar? Maybe some people love this feature but this (and the horizontal resize) was enough to make me downgrade to the previous version. So, for those who like this, can't there be an option to enable or disable the window resizing?

Both these things are extremely annoying. I attached a screenshot with the 3 "stages" the window goes through.

Attachments (1)

window_resize.gif (22.7 KB) - added by inko9nito 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by inko9nito

comment:1 Changed 12 years ago by seanegan

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2394 (vertical) and #2274 (horizontal)

comment:2 Changed 12 years ago by inko9nito

#2394 is about just the input area resizing, that happened back in the previous release as well. What I'm talking about is the window itself resizing.

#2274 has nothing to do with what I'm talking about. The guy is talking about the line being there all the time. I'm talking about the width of the window changing when the buddy starts typing.

comment:3 follow-up: Changed 12 years ago by seanegan

Sorry, the tickets mean more to me than is necessarily evident in the title and summary.

The input auto-resizing will be worked on until it's perfect. That's the purpose #2394 is serving right now.

The typing indication will move from an icon in the menu to a line of text in the message display. That's hwat #2274 refers to.

These, combined, will fix your problems.

comment:4 in reply to: ↑ 3 Changed 12 years ago by inko9nito

Replying to seanegan:

The typing indication will move from an icon in the menu to a line of text in the message display. That's hwat #2274 refers to.

That's how Google talk has it. That's a great idea. Thanks :)

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!