Opened 12 years ago

Closed 12 years ago

#2468 closed defect (duplicate)

Pidgin 2.1 crashes every time on "View Log"

Reported by: EdOfTheFu Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.1.0 Keywords: crash, log
Cc:

Description

It occurs when I right click on the buddy in the buddy list and click view log as well as when I select View Log in the menu in the conversation window.

This is the pidgin.RPT file:


Error occured on Tuesday, August 7, 2007 at 20:37:13.

C:\Program Files\Pidgin Debug\pidgin.exe caused an Access Violation at location 65283497 in module C:\Program Files\Pidgin Debug\plugins\log_reader.dll Writing to location 00000000.

Registers: eax=00000000 ebx=01e08d68 ecx=652872f8 edx=00ccb470 esi=01e08d68 edi=00d0ba50 eip=65283497 esp=0022e950 ebp=0022e998 iopl=0 nv up ei pl nz na pe nc cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010202

Call stack: 65283497 C:\Program Files\Pidgin Debug\plugins\log_reader.dll:65283497 trillian_logger_read c:/devel/pidgin-devel/pidgin-2.1.0/libpurple/plugins/log_reader.c:1430 65283E0E C:\Program Files\Pidgin Debug\plugins\log_reader.dll:65283E0E trillian_logger_size c:/devel/pidgin-devel/pidgin-2.1.0/libpurple/plugins/log_reader.c:1712 67CDE36D C:\Program Files\Pidgin Debug\libpurple.dll:67CDE36D purple_log_get_total_size c:/devel/pidgin-devel/pidgin-2.1.0/libpurple/log.c:238 64A882BA C:\Program Files\Pidgin Debug\pidgin.dll:64A882BA pidgin_log_show c:/devel/pidgin-devel/pidgin-2.1.0/pidgin/gtklog.c:719 64A477BA C:\Program Files\Pidgin Debug\pidgin.dll:64A477BA gtk_blist_menu_showlog_cb c:/devel/pidgin-devel/pidgin-2.1.0/pidgin/gtkblist.c:517 62743935 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62743935 g_closure_invoke 62756FB5 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62756FB5 g_signal_has_handler_pending 62757D5E C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62757D5E g_signal_emit_valist 62757FD6 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62757FD6 g_signal_emit 6069C2A5 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:6069C2A5 gtk_widget_activate 6058C71C C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:6058C71C gtk_menu_shell_activate_item 6058CA25 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:6058CA25 gtk_menu_shell_activate_item 60578E62 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:60578E62 gtk_marshal_VOIDUINT_STRING 62743935 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62743935 g_closure_invoke 62756BE6 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62756BE6 g_signal_has_handler_pending 62757ABC C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62757ABC g_signal_emit_valist 62757FD6 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll:62757FD6 g_signal_emit 6069C434 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:6069C434 gtk_widget_activate 60576011 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:60576011 gtk_propagate_event 605772FD C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:605772FD gtk_main_do_event 6B070C5E C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll:6B070C5E gdk_event_get_graphics_expose 672DEA67 C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll:672DEA67 g_main_context_dispatch 672DFF3B C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll:672DFF3B g_main_context_acquire 672E011A C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll:672E011A g_main_loop_run 6057686E C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll:6057686E gtk_main 64A890D7 C:\Program Files\Pidgin Debug\pidgin.dll:64A890D7 pidgin_main c:/devel/pidgin-devel/pidgin-2.1.0/pidgin/gtkmain.c:884 0040209B C:\Program Files\Pidgin Debug\pidgin.exe:0040209B WinMain? c:/devel/pidgin-devel/pidgin-2.1.0/pidgin/win32/winpidgin.c:638 0040249A C:\Program Files\Pidgin Debug\pidgin.exe:0040249A WinMain? c:/devel/pidgin-devel/pidgin-2.1.0/pidgin/win32/winpidgin.c:246 00401247 C:\Program Files\Pidgin Debug\pidgin.exe:00401247 004012B8 C:\Program Files\Pidgin Debug\pidgin.exe:004012B8 7C816FD7 C:\WINDOWS\system32\kernel32.dll:7C816FD7 RegisterWaitForInputIdle?

Change History (2)

comment:1 Changed 12 years ago by QuLogic

Dupe of #2349, I think. Or see #2458, too.

comment:2 Changed 12 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!