Opened 12 years ago

Closed 12 years ago

#2489 closed task (invalid)

Pidgin 2.1.0 has a problem with filetranfers.

Reported by: vasa Owned by: MarkDoliner
Milestone: Component: libpurple
Version: 2.1.0 Keywords: AIM Express file transfer failed
Cc:

Description

The problem is: (description of a problem) When a user A who uses AIM express, sending the file to another user B who uses Pidgin 2.1.0 the following occurs: user B receive file full, but user A will receive an error message "Transfer failed"

Change History (4)

comment:1 Changed 12 years ago by mirya

There was a discussion in in devel@…, Lukas Barth (tinloaf) pointed to his patch (http://developer.pidgin.im/attachment/ticket/365/purple_multifiles.diff-annotated), where setting conn->xferdata.flags to 1 might help. It didn't though, also tracing AIM6.1 AOL client responses has shown that they set this field to 0x20 or 0x24 (no idea what each means). Trying to do the same at the pidgin side didn't help though, so either there're more "special" fields in OftFrame? to set or another frame is sent additionally. I'll continue digging, if someone knows something I dont, plz. but a tip here.

comment:2 Changed 12 years ago by mirya

Just checked out Miranda AIM for the same bug, it works well in the trunk version, e.g. AIM Express doesn't complain about failed file transfers (ensure its OSCAR plugin is of 0.0.0.7 version, look at /miranda/protocols/AimOscar/aim.cpp, #define AIM_OSCAR_VERSION "\0\0\0\x07").

Digging their code led me to /miranda/protocols/AimOscar/file.cpp, last lines of it (starting at "ft.type=_htons(0x0204);", they do not like spaces :). They're calculating some file checksum ("ft.recv_checksum=_htonl(aim_oft_checksum_file(file));"), looks like the one libpurple OSCAR calculates for resumed file transfers, but not when uploading is done.

comment:3 Changed 12 years ago by MarkDoliner

  • Owner set to MarkDoliner
  • Status changed from new to assigned

comment:4 Changed 12 years ago by MarkDoliner

  • Resolution set to invalid
  • Status changed from assigned to closed

AIM Express doesn't support file transfers.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!