Opened 12 years ago

Last modified 6 years ago

#2500 new defect

XMPP screen names with @ symbol

Reported by: mtthw.cmpbll Owned by: deryni
Milestone: Component: XMPP
Version: 2.5.8 Keywords:
Cc:

Description

I am currently trying to log into a internal corporate jabber server, and the username we use is our work email. When I try to create an XMPP account in Pidgin, I type 'mcampbell@…' and fill in the rest of the details (including domain, which is the specific computer name that hosts the jabber server, we'll call it 'jabberserver'). Now, when I save and try to connect, I find that Pidgin has split my username at the @ symbol and appended the rest of it onto the beginning of the domain. I end up with Pidgin trying to connect with username 'mcampbell' to domain 'work.com@jabberserver'. I came across the mailing at http://pidgin.im/pipermail/devel/2007-July/002131.html which states the correct way to escape the @ symbol in a user name is '\40', but using 'mcampbell\40work.com' as my username returns a not authorized error. In trying to find my way to a solution, it seems like there is an awful lot of confusion as to the XMPP/Jabber account creation area, and I hate to add to it - I just don't understand why you're splitting my username when there's a domain box provided. I'm sure there are people who prefer it both ways, but do one or the other and not both. That said, is there actually a way to use an email address or other username with an @ symbol?

I'm using Pidgin 2.1.0 on Windows XP Profressional.

Change History (13)

comment:1 Changed 12 years ago by rekkanoryo

  • Resolution set to invalid
  • Status changed from new to closed

Put mccampbell in the screen name field, company.com in the domain field, then go to the Advanced tab and put jabberserver in the Connect Server field.

Screen name and Domain refer to the components of the Jabber ID.

comment:2 Changed 12 years ago by mtthw.cmpbll

This did not solve the problem.

I have a second user account on the same jabber server with a screen name of 'matt_campbell'. Using that as the screen name field and 'jabberserver' in the domain field, Pidgin connects fine.

Following the instructions provided, with 'mcampbell' as my screen name, 'company.com' as the domain, and 'jabberserver' as the advanced>>server, I receive a Not Authorized error. In the debug window, I see this configuration seems to end up with a JID of 'mcampbell@…/spark'. Using another XMPP IM client, I can view my client information and my JID is 'mcampbell@…@jabberserver/spark'. If the server admin set up my account with a username containing an @ symbol, Pidgin doesn't seem to be able to accommodate that.

The server is Jive Software's OpenFire XMPP server, not sure which version.

As a side note, I'm a software developer and would love to dig around in the code if there was indeed a bug. But this simply seems to be a functionality problem to me. With two text boxes (one for the screen name and one for the domain), there doesn't seem to be any reason for parsing the screen name textbox for @ signs and moving that portion to the domain box. If I put 'mcampbell@…' in the screen name box and jabberserver as the domain, that's what I want my screen name and domain to be.

comment:3 Changed 12 years ago by rekkanoryo

  • Resolution invalid deleted
  • Status changed from closed to reopened

Given comment:2, I'm going to reopen this ticket. I'm assigning this to nwalp, as he stated that the @ should be handled properly (i.e. correctly escaped) in the username field. This may be a simple matter of OpenFire not correctly handling an escaped @ in the node portion of the JID.

comment:4 Changed 12 years ago by rekkanoryo

  • Owner set to nwalp
  • Status changed from reopened to new

comment:5 Changed 12 years ago by nwalp

  • Owner changed from nwalp to deryni

etan, i'm gonna let you take a crack at this, since I've largely been ignoring the issue, and you seemed to be on top of it.

comment:6 Changed 12 years ago by seanegan

  • Component changed from pidgin (gtk) to XMPP

comment:7 Changed 10 years ago by bernmeister

Is this issue still happening in Pidgin 2.5.8?

comment:8 Changed 10 years ago by darkrain42

  • Version changed from 2.1.0 to 2.5.8

AFAIK, yes.

comment:9 Changed 10 years ago by MarkDoliner

Someone on the Pidgin mailing list said he used /40 in place of @ and that worked for him.

Is this really something we would want to do automatically? RFC3920 says that both @ and / are prohibited characters in the node.

comment:10 Changed 10 years ago by darkrain42

Ticket #7058 has been marked as a duplicate of this ticket.

comment:11 Changed 10 years ago by darkrain42

I think to fix this, we'd need to implement support for XEP-0106 in order to escape the username as its set in the account dialog. The escape character is '\', not '/'.

(see the ticket I just duped to this one)

comment:12 Changed 9 years ago by darkrain42

Ticket #11734 has been marked as a duplicate of this ticket.

comment:13 Changed 6 years ago by notphilipfry

this is non-trivial

"@" are also included in XMPP roster entity when using XMPP server gateway/transport to other IM services

XEP-0100

see also: http://spectrum.im/

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!