Opened 12 years ago

Closed 11 years ago

#2525 closed defect (fixed)

idle reporting based on keyboard and mouse doesn't work

Reported by: Luigiwalser Owned by: seanegan
Milestone: Component: pidgin (gtk)
Version: 2.1.0 Keywords:
Cc:

Description

Pidgin is reporting that I have been idle for 45 hours, but I have spent many of those hours using the computer, and of course I'm not idle right now.

I don't think this bug is new, because people were reporting problems with my idle times even on the 2.0.0betas. Problems have persisted through 2.0.2 and 2.1.0.

Change History (8)

comment:1 Changed 12 years ago by Luigiwalser

My idle time was up to like 67 hours, and then I sent someone an IM and my idle time went back to zero.

It appears my idle time was reporting how long it'd been since I'd sent an IM. I had changed statuses during the 67 hours but that didn't affect it. So even though I do have it set to report based on keyboard and mouse activity, it looks like it was only going on sending IMs.

comment:2 Changed 12 years ago by seanegan

  • Milestone set to 2.1.2
  • Owner set to seanegan
  • Status changed from new to assigned

comment:3 Changed 12 years ago by cong06

This isn't so much a bug as a very inconvenient missing feature.

The feature is there in Windows, not quite sure why it's not in the Linux version...

(I use Ubuntu 7.04)

comment:4 Changed 11 years ago by dave1g

There seem to be a lot of problems with idle... some the exact opposite of each other (stuck in idle, vs never getting to idle) My problem is the stuck in idle forever one. CCing all to keep track.

#2002 #2525 #2681 #5825 #5853 #5967 #6041

comment:5 Changed 11 years ago by dave1g

My issue in #5825 seems to be fixed with 2.4.3. Everyone on this ticket should report whether 2.4.3 has fixed or not fixed the issue for them.

comment:6 Changed 11 years ago by Sim-on

  • pending changed from 0 to 1

This seems to be very old ;) Is this still a problem, Luigiwalser?

comment:7 Changed 11 years ago by Luigiwalser

  • pending changed from 1 to 0

The original bug as I reported it did get fixed at some point, I even remember seeing in the ChangeLog where it was fixed. I'm sorry that I neglected to update this bug at that time.

Probably not the exact same bug, but similar in that sometimes I get stuck in idle again, but I am experiencing it again right now with 2.4.2.

I'll have to upgrade to 2.4.3 and give it some time to see if it has been fixed again.

comment:8 Changed 11 years ago by Sim-on

  • Resolution set to fixed
  • Status changed from assigned to closed

OK. Thanks for your reply. please fill a new ticket for this if you can reproduce this with 2.4.3 (seems to be similar to #5825).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!