Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#2640 closed defect (fixed)

Random crashes by libmsn.so

Reported by: Peter Dedecker Owned by:
Milestone: 2.2.0 Component: libpurple
Version: 2.0.2 Keywords: msn
Cc:

Description

Hi,

Last week, I've been using gaim 2.0.0b6 (provided by Ubuntu) and Pidgin 2.1.0 (from Getdeb). Here at work, I can use MSN by using the http-method and a proxy server. For XMPP, I have to set up an ssh-tunnel to a host outside the network to use forwarding of port 5222 on the server to my localhost. I didn't have any problem.

Today, I only have problems. First I had random crashes. As Getdeb warned for this, I switched back to pidgin (and pidgin-data) 2.0.2, and also tried my old gaim install, but none of this resulted in a stable app. Sometimes I can reproduce a crash by killing the ssh tunnel process, but this isn't always the fact. Also it seems libmsn.so causes the crash, but for MSN I don't use the tunnel. Random crashes occur.

I tried to get a backtrace, but I think I don't have enough information. In attach, you can find info from GDB.

Attachments (3)

gdb-pidgin.txt (7.6 KB) - added by Peter Dedecker 12 years ago.
gdb-pidgin-thc.txt (1.2 KB) - added by thc0 12 years ago.
Pidgin.GDB.txt (3.7 KB) - added by qsebas 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 follow-up: Changed 12 years ago by datallah

  • pending changed from 0 to 1

The gdb output attached doesn't contain debug symbols, so it isn't possible to extract anything particularly useful from it. Please follow the instructions here to install the debug symbols in order to get a backtrace containing debug symbols.

Changed 12 years ago by Peter Dedecker

comment:2 in reply to: ↑ 1 Changed 12 years ago by Peter Dedecker

  • pending changed from 1 to 0

Sorry, but at the mentioned page I only see "you might see '??' instead. If that's the case, gdb couldn't read the function names from Pidgin and so the backtrace won't end up being very useful after all" but no information in order to install the debug symbols. Maybe interesting to add?

So I used google and found a pidgin-dbg package for my version and attached a new version of the file.

comment:3 Changed 12 years ago by datallah

Actually, there are already distro-specific notes that should cover that.

Generally, googling for a -dbg package isn't the right thing to do because the debug symbols have to be from the same actual binary you're using, not just a version match. In this case, it appears that you've found the matching -dbg package.

comment:4 Changed 12 years ago by Peter Dedecker

Yes, I made sure it was a -dbg package from getdeg, were I got my binary.

Changed 12 years ago by thc0

comment:5 Changed 12 years ago by qsebas

I have the same problem, confirmed in Pidgin 2.1.0 and 2.1.1, I have Ubuntu 7.04 and connect MSN via proxy HTTP, same proble to retrieve the GDB information.. I think a pidgin -d output can be usefull:

allways the las lines of the output are like:

(16:42:00) buddyicon: Wrote cache file: /home/sebas/.purple/icons/7e5a109bb737b454f388523cacd0043f644697d2.png (16:42:00) msn: C: SB 004: MSG 6 D 147 (16:42:00) msn: C: SB 004: OUT (16:42:00) msn: S: SB 004: ACK 4

Changed 12 years ago by qsebas

comment:6 Changed 12 years ago by datallah

#2942 has a good backtrace for this issue.

comment:7 Changed 12 years ago by datallah@…

  • Milestone set to 2.2.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 7aea471c6710708afa40152f5fc3aaeda3d67e76) Deal better with receiving a msn ACK when there is no switchboard connected. Fixes #2640.

comment:8 follow-up: Changed 12 years ago by thc0

Cool... How I can get the fix?

comment:9 in reply to: ↑ 8 Changed 12 years ago by datallah

Replying to thc0:

Cool... How I can get the fix?

When 2.2.0 is released, upgrade.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!