Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2664 closed defect (duplicate)

Chinese characters not correctly displayed

Reported by: adamsonh Owned by:
Milestone: Component: winpidgin (gtk)
Version: 2.1.0 Keywords: Chinese characters
Cc:

Description

I use XP English version with Chinese(PRC) enabled for non-Unicode programs. I don't have any problem exchanging messages with most of friends using my msn id. However, Chinese (Hong Kong) messages sent to me from two out of my 20-odd friends in HK cannot be shown correctly on my pidgin (2.00-2.11). Those characters appear as squares. If I close the chat window and come back again, they appear correctly.

Please take a look at http://polycastle.3322.org:8021/pidgin.jpg

Attachments (1)

pidgin.jpg (53.6 KB) - added by adamsonh 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by adamsonh

comment:2 Changed 10 years ago by datallah

  • Component changed from pidgin (gtk) to winpidgin (gtk)
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #604.

comment:3 Changed 10 years ago by adamsonh

I tried all the methods listed in #604, but I still could not solve the problem. I have no problem with most of my contacts who use Chinese (both simplified and traditional). Only 2 out of them have such a problem. This morning I installed pidgin 2.11 onto a simplified Chinese Windows 2000 computer and found the same problem with those 2 users. Please pay some attention to my posts. I can ask those two users to provide information for debugging.

comment:4 Changed 10 years ago by datallah

This certainly is a font problem (as specified in #604). If the encoding was incorrect, the history plugin wouldn't be able to display the text correctly either.

If you uncheck "Show formatting on incoming messages" in the conversation preferences (which is mentioned in #604), it should cause it to use the default font (which apparently works because your history shows the text correctly).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!