Opened 10 years ago

Closed 10 years ago

#2775 closed defect (fixed)

New Pidgin duplicates buddies in AIM

Reported by: varchar255 Owned by: MarkDoliner
Milestone: Component: AIM
Version: 2.1.1 Keywords: duplicate, buddies
Cc:

Description

When using the new Pidgin 2.1.1, I noticed some buddies were duplicated (exact same name but appearing in different groups). I checked blist.xml and Pidgin seems to be adding the second name on its own as older versions used the exact same blist.xml with no problems. This is a problem because when I removed one of the two names in Pidgin, apparently the AIM server correctly had only one name so it resulted in the buddy being removed completely whereas I just wanted to get rid of the Pidgin duplicate.

I'm using Pidgin 2.1.1 on Windows. This was definitely working in Gaim beta 6, and I think it was ok in 2.1.0 also although I didn't specifically look for it.

Attachments (1)

pidgin-2.2.0-fix-duplicate-buddies.patch (412 bytes) - added by nhulsch 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by nhulsch

i can confirm that for pidgin 2.1.1 running on fedora core 6.

also the notify plugin is logging every event twice in the conversation window (i guess because the buddy is twice in the list)

comment:2 follow-up: Changed 10 years ago by loptosko

Duplicate of #2712

comment:3 in reply to: ↑ 2 Changed 10 years ago by varchar255

Replying to loptosko:

Duplicate of #2712

Are you sure this is a dupe? Bug 2712 is talking about duplicated groups, not buddies, and in my case I do not have any non-English characters in the names of my buddies.

comment:4 Changed 10 years ago by loptosko

Sorry I mistaken.

But anyway, I just noticed the same thing happening to me (Pidgin 2.1.1). I had the same contact in 2 groups, and when I removed it from one group, logged out and back, the another contact disappeared too. I don't know if it happened in older versions of Pidgin.

comment:5 Changed 10 years ago by nhulsch

bug is still there in 2.2.0

comment:6 Changed 10 years ago by nhulsch

this attachment will fix the duplicate buddies at the oscar protocol.

i have to say, that you have to manually kick (one of) the duplicate buddies out of the blist.xml file. After that it will not duplicate any buddy.

I've just restorted that line from 2.1.0 - maybe the pidgin team can say something to that change.

Changed 10 years ago by nhulsch

comment:7 Changed 10 years ago by seanegan

  • Component changed from libpurple to AIM
  • Owner set to MarkDoliner

comment:8 Changed 10 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

You're allowed to have the same buddy in multiple groups in AIM. Earlier versions of Pidgin showed each buddy in at most one group, even if they were supposed to be listed in more than one group (because your buddylist stored on the server has them in more than one group).

This was fixed to correctly display the buddy in both groups. If you delete one of them it shouldn't come back. I can't reproduce the bug where deleting one of the buddies causes both of them to be deleted.

If you have a buddy in more than one group and you can't delete him then let me know. Otherwise everything here sounds like it's working properly.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!