Opened 9 years ago

Closed 7 years ago

#2820 closed defect

msimprpl too much CPU usage when importing friends, appears to hang, may freeze on Vista

Reported by: jeff Owned by: jeff
Milestone: Component: MySpace
Version: 2.1.1 Keywords: msimprpl
Cc:

Description

insomniacsoul says that importing friends takes up too much CPU.

Attachments (1)

msimprpl-import-friends-cpu.png (20.2 KB) - added by jeff 9 years ago.
first three spikes are importing 19 friends from msimprpl, next three are from importing 25 friends on my main account

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by jeff

first three spikes are importing 19 friends from msimprpl, next three are from importing 25 friends on my main account

comment:1 Changed 9 years ago by jeff

CPU usage spikes near 100% while importing, but only momentarily. May be a problem with very large buddy lists. Run in a separate thread?

comment:2 Changed 9 years ago by jeff

insomniacsoul: the latest msimprpl(0.16) has another bug, the "add friends from myspace.com" feature worked, but only got the bands in my friends list, it did not retrieved the "normal account" friends.

comment:3 Changed 9 years ago by jeff

  • Milestone set to 2.3.0
  • priority changed from minor to major
  • Summary changed from msimprpl too much CPU usage when importing friends? to msimprpl too much CPU usage when importing friends, appears to hang, may freeze on Vista

Spotted on digg: http://digg.com/linux_unix/Pidgin_2_2_0_out_in_the_wild

by niviche on 09/15/2007 This version seems to run fine, except for the Myspaceim plugin. I can log-in, but clicking on "add contacts from myspace" just freezes the whole app (on Vista).

comment:4 Changed 9 years ago by seanegan

  • Component changed from libpurple to MySpace

comment:5 Changed 8 years ago by Sim-on

  • Milestone set to 2.4.2

comment:6 Changed 8 years ago by mpadams

On a 32-bit Ubuntu Hardy machine with Pidgin 2.4.1, I'm seeing periodic CPU spikes to 100%, and it appears to be GTK-related, as when I switch the Appearance in GNOME, the overload goes away. I think the root cause of this is responsible for multiple bugs.

http://developer.pidgin.im/ticket/4666 http://developer.pidgin.im/ticket/2820

comment:7 Changed 7 years ago by bernmeister

Is this still an issue in Pidgin 2.5.8?

comment:8 Changed 7 years ago by rekkanoryo

  • Status changed from new to pending

comment:9 Changed 7 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!