Opened 10 years ago

Closed 4 years ago

Last modified 23 months ago

#3066 closed task (out of date)

We need a functional donations page.

Reported by: kstange Owned by: kstange
Milestone: Component: webpage
Version: 2.1.1 Keywords: donations
Cc: dtfinch, macnewbold, hobarrera

Description

This is a reminder to me to work on an authorize.net capable donations page!

Change History (23)

comment:1 Changed 10 years ago by kstange

  • Type changed from defect to task

comment:2 Changed 10 years ago by kstange

  • Milestone set to Completed Web Site

comment:3 Changed 10 years ago by Commifreak

Use Paypal XD

comment:4 Changed 9 years ago by caseyho

Ticket #3862 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by rekkanoryo

Any status updates on the donations page?

comment:6 Changed 8 years ago by RizThon

It should be quite straight forward to use paypal for this. Just look for "donation paypal" in google... You can look here https://www.paypal.com/cgi-bin/webscr?cmd=p/xcl/rec/donate-intro-outside and also here for a sample https://www.paypal.com/cgi-bin/webscr?cmd=_pdn_donate_techview_outside

comment:7 Changed 8 years ago by rekkanoryo

Some of us are opposed to PayPal for various reasons, so we won't use it.

comment:8 Changed 8 years ago by macnewbold

Is there anything I can do to help? I work with authorize.net integrations quite a lot. Pardon the ignorance, but is the site in PHP or some other language?

comment:9 Changed 8 years ago by alex22

Just adding my 'me too'. I would be more than willing to support pidgin. The same goes for a number of my friends.

comment:10 Changed 8 years ago by kobedf

Same here. I appreciate your work and would like to support it.

comment:11 Changed 7 years ago by jj00

I Just spent an hour trying to figure out how to donate to this project. I've been using Pidgin for many, many years and finally wanted to show some appreciation.

I can only comment on the other comments on this ticket, so I assume there is some resistance to PayPal?? I know people have issues with PayPal? (it can really suck), but it seems like they are the easiest solution for now. Once you have it setup, you can always change it if something better comes along.

I noticed that Adium (sister-project?) has a PayPal? donate button on their main page, wouldn't just be easier to follow their lead and get something setup quick and easy?

Thanks for your time!

comment:12 Changed 7 years ago by hobarrera

Why should they "follow" the lead of others? There were strong issues with paypal and it was rejected more than a year ago.

Last year, paypal demonstrated it did not care for or support freedom of speech, and favoured censure.

I don't think the pidgin project wants a logo of such a company on their website, or to pay a small commission to someone with those principles.

It's a matter of principle, not comfort, or friendliness, or ease-of-use.

It's the same reason why I would *not* pay for pidgin if it were proprietary, but would like to donate to it being free as it is.

comment:13 Changed 7 years ago by jj00

Thanks for your quick response.

I don't want to start a religious war over PayPal?, it was simply a suggestion for a quick solution. As far as following the lead of others, there is good argument for learning from the decisions of others. Maybe Adium vetted all the other options and just decided PayPal? was the best option for now (or maybe they were just lazy).

I noticed this particular issue has been open for 3 years, and if PayPal? was rejected more than a year ago, I see nothing wrong with re-asking the question of whether or not to use them.

Anyway, how about Google Checkout? They also have a donations program that seems like it would be a good fit. Isn't Pidgin an active benefactor of the Summer of Code project? Maybe they would be willing to help setup a donations account.

comment:14 Changed 6 years ago by Tm0

Do you guys have any idea what kind of service you will allow? I have heard many good things about RegNet?. If you are okay with that it should be fairly easy to implement.

http://www.reg.net/default.asp

comment:15 Changed 5 years ago by johsjo

Flattr is a micro-donation service that hosts quite a lot of open source projects. I would love to see Pidgin added there.

comment:16 Changed 4 years ago by tfar

So. What needs to be done for this? What are the requirements the Pidgin devs have for this? Would flattr donations work for you? I think they're not that hard to setup. Is there a way the community can help with this?

comment:17 Changed 4 years ago by MarkDoliner

  • Resolution set to out of date
  • Status changed from new to closed

I'm going to close this. Please read on for the my reasons.

Pidgin is assisted by a US registered non-profit organization called Instant Messaging Freedom, Inc. https://imfreedom.org/ It was founded by Pidgin developers and former Pidgin developers to help with lawsuits, hold copyright for people who may not wish to hold it themselves, pay legal fees, pay contractors for design, development, etc, and to optionally accept donations. In practice IM Freedom doesn't do a whole lot. Our internet hosting is generously provided by Network Redux (http://www.networkredux.com/), SourceForge (https://sourceforge.net/), and I believe Steadfast (https://steadfast.net/). Software Freedom Law Center has generously assisted with various legal bits for free, when needed. We haven't had legal problems in many years. We haven't seen a need to pay designers or developers recently (with one exception, which I'll talk about below). IM Freedom does accept mentor stipends from Google Summer of Code, and because of that, and because we have very low costs, we don't really need donations.

The one exception is Tomasz Wasilczyk. He was a developer who was already with the project. A large company decided to donate money to us so that we might pay him to improve Pidgin, libpurple, Finch, and now Adium. This is going well and everyone seems happy with it. We are in the process of doing a second payment to him now for additional work.

There's a question of, if we were to accept donations, what would we use them for? We could possibly pay for more development. This can be difficult... we existing developers have little bandwidth to adequately do code reviews. Tomasz doesn't need close code reviews because he's been working with the project for a few years and he does good work. It would be hard for us to hire someone new to the project because they would need lots of oversight, which we may not have time to provide. Our existing developers tend to not have time themselves to do work for pay. I don't think we have a strong need to pay for additional hosting services. I don't think we have a strong need to pay for design or artwork.

Perhaps after Tomasz completes his additional work he'll desire to continue, and perhaps then we could request donations for a specific set of tasks to work on. Or perhaps someone else will come along who will desire to do work and propose a price.

But for now I don't see a strong need for us to accept donations.

All that being said, if you really want to donate, you may do so by making a donation to the IM Freedom PayPal account using this page: https://imfreedom.org/donate.php

Note that PaylPal deducts a percentage-based transaction fee. I do not know the exact amount, but I believe it's less than 5%.

Also consider donating to these other great causes, which have more bandwidth for using donations than we do:

  • Electronic Frontier Foundation
  • Software Freedom Law Center
  • Electronic Privacy Information Center
  • Free Software Foundation

comment:18 Changed 4 years ago by MarkDoliner

Also, thank you for your interest! We do appreciate it.

On the topic of bounties, I think there probably isn't a consensus among us developers or among the IM Freedom board. We probably tend to be mildly in favor. Having more people write patches for Pidgin is almost always a good thing. There still exists the problem of us not having enough time to reviewing the change and enforce a standard of high quality code.

comment:19 Changed 4 years ago by loomchild

Hi,

My name is Jarek Lipski and I recently developed BountyFunding? (​http://bountyfunding.org), a decentralised bounty crowdfunding platform for free / open source software. I was wondering whether you would be interested in trying my project in your development?

Although BountyFunding? is still in an alpha/beta stage and it contains some rough edges (for example - the final developer transfer step is manual), it is already functional (check ​http://bountyfunding.org/demo to see it in action). It is self-hosted and integrates with the Trac issue tracker, so you maintain full control over the process and can decide, for example, which payment methods to accept (unfortunately only PayPal? is supported for now, but Bitcoin and others are coming soon), which tasks can be sponsored and what features will be developed. BountyFunding? is also a free / open source software itself, licensed under AGPL.

As the project is still very young and I don't currently have any users, apart from BountyFunding? itself, I can offer dedicated support while deploying the software and resolve any problems if/as they arise (I can spend up to 10 hours per week on it).

I would be very happy to answer any questions you may have.

comment:20 Changed 4 years ago by MarkDoliner

I outlined our general stance on bounties on our SoCAndBountyIdeas wiki page. We're not against them, but people interested in working for bounties will need to take on the responsibility of nagging us developers to determine what bug fixes/features we're willing to accept, and we can't guarantee any sort of turnaround time for code reviews--we just don't have the manpower.

comment:21 Changed 4 years ago by loomchild

Thanks for adding BountyFunding to the wiki.

The thing is that it's hosted by the project itself and connected with the issue tracker using a plugin. In other words, unlike other crowdfunding solutions mentioned there, users can't just sponsor Pidgin issues on bountyfunding.org website right now, it needs to be configured in Pidgin's Trac.

Benefit is that the community controls which issues can be sponsored (for example only accepted or assigned ones) and everything is in on place (no synchronization necessary, single website to look for users and devs, etc.) There also no fees and project fully controls the donations - they can be split between the developer implementing the feature and the project fund for example.

Please feel free to leave the link to BountyFunding on the wiki or remove it as it is currently irrelevant.

Last edited 4 years ago by loomchild (previous) (diff)

comment:22 Changed 4 years ago by MarkDoliner

Ah, thanks for the clarification. I removed the link.

comment:23 Changed 23 months ago by Robby

  • Milestone Completed Web Site deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!