Opened 12 years ago

Closed 3 years ago

#3126 closed defect (out of date)

HTTP method does not work

Reported by: moicdoudou Owned by: khc
Milestone: Component: MSN
Version: 2.2.0 Keywords: http method msn proxy read error
Cc: datallah

Description (last modified by datallah)

Hey

I cannot login to MSN network with Pidgin 2.2.0. There is a proxy (host:wwwcache.insa-toulouse.fr and port:3128, the two open ports are the port 80 and 443) on the network of my school. Windows Live Messenger works fine and Miranda IM on Windows also (It works with Jabber protocol only on port 443, not on port 80). Perhaps, HTTP method would work on port 443 ? Here is the debug output (I try also without the HTTP protocol) :

connection: Connecting. gc = 0x85ac7e0
(15:09:58) msn: new httpconn (0x8514760)
(15:09:58) dns: DNS query for 'wwwcache.insa-toulouse.fr' queued
(15:09:58) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
(15:09:58) dns: Created new DNS child 4528, there are now 1 children.
(15:09:58) dns: Successfully sent DNS request to child 4528
(15:09:58) dns: Got response for 'wwwcache.insa-toulouse.fr'
(15:09:58) dnsquery: IP resolved for wwwcache.insa-toulouse.fr
(15:09:58) proxy: Attempting connection to 195.83.11.66
(15:09:58) proxy: Connecting to gateway.messenger.hotmail.com:80 via wwwcache.insa-toulouse.fr:3128 using HTTP
(15:09:58) proxy: Connection in progress
(15:09:58) proxy: HTTP proxy connection established
(15:09:59) msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0
(15:09:59) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS user@hotmail.com
(15:09:59) msn: HTTP: Read error
(15:09:59) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Erreur de lecture
(15:09:59) msn: C: NS 000: OUT
(15:09:59) msn: HTTP: Read error
(15:09:59) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Erreur de lecture
(15:09:59) g_log: msn_session_disconnect: assertion `session->connected' failed(15:09:59) account: Disconnecting account 0x8161460
(15:09:59) connection: Disconnecting connection 0x85ac7e0
(15:09:59) msn: destroy httpconn (0x8514760)
(15:09:59) connection: Destroying connection 0x85ac7e0

Change History (22)

comment:1 in reply to: ↑ description Changed 12 years ago by moicdoudou

How can i edit my ticket ? I would like delete my address

comment:2 Changed 12 years ago by rekkanoryo

You can't. Only a developer can edit the text that you submitted for the original ticket.

comment:3 Changed 12 years ago by seanegan

  • Component changed from pidgin (gtk) to MSN
  • Owner set to khc

comment:4 Changed 11 years ago by khc

  • Cc datallah added

is this fixed by #2638?

comment:5 Changed 11 years ago by datallah

  • pending changed from 0 to 1

I doubt it, but the reporter is the only one who can tell us for sure.

comment:6 Changed 11 years ago by moicdoudou

  • pending changed from 1 to 0

I try again with Pidgin 2.2.2 :

(21:25:59) account: Connecting to account xxxxxxxxxx@hotmail.com
(21:25:59) Session Management: Received first save_yourself
(21:25:59) Session Management: Received save_complete
(21:25:59) docklet: embedded
(21:26:03) connection: Connecting. gc = 0x858b010
(21:26:03) msn: new httpconn (0x858b938)
(21:26:03) dns: DNS query for 'wwwcache.insa-toulouse.fr' queued
(21:26:03) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
(21:26:03) dns: Created new DNS child 5339, there are now 1 children.
(21:26:03) dns: Successfully sent DNS request to child 5339
(21:26:03) dns: Got response for 'wwwcache.insa-toulouse.fr'
(21:26:03) dnsquery: IP resolved for wwwcache.insa-toulouse.fr
(21:26:03) proxy: Attempting connection to 195.83.11.66
(21:26:03) proxy: Connecting to gateway.messenger.hotmail.com:80 via wwwcache.insa-toulouse.fr:3128 using HTTP
(21:26:03) proxy: Connection in progress
(21:26:03) proxy: HTTP proxy connection established
(21:26:03) msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0
(21:26:03) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS xxxxxxxxxxx@hotmail.com
(21:26:03) msn: HTTP: Read error
(21:26:03) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Erreur de lecture
(21:26:03) msn: C: NS 000: OUT
(21:26:03) msn: HTTP: Read error
(21:26:03) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Erreur de lecture
(21:26:03) g_log: msn_session_disconnect: assertion `session->connected' failed
(21:26:03) account: Disconnecting account 0x81870d8
(21:26:03) connection: Disconnecting connection 0x858b010
(21:26:03) msn: destroy httpconn (0x858b938)
(21:26:03) connection: Destroying connection 0x858b010

It seems it uses the port 80, not the 443.

PS : Could someone delete my email in the first post, please ?

comment:7 Changed 11 years ago by datallah

  • Description modified (diff)

comment:8 Changed 11 years ago by Greeds2

Hi there,

I am also experiencing this problem on Win32 pidgin 2.4.0. Obviously the port setting in the account configuration doesn't do anything as I've tried changing it - the HTTP method always connects on port 80.

(14:37:28) account: Connecting to account xxxxx@hotmail.com
(14:37:28) connection: Connecting. gc = 01B37FE8
(14:37:28) msn: new httpconn (01B36C58)
(14:37:28) dnsquery: Performing DNS lookup for dk01snz24.simcorp.int
(14:37:28) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
(14:37:28) prefs: /pidgin/blist/width changed, scheduling save.
(14:37:28) prefs: /pidgin/blist/height changed, scheduling save.
(14:37:28) dnsquery: IP resolved for dk01snz24.simcorp.int
(14:37:28) proxy: Attempting connection to 192.168.100.81
(14:37:28) proxy: Connecting to gateway.messenger.hotmail.com:80 via dk01snz24.simcorp.int:8080 using HTTP
(14:37:28) proxy: Connection in progress
(14:37:28) proxy: HTTP proxy connection established
(14:37:28) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Writing error
(14:37:28) msn: C: NS 000: OUT
(14:37:28) msn: Attempted HTTP write before session is established
(14:37:28) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Writing error
(14:37:28) msn_session_disconnect: assertion `session->connected' failed
(14:37:28) account: Disconnecting account 00C72BF0
(14:37:28) connection: Disconnecting connection 01B37FE8
(14:37:28) msn: destroy httpconn (01B36C58)
(14:37:28) connection: Destroying connection 01B37FE8

I also notice that the message has changed slightly since the original post was made.

I'm on a restrictive firewall that can only make outgoing TCP connections on port 80 or 443 so haven't got any other way of getting Pidgin to work the normal way. I can use an SSH tunnel to get round the issue but thought I'd provide some additional information in case it's of any help to the plugin maintainers.

I'd imagine that this will be affecting a number of other HTTP method users at the moment, unless someone can point out a config option I might have missed.

Thanks for all the good work!

Alex

comment:9 Changed 11 years ago by karypid

I have also been experiencing this bug with 2.4.0 and now with 2.4.1.

The problem is that my proxy (as is the case with other users) only allowns HTTP CONNECT to port 443. The "Port" preference (defaults to 1863) applies to the MSN server preference (which defaults to messenger.hotmail.com) for NON http-method connections.

When you enable the "Use HTTP Method" checkbox, pidgin attempts to connect to port 80 (this is apparently hard-coded?) via the proxy, which is not allowed on my site (as well as those of the other posters). Changing the "port" setting has no effect, as it only applies to the NON-http method server (messenger.hotmail.com). I tried to trick pidgin by specifying gateway.messenger.hotmail.com:443 as the "HTTP method server" but the debug log says it still tries to connect to port 80 (gateway.messenger.hotmail.com:443:80).

comment:10 Changed 11 years ago by felipec

  • Owner changed from khc to felipec
  • Status changed from new to assigned

comment:11 Changed 11 years ago by felipec

  • Owner changed from felipec to khc
  • Status changed from assigned to new

comment:12 Changed 11 years ago by karypid

I am using Pidgin 2.4.3 and this issue seems to be fixed. At least, it works for me now.

comment:13 Changed 11 years ago by bernmeister

Is this an issue for anyone still?

comment:14 Changed 11 years ago by neewom

Unfortunately, I believe I am. Using the HTTP method, I changed the default port and am still receiving:

(16:00:13) proxy: Connecting to gateway.messenger.hotmail.com:80 with no proxy
(16:00:13) proxy: Connection in progress
(16:00:13) proxy: Connected to gateway.messenger.hotmail.com:80.

This is with 2.5.0

comment:15 Changed 11 years ago by koms1016

This is still an issue for me. Sometimes MSN connects but it doesn't most of the time. The native MSN Messenger app connects but Pidgin has issues. I am using 2.5.1. Log below:

Pidgin Debug Log : 9/3/2008 8:18:16 AM
(08:18:04) gtkappbar: wnd_poschanging
(08:18:04) account: Connecting to account ksa_uh@hotmail.com
(08:18:04) connection: Connecting. gc = 020E52B8
(08:18:04) msn: new httpconn (020EE100)
(08:18:04) proxy: No Windows proxy set.
(08:18:04) dnsquery: Performing DNS lookup for gateway.messenger.hotmail.com
(08:18:04) msn: C: NS 000: VER 1 MSNP15 CVR0
(08:18:04) dnsquery: IP resolved for gateway.messenger.hotmail.com
(08:18:04) proxy: Attempting connection to 65.54.239.211
(08:18:04) proxy: Connecting to gateway.messenger.hotmail.com:80 with no proxy
(08:18:04) proxy: Connection in progress
(08:18:04) proxy: Connected to gateway.messenger.hotmail.com:80.
(08:18:04) proxy: No Windows proxy set.
(08:18:05) msn: S: NS 000: VER 1 MSNP15
(08:18:05) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.5.1288 msmsgs ksa_uh@hotmail.com
(08:18:05) proxy: No Windows proxy set.
(08:18:05) msn: HTTP: Read error
(08:18:05) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Reading error
(08:18:05) msn: C: NS 000: OUT
(08:18:05) msn: HTTP: Read error
(08:18:05) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Reading error
(08:18:05) account: Disconnecting account 00CA1528
(08:18:05) connection: Disconnecting connection 020E52B8
(08:18:05) msn: destroy the OIM 020AD918
(08:18:05) msn: destroy httpconn (020EE100)
(08:18:05) jabber: jabber_actions: have pep: NO
(08:18:05) connection: Destroying connection 020E52B8
(08:18:09) util: Writing file accounts.xml to directory C:\Documents and Settings\KAgrawal\Application Data\.purple
(08:18:09) util: Writing file C:\Documents and Settings\KAgrawal\Application Data\.purple\accounts.xml

comment:16 Changed 10 years ago by Cilyan

Hello, I have the same error with 2.5.5 on linux. I think it is linked to http://developer.pidgin.im/ticket/7045#comment:2 and I posted there a new debug log, I hope this will help.

comment:17 Changed 10 years ago by bernmeister

Should this ticket be marked as a duplicate of #7045 as it has similar symptoms?

comment:18 Changed 10 years ago by Cilyan

It seems to be the same problems, yes. However, this thread is more active and more detailed. Maybe it is the one that should be kept. Unfortunately too, I left this company a month ago so I won't be able to test. But I can find people who can.

comment:19 Changed 9 years ago by archastrel

I believe this problem still exists in 2.7.3:

(11:01:19) account: Connecting to account me@invalid.org.
(11:01:19) connection: Connecting. gc = 027D3FB0
(11:01:19) msn: new httpconn (026B97C0)
(11:01:19) dnsquery: Performing DNS lookup for gateway.messenger.hotmail.com
(11:01:19) msn: C: NS 000: VER 1 MSNP15 CVR0
(11:01:19) dnsquery: IP resolved for gateway.messenger.hotmail.com
(11:01:19) proxy: Attempting connection to 64.4.45.62
(11:01:19) proxy: Connecting to gateway.messenger.hotmail.com:80 with no proxy
(11:01:19) proxy: Connection in progress
(11:01:20) proxy: Connecting to gateway.messenger.hotmail.com:80.
(11:01:20) proxy: Connected to gateway.messenger.hotmail.com:80.
(11:01:20) msn: S: NS 000: VER 1 MSNP15
(11:01:20) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 8.5.1302 BC01 me@invalid.org
(11:01:20) msn: S: NS 000: CVR 2 14.0.8117 14.0.8117 14.0.8117 http://msgruser.dlservice.microsoft.com/download/A/6/1/A616CCD4-B0CA-4A3D-B975-3EDB38081B38/en/wlsetup-cvr.exe http://download.live.com/?sku=messenger
(11:01:20) msn: C: NS 000: USR 3 SSO I me@invalid.org
(11:01:21) msn: S: NS 000: 931 3
(11:01:22) msn: S: NS 000: 931 3
(11:01:24) msn: S: NS 000: 931 3
(11:01:25) util: Writing file accounts.xml to directory C:\Documents and Settings\bluerv\Application Data\.purple
(11:01:25) util: Writing file C:\Documents and Settings\bluerv\Application Data\.purple\accounts.xml
(11:01:26) msn: S: NS 000: 931 3
(11:01:28) msn: S: NS 000: 931 3
(11:01:30) msn: S: NS 000: 931 3
(11:01:32) msn: S: NS 000: 931 3
(11:01:34) msn: S: NS 000: 931 3
(11:01:36) msn: S: NS 000: 931 3
(11:01:38) msn: S: NS 000: 931 3
(11:01:40) msn: S: NS 000: 931 3
(11:01:42) msn: HTTP: servconn 000 read error, len: -1, errno: 0, error: Remote host closed connection.
(11:01:42) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Reading error
(11:01:42) msn: C: NS 000: OUT
(11:01:42) connection: Connection error on 027D3FB0 (reason: 0 description: Connection error from Notification server:
Reading error)
(11:01:42) account: Disconnecting account me@invalid.org (027C8938)
(11:01:42) connection: Disconnecting connection 027D3FB0
(11:01:42) msn: destroy the OIM 027C5188
(11:01:42) msn: destroy httpconn (026B97C0)
(11:01:42) connection: Destroying connection 027D3FB0
(11:01:48) util: Writing file accounts.xml to directory C:\Documents and Settings\bluerv\Application Data\.purple
(11:01:48) util: Writing file C:\Documents and Settings\bluerv\Application Data\.purple\accounts.xml

comment:20 Changed 9 years ago by janvlug

I think I experience this problem as well on Linux for: Pidgin 2.7.3-1.fc12 (libpurple 2.7.3)

Settings:
Server: gateway.messenger.hotmail.com
Port: 80
Use HTTP Method: selected
HTTP Method server: gateway.messenger.hotmail.com
Show custom smileys: enabled
Allow direct connections: enabled
Proxy type: Use GNOME Proxy Settings

Debug output:

Pidgin Debug Log : Tue 07 Sep 2010 10:53:57 AM CEST
(10:53:14) util: Writing file prefs.xml to directory /home/me/.purple
(10:53:14) util: Writing file /home/me/.purple/prefs.xml
(10:53:20) account: Connecting to account me@live.com.
(10:53:20) connection: Connecting. gc = 0x1e2cd10
(10:53:20) msn: new httpconn (0x2039910)
(10:53:20) dns: DNS query for 'example.proxy.org' queued
(10:53:20) msn: C: NS 000: VER 1 MSNP15 CVR0
(10:53:20) dns: Wait for DNS child 4754 failed: No child processes
(10:53:20) dns: Created new DNS child 5041, there are now 1 children.
(10:53:21) dns: Successfully sent DNS request to child 5041
(10:53:21) dns: Got response for 'example.proxy.org'
(10:53:21) dnsquery: IP resolved for example.proxy.org
(10:53:21) proxy: Attempting connection to 192.a.b.c
(10:53:21) proxy: Connecting to gateway.messenger.hotmail.com:80 via example.proxy.org:8088 using HTTP
(10:53:21) proxy: Connection in progress
(10:53:21) proxy: Connected to gateway.messenger.hotmail.com:80.
(10:53:21) proxy: HTTP proxy connection established
(10:53:21) proxy: Connected to gateway.messenger.hotmail.com:80.
(10:53:21) msn: S: NS 000: 601 1
(10:53:25) util: Writing file accounts.xml to directory /home/me/.purple
(10:53:25) util: Writing file /home/me/.purple/accounts.xml
(10:53:57) prefs: /pidgin/filelocations/last_save_folder changed, scheduling save.

comment:21 Changed 9 years ago by janvlug

Regarding my previous comment: After disabling 'Use HTTP Method' and now using port 1863 I can connect to MSN. I'm behind a proxy and use GNOME proxy settings in Pidgin.

comment:22 Changed 3 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Port 80 http method doesn't exist anymore.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!