Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#3208 closed patch (fixed)

Add support for ICQ6 status note

Reported by: collin Owned by: MarkDoliner
Milestone: 2.4.0 Component: ICQ
Version: 2.0.2 Keywords:
Cc:

Description

Adds support for ICQ6 status notes.

Attachments (2)

icq6_status_note_support.diff (26.6 KB) - added by collin 12 years ago.
tlv_types (1.8 KB) - added by reh 12 years ago.
tlv types part of the 0x0fb4 meta subtype response

Download all attachments as: .zip

Change History (14)

comment:1 Changed 12 years ago by Sim-on

mh this should be patch not defect?!

fixes #703 (or #2246) ?????

comment:2 Changed 12 years ago by collin

Yep. sorry. that was a missclick

comment:3 Changed 12 years ago by lschiere

  • Component changed from unclassified to ICQ
  • Owner changed from lschiere to MarkDoliner
  • Type changed from defect to patch

Changed 12 years ago by collin

comment:4 Changed 12 years ago by collin

there was a problem with the originally attached patch. I replaced it by the corrected version...

comment:5 Changed 12 years ago by seanegan

  • Milestone set to 2.2.1

Changed 12 years ago by reh

tlv types part of the 0x0fb4 meta subtype response

comment:6 Changed 12 years ago by reh

I have added a file containing the currently known tlv types part of the 0x0fb4 meta subtype response. Maybe you can add it to the code so that they are somehow documented.

comment:7 Changed 11 years ago by schoen

collin: What type of status message does this patch help to retreive? There are two types of status messages in the official ICQ 6 client; one is some currently-mood like message like »I love ants«, and the other is directly requested from the client (i.e. ordinary away message).

comment:8 Changed 11 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

I committed this with some modifications. Basically I'm super picky.

Stripping HTML markup from info->status in oscar.c:purple_parse_oncoming() is not a valid thing to do. The available message is a plain text field and does not contain HTML. But I don't think that change is related to the status note changes, is it?

I changed the indentation and commenting to be more similar to the existing code.

I had already added a handler for SNAC_FAMILY_FEEDBAG/SNAC_SUBTYPE_FEEDBAG_MOD to oscar.c that behaved slightly differently, so I used that and added in your aim_icq_getstatusnote() change.

The family_icbm.c changes didn't compile because of IID and GUID aren't defined. I worked around that by using a 32 bit int to represent the capability as is done elsewhere in the code, and used OSCAR_CAPABILITY_EMPTY to check if it was all zeros.

I changed "for (;;)" in family_icq.c to parse out the info using a tlv list, as is done elsewhere in the oscar prpl.

I don't like using a dummy while loop in family_icbm.c to allow breaking out of the current flow... it makes the logic different from other places in the oscar prpl, and I think I might try to change that.

Also, I think it would be good if we could find a way to show both the status message and the status note. Maybe show them in the tooltip. Or the get info box.

But other than those things, nice job getting this working. Sorry it took me so long to get to it. I hope you'll keep submitting patches to us. Thanks!

comment:9 Changed 11 years ago by markdoliner@…

(In c51dd3dede6eda2c84e622b4ffe5f7a9e01152a0) Partial support for reading ICQ 6 status notes. The status note will show up next to the person's name in the buddy list, but only if they don't have another status message set.

This is from Collin from ComBOTS GmbH. Fixes #3208.

comment:10 follow-up: Changed 11 years ago by schoen

It doesn’t work most of the time. Only once I was able to fetch an ICQ 6 away message for a short period of time.

ICQ 6 available messages can be retrieved, since these are AIM-like status messages.

comment:11 in reply to: ↑ 10 Changed 11 years ago by Sim-on

Replying to schoen:

It doesn’t work most of the time. Only once I was able to fetch an ICQ 6 away message for a short period of time.

confirmed

comment:12 Changed 10 years ago by ghost_zero

I am not sure if this is related to this issue but I can't read status messages from various people either. However, one of them is using Miranda IM, so I am not sure if this is related to ICQ6 or not.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!