Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#3266 closed defect (worksforme)

Not receiving google messages

Reported by: protective1 Owned by: deryni
Milestone: Component: Google Talk
Version: 2.2.0 Keywords: google messages not received 503 service unavailable
Cc:

Description

I am not receiving Google messages on Pidgin 2.2.0 on Redhat Enterprise Linux 4. It worked fine in previous versions of Pidgin on this computer. When I try to send a message to myself, I get the debug output below (I have replaced my username with XXXXXX):

(17:18:14) jabber: Sending (ssl): <message type='chat' id='purplee5ba2ccf' to='XXXXXX@…'><x xmlns='jabber:x:event'><composing/></x><composing xmlns='http://jabber.org/protocol/chatstates'/></message>

(17:18:14) jabber: Recv (ssl)(321): <message type="error" id="purplee5ba2ccf" to="XXXXXX@…/HomeDA24F690" from="XXXXXX@…"><x xmlns="jabber:x:event"><composing/></x><composing xmlns="http://jabber.org/protocol/chatstates"/><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

(17:18:15) jabber: Sending (ssl): <message type='chat' id='purplee5ba2cd0' to='XXXXXX@…'><x xmlns='jabber:x:event'><composing/></x><active xmlns='http://jabber.org/protocol/chatstates'/><body>test</body><html xmlns='http://jabber.org/protocol/xhtml-im'><body xmlns='http://www.w3.org/1999/xhtml'>test</body></html></message>

(17:18:15) jabber: Sending (ssl): <message type='chat' id='purplee5ba2cd1' to='XXXXXX@…'><x xmlns='jabber:x:event'/><active xmlns='http://jabber.org/protocol/chatstates'/></message>

(17:18:15) jabber: Recv (ssl)(446): <message type="error" id="purplee5ba2cd0" to="XXXXXX@…/HomeDA24F690" from="XXXXXX@…"><x xmlns="jabber:x:event"><composing/></x><active xmlns="http://jabber.org/protocol/chatstates"/><body>test</body><html xmlns="http://jabber.org/protocol/xhtml-im"><body xmlns="http://www.w3.org/1999/xhtml">test</body></html><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

(17:18:15) jabber: Recv (ssl)(303): <message type="error" id="purplee5ba2cd1" to="XXXXXX@…/HomeDA24F690" from="XXXXXX@…"><x xmlns="jabber:x:event"/><active xmlns="http://jabber.org/protocol/chatstates"/><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

Change History (22)

comment:1 Changed 11 years ago by protective1

If I log into google mail (mail.google.com), the messages from other people show up in the chat log. However, Pidgin never received these messages.

comment:2 Changed 11 years ago by seanegan

  • Component changed from unclassified to Google Talk
  • Owner changed from lschiere to seanegan

comment:3 Changed 11 years ago by seanegan

  • pending changed from 0 to 1

This is definitely a server issue. If it doesn't go away shortly, let me know and I'll help debug it.

comment:4 Changed 11 years ago by protective1

  • pending changed from 1 to 0

Just to check, I tried this on another computer that's still using Gaim 2.0.0b6. This computer had a working Gaim/GoogleTalk? setup before. Now I get similar errors when sending a message to myself:

jabber: Sending (ssl): <message type='chat' id='gaim5c01a696' to='XXXXXX@…'><x xmlns='jabber:x:event'><composing/></x><composing xmlns='http://jabber.org/protocol/chatstates'/></message>

jabber: Recv (ssl)(319): <message type="error" id="gaim5c01a696" to="XXXXXX@…/Gaim5C7C363D" from="XXXXXX@…"><x xmlns="jabber:x:event"><composing/></x><composing xmlns="http://jabber.org/protocol/chatstates"/><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

jabber: Sending (ssl): <message type='chat' id='gaim5c01a697' to='XXXXXX@…'><x xmlns='jabber:x:event'><composing/></x><active xmlns='http://jabber.org/protocol/chatstates'/><body>test</body><html xmlns='http://jabber.org/protocol/xhtml-im'><body xmlns='http://www.w3.org/1999/xhtml'>test</body></html></message>

jabber: Sending (ssl): <message type='chat' id='gaim5c01a698' to='XXXXXX@…'><x xmlns='jabber:x:event'/><active xmlns='http://jabber.org/protocol/chatstates'/></message>

jabber: Recv (ssl)(444): <message type="error" id="gaim5c01a697" to="XXXXXX@…/Gaim5C7C363D" from="XXXXXX@…"><x xmlns="jabber:x:event"><composing/></x><active xmlns="http://jabber.org/protocol/chatstates"/><body>test</body><html xmlns="http://jabber.org/protocol/xhtml-im"><body xmlns="http://www.w3.org/1999/xhtml">test</body></html><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

jabber: Recv (ssl)(301): <message type="error" id="gaim5c01a698" to="XXXXXX@…/Gaim5C7C363D" from="XXXXXX@…"><x xmlns="jabber:x:event"/><active xmlns="http://jabber.org/protocol/chatstates"/><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></message>

It seems that the server problem hasn't gone away.

comment:5 Changed 11 years ago by protective1

btw - the 2.0.0b6 computer is running WinXP.

comment:6 follow-up: Changed 11 years ago by seanegan

  • pending changed from 0 to 1

Is this still happening?

comment:7 in reply to: ↑ 6 ; follow-up: Changed 11 years ago by protective1

  • pending changed from 1 to 0

Replying to seanegan:

Is this still happening?

Yes - as far as I know it's still happening. Is there anything you want me to check / log to help you debug it?

comment:8 in reply to: ↑ 7 Changed 11 years ago by sofist

Replying to protective1:

Replying to seanegan:

Is this still happening?

Yes - as far as I know it's still happening. Is there anything you want me to check / log to help you debug it?

I am also having this problem on ubuntu 7.10 (2.2.1) and on self compiled 2.2.2. Any idea how to debug this?

comment:9 Changed 11 years ago by protective1

still not working in 2.2.2

comment:10 Changed 11 years ago by kkwansj

With client version 2.3.0, running under CentOS 4.2, the issue is still present.

comment:11 Changed 11 years ago by seanegan

What version of libxml2 are you guys using?

comment:12 follow-up: Changed 11 years ago by protective1

I'm using libxml2 version 2.6.16 Is there any problem with that version?

comment:13 Changed 11 years ago by evands

A user is reporting this on the Adium feedback mailing list. That's libpurple 2.3.1, libxml2 2.6.16 as well.

comment:14 in reply to: ↑ 12 ; follow-up: Changed 11 years ago by seanegan

Replying to protective1:

I'm using libxml2 version 2.6.16 Is there any problem with that version?

Maybe. Do you think you can try upgrading it and see if the problem goes away?

comment:15 Changed 11 years ago by dankots

I'm also having this problem. I've built Pidgin 2.3.1, on Red Hat Enterprise Linux 4. I see the messages received from google talk in the Debug Window, but they do not make it to the chat window.

I tried the fix shown in ticket http://developer.pidgin.im/ticket/3532 but that didn't work for me. Is that the same issue?

comment:16 in reply to: ↑ 14 Changed 11 years ago by kingsly

Replying to seanegan:

Replying to protective1:

I'm using libxml2 version 2.6.16 Is there any problem with that version?

Maybe. Do you think you can try upgrading it and see if the problem goes away?

I've been having the same issue on CentOS since Nov 07,

I upgraded libxml2 from 2.6.16 to 2.6.26(rebuilt the latest update SRPM for centos 5)

And the problem disappeared! Finally able to use gtalk with pidgin after 3+ months! (Someone on #pidgin was having the same problem and the rpms I built solved the problem for him too.)

In case anyone is interested you can get the latest srpm from the updates directory for centos 5.1 from one of the mirrors and rebuild it on your machine or use the rpms i compiled for centos 4 from http://kingsly.net/tmp/libxml2/

Download all three of them into a directory and run "rpm -Fvh libxml2*rpm" and restart pidgin!

comment:17 follow-ups: Changed 11 years ago by emilal

This fix also resoved my bug - I'm working on Redhat Linux.

Can you modify the .configure script - so if the version is old to prevent further compilation, please?

comment:18 in reply to: ↑ 17 Changed 11 years ago by Nokia

I can confirm the bug on Fedora 8. I had this error both on version 2.3.1 and on 2.4.0, but I didn't realize it was actually a bug until recently when I had to find out what was this strange error and how to fix it. I first noticed it when trying to leave an offline message to a Google/Gtalk? contact. I haven't seen it on Ubuntu so far, yet Ubuntu still runs on 2.3.1 for the moment.

comment:19 in reply to: ↑ 17 Changed 11 years ago by Nokia

I can confirm the bug on Fedora 8. I had this error both on version 2.3.1 and on 2.4.0, but I didn't realize it was actually a bug until recently when I had to find out what was this strange error and how to fix it. I first noticed it when trying to leave an offline message to a Google/Gtalk? contact. I haven't seen it on Ubuntu so far, yet Ubuntu still runs on 2.3.1 for the moment.

comment:20 Changed 10 years ago by deryni

  • Owner changed from seanegan to deryni

comment:21 Changed 10 years ago by seanegan

  • Resolution set to worksforme
  • Status changed from new to closed

Closing as this looks like the fault of old libxml2s

comment:22 Changed 10 years ago by datallah

This is the relevant libxml2 bug: http://bugzilla.gnome.org/show_bug.cgi?id=164142

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!