Opened 12 years ago

Closed 3 years ago

Last modified 3 years ago

#336 closed enhancement (wontfix)

Auto-personize (auto-contactize) duplicate accounts

Reported by: rlaager Owned by: rlaager
Milestone: Component: libpurple
Version: 2.0 Keywords:
Cc: BUGabundo, Dawudd

Description (last modified by rlaager)

Somewhat related to ticket #44, libpurple (or Pidgin) should automatically combine buddies (within a group) where we are reasonably certain they are the same person. For example, we can turn everything into an equivalent e-mail address and create contacts based on that:

AIM/ICQ: %s@aim.com                  -> richielaager@aim.com || 1234567890@aim.com
Yahoo:   msn   ? (%s : %s@yahoo.com) -> rlaager@hotmail.com  || rlaager@yahoo.com
MSN:     yahoo ? (%s@yahoo.com : %s) -> rlaager@yahoo.com    || rlaager@hotmail.com
XMPP:    %s (w/o resource)           -> rlaager@gmail.com

In this way, if someone has my Yahoo account on both their Yahoo and MSN accounts, they will group. Buddies will likewise group when adding AIM buddies on ICQ or vice versa.

Change History (8)

comment:1 Changed 12 years ago by lschiere

unless in different groups.

comment:2 Changed 11 years ago by rlaager

Ticket #7056 has been marked as a duplicate of this ticket.

comment:3 Changed 11 years ago by rlaager

  • Description modified (diff)
  • Summary changed from Auto-personize duplicate accounts to Auto-personize (auto-contactize) duplicate accounts

comment:4 Changed 11 years ago by BUGabundo

Yahoo and AIM dont use email for IM accounts. they use usernames

comment:5 Changed 3 years ago by Robby

This seems like overengineering…

comment:6 Changed 3 years ago by rlaager

Let's just close this.

comment:7 Changed 3 years ago by rlaager

  • Resolution set to wontfix
  • Status changed from new to closed

comment:8 Changed 3 years ago by Robby

  • Milestone 3.0.0 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!