Opened 11 years ago

Closed 11 years ago

#3445 closed defect (wontfix)

pidgin loads firefox with wrong url when domain name is internationalized

Reported by: atodorov Owned by: seanegan
Milestone: Component: unclassified
Version: 2.0.2 Keywords:
Cc:

Description

Description of problem: When opening url to a website from pidgin, firefox fails to load the correct url when domain name contains non ascii characters.

Version-Release number of selected component (if applicable): pidgin-2.0.2-3.el5 firefox-1.5.0.12-3.el5

How reproducible: Always

Steps to Reproduce:

  1. In pidgin send a message containing "http://www.сватбата.com/". This is

domain name in cyrillic.

  1. The other person in the conversation receives the message and it is

recognised as hyperlink. I can read the cyrillic text and click on the link.

  1. Firefox loads with url:

http://www.%d1%81%d0%b2%d0%b0%d1%82%d0%b1%d0%b0%d1%82%d0%b0.com which looks like url encoded cyrillic string.

  1. The correct url is: http://www.xn--80aaacd3gjc.com/
  2. If written directly in Firefox address bar in cyrillic this domain name is

translated correctly and page loads. Actual results: pidgin starts Firefox with url encoded cyrillic string. Firefox fails to load the page since it's not an IDN and it's not translated.

Expected results: Firefox is started with correct parameter and translates the IDN to the actual value as it does when user types the address manually.

Additional info:

Change History (7)

comment:1 follow-up: Changed 11 years ago by nosnilmot

Are you using a UTF-8 locale? if you run "gnome-open http://www.сватбата.com/" or "firefox -a firefox -remote OpenURL(http://www.сватбата.com/)" from a terminal, does the correct URL open in firefox?

comment:2 in reply to: ↑ 1 Changed 11 years ago by atodorov

Replying to nosnilmot:

Are you using a UTF-8 locale?

en_US.UTF-8

if you run "gnome-open http://www.сватбата.com/"

produces the error above

or "firefox -a firefox -remote OpenURL(http://www.сватбата.com/)"

works as expected.

comment:3 Changed 11 years ago by lschiere

  • Owner changed from lschiere to elb

Ethan, any ideas here? If not, please assign to Sean, as this seems an issue with his gnome stuff.

comment:4 Changed 11 years ago by nosnilmot

This looks like a bug in gnome-open to me.

comment:5 Changed 11 years ago by elb

  • Owner changed from elb to seanegan

I agree with nosnilmot; I don't think this is a Pidgin bug at all. Whatever the URL handler is should either be passing the cyrillic directly through to firefox (where it can do IDN-alize it) or IDN-alizing it itself if it thinks it knows how. Our internal URL handler does nothing but shell-escape its argument, which would not affect it in the above manner, but executing gnome-open 'http://www.сватбата.com/' behaves as described above.

I think this should to to upstream. Sean?

comment:6 Changed 11 years ago by seanegan

This has been submitted as 501455

comment:7 Changed 11 years ago by seanegan

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!