Opened 9 years ago

Closed 5 years ago

Last modified 15 months ago

#3581 closed enhancement (out of date)

Buddy List Backup on System Crash

Reported by: prozach Owned by: nwalp
Milestone: Component: libpurple
Version: 2.2.1 Keywords:
Cc: shirish

Description

My computer has crashed twice, just a quick/cold/hard blue screen of death then reboot. The problem is when the computer comes back up Pidgin has problems reading my buddy list, as if it was in the middle of a write or some such when it happened. I'm able to get my buddy list back from the various servers I connect to but it's a pain as I have to then re-order the groups as well as re-combine the buddies.

It appears that Pidgin opens the buddy list when it launches then saves it back to disk whenever it closes, would it be possible to have a buddylist.bkp file (or some such) that stores a backup copy of the buddy list and is updated and saved whenever the buddy list is changed in the application. This way, if pidgin has an issue reading the buddy list at start up it can revert to the backup copy rather than re-pulling from the servers and loosing all the ordering/combining of contacts and groups.

Attachments (1)

pidgin-backup-0.1.tbz2 (2.6 KB) - added by charding 8 years ago.
Pidgin Backup Plugin

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by lschiere

  • pending changed from 0 to 1

It should create a ~/.purple/blist.xml~

comment:2 Changed 9 years ago by lschiere

  • Component changed from unclassified to libpurple
  • Owner changed from lschiere to nwalp

comment:3 Changed 9 years ago by prozach

  • pending changed from 1 to 0

Upon restarting and finding a messed up buddy list it does copy the existing buddy list to be blist.xml~ then re-creates the buddy list from the server-side copies.

The problem is the blist.xml~ is all messed up. When I open in VIM it gives the [noeol] message then I have a heck of a time seeing the end of the file (lots of @ symbols and vim seems to lock up). The @ symbols also start right in the middle of a contact.

comment:4 Changed 9 years ago by prozach

Oh, when I finally get to the very last char on the very last record vim shows: 4087,66726-133442 (line#,character#-column#)

comment:5 Changed 9 years ago by sadrul

  • Milestone set to Plugin Suggested

I think this is best done in a plugin.

comment:6 Changed 8 years ago by shirish

I would also be interested to have this sort of plugin.

Changed 8 years ago by charding

Pidgin Backup Plugin

comment:7 Changed 8 years ago by charding

I've just created this plugin (pidgin-backup-0.1.tbz2) for simple backup of the user's prefs.xml file. To use it just type make and sudo make install and then look for the 'Pidgin Backup' plugin listing, click the 'Configure' button from the plugins list and click the 'Backup' button from the popup window. It copies your prefs.xml file to prefs.xml.bk in your pidgin user directory.

This hasn't been tested on linux that much or on windows at all as I don't have a windows machine. I take no responsibility if this plugin does not work or it alters your .purple in weird ways. I suggest, before you try this plugin, that you backup your entire purple directory.

That being said, this plugin should work with no problems at all...

Let me know if people would like changes to it and/or additional options added to it.

comment:8 Changed 8 years ago by charding

I also found this but haven't tried it. It might be what people are looking for...

comment:9 Changed 5 years ago by nwalp

  • Status changed from new to pending

Is this still an issue, or have we outgrown this problem?

comment:10 Changed 5 years ago by prozach

  • Resolution set to out of date
  • Status changed from pending to closed

comment:11 Changed 15 months ago by Robby

  • Milestone Plugin Suggested deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!