Opened 12 years ago

Last modified 11 years ago

#3655 new defect

Finch is inaccessible to color blind users when used in a terminal

Reported by: galt Owned by:
Milestone: Component: finch (gnt/ncurses)
Version: 2.2.1 Keywords: color,colour
Cc:

Description

When running Finch in a (non-virtual) terminal, drop down menu entries are colored gray, and the entry in focus is colored teal. So for a color blind user of Finch, when they open up a drop down menu and click down to select an entry (say, a protocol type), nothing happens.

This may be the case for other UI elements as well, if they use the same color scheme.

Change History (10)

comment:1 Changed 12 years ago by sadrul

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3560.

comment:2 Changed 12 years ago by sadrul

Also, look at the sample .gntrc file in 'man finch' to see how you can change the different colors.

comment:3 Changed 12 years ago by galt

I really don't think this shares much with #3560.
This ticket is not about colorless terminals, it's about the color scheme that is used in certain UI elements, and makes them very hard to use for color blind users, even with terminals that do support color.

Thanks for pointing me to .gntrc, but I still think that the default color scheme should be accessible to everyone.

comment:4 Changed 12 years ago by sadrul

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I will happily consider suggestions/patches.

comment:5 Changed 12 years ago by galt

Possible solutions that I can think of:

  • Have the background of the entry in focus be blue, like it is for all other UI elements that are in focus. Maybe have the blue background of the original value shift down to other entries along with the focus. I think this would have a nice feel to it.
  • For the entry in focus, use a background color other than black, since black is the standard BG color of a terminal.
  • Just change the color (teal) to something that is clearly distinct from gray (maybe green or orange?).

comment:6 Changed 11 years ago by sadrul

  • Resolution set to worksforme
  • Status changed from reopened to closed

I don't understand what your are suggesting about the background of the entry boxes. Currently, the background for an entry is blue when in focus, and black when not in focus.

The foreground of the entry is white when in focus, and cyan when not. Both the colors are clearly visible against the background colors.

I am going to close it and suggest changing the color in ~/.gntrc instead.

comment:7 Changed 11 years ago by galt

This is not about the entry box at all, it's about the drop-down menus.

comment:8 Changed 11 years ago by galt

OK, I went over the description and I realize how it could be understood as if it was referring to entry boxes, at least when reading through it quickly. So I'll try to make the explanation as succinct as possible:

When navigation between entries in a drop-down menu, the entry in focus is coloured teal on top of a black background, while other entries are coloured gray on top of the default terminal background.
In a non-virtual terminal, the default background colour is black. The user can only tell what entry of the drop-down menu is in focus by the colour of the text.

The problem: Colour blind users very often can't tell teal from gray, at least with the colour depth of a terminal environment.

comment:9 Changed 11 years ago by rlaager

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:10 Changed 11 years ago by sadrul

  • Owner sadrul deleted
  • Status changed from reopened to new
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!