Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#3683 closed defect (invalid)

Backspace Beeps

Reported by: fishpool Owned by: lschiere
Milestone: Component: winpidgin (gtk)
Version: 2.2.2 Keywords:
Cc:

Description

So upon upgrading to 2.2.2. when i hit backspace and there is nothing there, my computer beeps. It hadn't happened in the past and its only in Pidgin. Windows XP.

Change History (18)

comment:1 follow-up: Changed 10 years ago by datallah

  • Resolution set to invalid
  • Status changed from new to closed

This is a GTK+ (mis)feature.

You can disable it by setting the gtk-error-bell setting to FALSE your gtkrc file.

comment:2 Changed 10 years ago by dave1g

Using Pidgin

I have this

gtk-theme-name = "MS-Windows"
gtk-error-bell = "FALSE"

in both %APPDATA%\.purple\gtkrc-2.0 and %APPDATA%\.purple\.gtkrc-2.0 I wasnt sure which was meant, but neither turns of that horribly annoying beep. clearly an invalid (pidgin) bug, but everyone will hate you for it lol

comment:3 Changed 10 years ago by deryni

gtk-error-bell apparently wants to be set to 0.

comment:4 Changed 10 years ago by dave1g

thank you,

and just for everyones knowledge, what I thought was a typo was not, put

gtk-error-bell = 0

in the file %APPDATA%\.purple\gtkrc-2.0

comment:5 Changed 9 years ago by thaclient

I'm using Vista and those files were not present, but the directory was. I created both of them (one with the "." and one without) and reloaded Pidgin. Worked perfectly with:

gtk-error-bell = 0

comment:6 Changed 9 years ago by deryni

The gtkrc-2.0 file in %APPDATA%\.purple\ should not have a leading dot, for the record.

comment:7 in reply to: ↑ 1 Changed 9 years ago by ngwells

Replying to datallah:

This is a GTK+ (mis)feature.

You can disable it by setting the gtk-error-bell setting to FALSE your gtkrc file.

In my opinion, this should still be considered valid ticket. It's a change in the behavior of the application, it's not at all clear how control it, and it cannot be controlled through the UI. The workaround mentioned does seem to work, but it's a little above and beyond what most people would consider normal application configuration steps.

comment:8 Changed 9 years ago by datallah

I plan to disable this by default in the next GTK+ release, and I've filed a ticket upstream to suggest that they make the same change.

comment:9 Changed 9 years ago by plainstarchedtom

A question about the upstream fix (this might not be the appropriate forum, but I didn't know for sure where to ask): The last comment in the GTK+ thread mentions just disabling the beep if a user presses backspace in an empty text area. Does the patch also address the problem I'd experienced -- pressing page-up or page-dn when already at the top/bottom of a list and getting the beep?

Anyway, from an end-user standpoint this fix was, in my estimation, pretty difficult to implement (but thanks for all the directions!), and I thought that the beeping presented a serious functionality issue - although I don't know how you determine priority for bugs and whatnot, but I can only imagine the headache this could cause some people. Even though the source of the problem is with GTK+, what are the chances of a pidgin patch? Alternatively, when will the next GTK release be available/is it packaged with pidgin?

As a pretty basic user, I really don't know what most of this stuff means and am just hoping for help for clueless folks like me. Thanks.

comment:10 Changed 9 years ago by datallah

The upstream fix that has been committed is the same as the fix here and applies to all cases where the beep occurs.

As far as priority goes, this is clearly a low priority item - it is an annoyance, but there is an easy workaround - it isn't like it is a crashing or something.

The next release of pidgin will contain a "fixed" GTK+ runtime.

comment:11 Changed 9 years ago by proft

There have been any number of additional bugs filed against this defect. IMHO changing a global setting in GTK+ is not a very elegant solution as that may affect all applications on the system that use GTK+.

Expecting basic users to perform such detailed editing of GTK+ settings is not terribly reasonable.

It seems to me that the look and feel of an application should be controlled by that app and not the responsibility of users to tune the back-end application engine.

comment:12 Changed 9 years ago by dave1g

is this still an issue in 2.4?

comment:13 Changed 9 years ago by proft

Yes--I'm running Pidgin 2.4.0 (with latest supplied GTK+) and it performs the same way.

comment:14 Changed 9 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)

If you were using GTK+ 2.12.1 rev b. or higher with the MS-Windows GTK+ theme (which is the default), the beeping would not occur.

For other themes, you need to change the setting in your gtkrc file as mentioned above.

comment:15 Changed 9 years ago by QuLogic

Ticket #7226 has been marked as a duplicate of this ticket.

comment:16 Changed 8 years ago by phinn

This PC speaker beep bug is still a problem for me in WinXP with Pidgin 2.5.4, I had to switch to a non default windows theme in GTK as a work around for another bug that is not closed either.

comment:17 Changed 8 years ago by phinn

Okay I fixed it with this work around slightly different from above:

In: \%APPDATA%\gtkrc-2.0 place the following: gtk-error-bell = 0

Then save, restart Pidgin and it should be fixed.

comment:18 Changed 8 years ago by rekkanoryo

Ticket #8379 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!