Opened 12 years ago

Closed 11 years ago

#3696 closed defect (duplicate)

MSN messages always yield "Message could not be sent because an error with the switchboard occurred"

Reported by: rsk308 Owned by: khc
Milestone: Component: MSN
Version: 2.2.2 Keywords: MSN, server, switchboard, solaris
Cc:

Description

Using 2.2.2, compiled from source on Solaris 9/sparc with gcc 3.4.6. This appears related to #2836. Problem persists whether using non-HTTP method or HTTP method (with appropriate ports in each case).

I'm recompiling pidgin with --debug now and will see if I can ferret out additional information.

Attachments (1)

pidgin.trace (1.2 KB) - added by rsk308 12 years ago.
Debug output of pidgin while triggering this error

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by rsk308

Debug output of pidgin while triggering this error

comment:1 Changed 12 years ago by rsk308

I've finished recompiling with --debug and have recreated the problem. Attached is what I believe to be the relevant portion of the debug output.

comment:2 Changed 12 years ago by QuLogic

Error 208 is invalid account name. I can't say why since you've edited out the emails. Does this happen with everyone?

comment:3 Changed 12 years ago by rsk308

Yes, this happens wish everyone. One of the tests I conducted used two of my own accounts (utilizing different instances of pidgin on different systems running different operating systems). Another test used a friend's known-working account (logged in with M$'s own chat client).

comment:4 in reply to: ↑ description Changed 11 years ago by tjwalker

Replying to rsk308:

Using 2.2.2, compiled from source on Solaris 9/sparc with gcc 3.4.6. This appears related to #2836. Problem persists whether using non-HTTP method or HTTP method (with appropriate ports in each case).

I'm recompiling pidgin with --debug now and will see if I can ferret out additional information.

Greetings, Is this still a known issue? Just installed v. 2.3.1 on a Windows XP box. Encountering the same error message on every sent message via MSN. I can receive from MSN user, I can log into the hotmail.com mailbox via Pidgin - just can't IM.

comment:5 Changed 11 years ago by rsk308

I haven't had occasion to re-test since -- let me go back to the debug build that I generated and try to replicate the problem. I'm also thinking -- since it's been a while -- that I should grab the latest version from the repository, build that, and try with it as well, just in case it's been addressed by other changes that have been made.

comment:6 follow-up: Changed 11 years ago by rsk308

I've replicated the problem, but (as before) on Solaris 9. I'm not terribly sure it's worth hunting it down there, given that most of the world has moved on to Solaris 10 by now. My intention is to grab Solaris 10 8/2007 from Sun, install it, build gcc and other tools required for pidgin, and try there. If the problem persists, then I'm going to lean toward presuming it's a real pidgin bug. If the problem disappears, then I'm going to lean toward presuming it's related to Solaris 9 or something specific in the software environment here. (This is all on Sparc; I'll probably get around to trying it with Solaris-on-Intel as well, but that may take a while.)

comment:7 in reply to: ↑ 6 Changed 11 years ago by Sim-on

  • Component changed from libpurple to MSN
  • Owner set to khc
  • pending changed from 0 to 1

Replying to rsk308:

If the problem persists, then I'm going to lean toward presuming it's a real pidgin bug. If the problem disappears, then I'm going to lean toward presuming it's related to Solaris 9 or something specific in the software environment here. (This is all on Sparc; I'll probably get around to trying it with Solaris-on-Intel as well, but that may take a while.)

Did the problem disappear?

comment:8 Changed 11 years ago by rsk308

  • pending changed from 1 to 0

I haven't gotten that far yet. I'm doing this work on an old Sun box, so everything takes a while to build. (e.g., gcc takes the better part of three days) Oh, I'm still slogging my way toward it, it's just that the current algorithm is "type make, then go to bed, check it in the morning".

comment:9 Changed 11 years ago by khc@…

(In d74f5de7c6212216ca73edc2bfdbd770813a5f5b):
Stu's idea, I sort of did it the other way. I don't know if it will help but I am going to References #1862, #3696, #6776

comment:10 Changed 11 years ago by khc

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #3330.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!