Opened 12 years ago

Closed 12 years ago

#3698 closed defect

Contacts not visible on bonjour

Reported by: lithium Owned by: MarkDoliner
Milestone: Component: Bonjour
Version: 2.2.2 Keywords:
Cc:

Description

While testing the Empathy client I found another bug in Pidgin's Bonjour implementation: we have got a small WLAN network at home. Using Empathy, I could see and chat with my sister, who uses Pidgin. Using Pidgin, I was not able to see here presence. I can see my Pidgin in Empathy, though.

Any idea how to further narrow the problem down? My sis is using Pidgin 2.2.1 (from ubuntu gusty), I use 2.2.2.

Attachments (2)

notshowingup.png (182.5 KB) - added by lithium 12 years ago.
Presence not shown in Buddylist
wrongstatus.png (210.6 KB) - added by lithium 12 years ago.
Wrong status in Buddylist

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by datallah

  • pending changed from 0 to 1

Can you see her presence in the Avahi browser?

comment:2 Changed 12 years ago by lithium

  • pending changed from 1 to 0

Yes. I think the problem is related to pidgin not refreshing the status correctly. Note: after I enable/disable the accounts on both pcs, sooner or later the accounts show up on both PCs. Even if pidgin doesn't show the other presence, avahi-discover does.

There is also a problem where I update a status (available -> away for example) on one PC and it doesn't change on the other. Again, avahi-discover shows the right status on both machines.

I have tested this with both pidgin-pidgin and pidgin-empathy and get the same results.

The following screenshots have been made using VNC, so both clients and avahi-discovers are shown. The first shows a contact not being shown in the buddy list, while it is in avahi-discover. The other shows a status update that is not reflected in the GUI.

Changed 12 years ago by lithium

Presence not shown in Buddylist

Changed 12 years ago by lithium

Wrong status in Buddylist

comment:3 Changed 12 years ago by lithium

The blue/turquise lines only show which windows belong together (one PC) because it's a bit hard to make out which window belongs to which side of the VNC ;)

comment:4 Changed 12 years ago by datallah

  • pending changed from 0 to 1

I'm unable to recreate this, Pidgin detects status changes and notices new contacts of users using gajim, avahi, ichat and other pidgin users just fine for me (I haven't tries with empathy).

Are you using Pidgin compiled against avahi natively or through the howl wrapper?

comment:5 Changed 12 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from new to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!