Opened 11 years ago

Closed 5 years ago

#4308 closed enhancement (fixed)

Finch on windows

Reported by: steppnav Owned by: sadrul
Milestone: 3.0.0 Component: finch (gnt/ncurses)
Version: 2.3.0 Keywords: mingw win32
Cc:

Description

I use cygwin on Windows. Has anybody made finch for that pseudo*nix?

Change History (6)

comment:1 Changed 11 years ago by datallah

At one point, I think Sadrul built it on cygwin, but IIRC it wasn't fully operational and I don't think anyone has played with it since.

If you're interested in trying, you might have better luck building a cygwin finch against a native win32 libpurple.

comment:2 Changed 11 years ago by sadrul

  • Milestone set to Patches welcome
  • Summary changed from Where can I get finch? to Finch on windows

comment:3 in reply to: ↑ description Changed 8 years ago by ulesPidgin

Replying to steppnav:

I use cygwin on Windows. Has anybody made finch for that pseudo*nix?

I volunteer for code finch for win32, any advice on how to start is welcomed

comment:4 follow-up: Changed 7 years ago by ulesPidgin

I managed to compile finch with some workarounds in cygwin, it's running but I can't add accounts because it tells: There are no protocol plugins installed. (you probably forgot to 'make install'). But I did 'make install' i had to disable come features, like Perl, does it may be the cause?

comment:5 in reply to: ↑ 4 Changed 7 years ago by ulesPidgin

Replying to ulesPidgin:

I managed to compile finch with some workarounds in cygwin, it's running but I can't add accounts because it tells: There are no protocol plugins installed. (you probably forgot to 'make install'). But I did 'make install' i had to disable come features, like Perl, does it may be the cause?

these are the arguments to ./configure --enable-consoleui --disable-gtkui --disable-gstreamer --disable-vv --disable-meanwhile --disable-avahi --disable-nm --disable-perl

comment:6 Changed 5 years ago by tomkiewicz

  • Keywords mingw win32 added; cygwin finch removed
  • Milestone changed from Patches welcome to 3.0.0
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

As for 5ffcb3db9398, it should finally be possible to build finch for windows (native console app, not cygwin) without any workarounds. The only required configure parameter is:

./configure --host=i686-w64-mingw32

for cross-compilation. You may also provide --prefix and you should set PKG_CONFIG and PKG_CONFIG_PATH env variables to properly cross compile. You don't have to disable things not supported on win32, as they are disabled by default on this OS.

There is no installer yet. I also haven't tested compilation on cygwin.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!