Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4442 closed defect (fixed)

Conversation window is closed without notice

Reported by: robochief Owned by: sadrul
Milestone: 2.5.2 Component: pidgin (gtk)
Version: 2.4.0 Keywords:
Cc: Insomniac18, Chorca

Description

On Windows, on different PCs and chatting with different protocols (MSN, XMPP & AIM), sometimes when I'm in the middle of writing a message, conversation windows just disappears, even if I had several conversation in different tabs, they all get closed.

And in spite of having deactivated the option "Close IMs immediatly when the tab is closed", after the abrupt closure, when I reopen a conversation Pidgin won't show last messages.

If there's any more info. I can provide, let me know.

Regards, robochief

Attachments (3)

purple-debug.log (9.4 KB) - added by robochief 11 years ago.
Debug file of last minutes where conversation window was closed
pidgin_debug.log (1.6 KB) - added by XBit 11 years ago.
DeeperID-debug.txt (10.0 KB) - added by DeeperID 11 years ago.
close window debug

Download all attachments as: .zip

Change History (60)

comment:1 Changed 11 years ago by datallah

  • pending changed from 0 to 1

Is pidgin crashing when this happens?

What does the debug log say?

comment:2 Changed 11 years ago by robochief

  • pending changed from 1 to 0

No, Pidgin doesn't crash at all; the only issue is the conversation window disappearing. I'll get the debug log and update ticket.

comment:3 Changed 11 years ago by robochief

Got the debug log, and when a window is closed, the following entry appears:

[TIME_STAMP] oscar: Received unknown typing notification message from [CONTACT_NAME].  Type1 is 0x0001 and type2 is 0x000f.

comment:4 Changed 11 years ago by datallah

  • pending changed from 0 to 1

That is likely not related.

Please post the whole debug log (or at least the last minute or two up to and including the conversation closing itself).

Changed 11 years ago by robochief

Debug file of last minutes where conversation window was closed

comment:5 Changed 11 years ago by robochief

  • pending changed from 1 to 0

I hope the debug file I attached will help.

comment:6 Changed 11 years ago by XBit

I don't know if it helps, but I have the same problem starting with 2.3.1.
I am attaching a debug log too, maybe it helps.
Regards,
XBit

Changed 11 years ago by XBit

comment:7 Changed 11 years ago by mots

i also experience the same problem. but pidgin show me the log if i reopen the window. (one of the buddy that had its conversation window closed is using adium)

comment:8 Changed 11 years ago by XBit

Any chance to get some opinions on this bug, or we'll have to wait until more people are affected?

comment:9 Changed 11 years ago by Daniel Beardsmore

Never had it happen whilst typing or while the window was focused, but it does happen when I'm not typing to a background window. Never seen a window with multiple tabs disappear, but certainly, a window with one tab will sometimes just disappear when I'm not looking. The conversation is always closed internally -- it doesn't stay open and the last messages do not return.

This bug started with 2.3.1; FWIW I am using Windows 2000.

comment:10 Changed 11 years ago by robochief

This keeps happening to me, not that often, but randomly. Window can be active, while writing a message, in background... Etc.

comment:11 Changed 11 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from lschiere to datallah

#4649 has some potentially useful information about this.

comment:12 in reply to: ↑ description Changed 11 years ago by Kyrra

This keeps happening to me only on my home PC (not work). It's happened no matter if I have focus on the Chat window. My Home PC uses AIM/MSN/GChat(XMPP)/ICQ and I have the problem. My work PC only uses XMPP(jabber) and I haven't run into the issue yet.

Both are WinXP SP2 with Pidgin 2.3.1.

comment:13 Changed 11 years ago by Daniel Beardsmore

I read about this bug somewhere on the Pidgin site before it happened to me, so I was expecting it. When it finally happened, it was to an AIM user, and it re-occurred for him once or twice. It's also occurred to an ICQ user at least once. It's been relatively infrequent for me.

comment:14 Changed 11 years ago by zodiac_hh

I just have to add that this happens multiple times per day (WinXP, with XMPP) and is a major annoyance. If you don't use chat logs and new messages appear in the chat window, and this bug kills it off, the messages are effectively lost if you don't read them fast enough. If this happens to a lot of people I suggest bumping up the priority because losing messages could drive people away from Pidgin. (And I#m not talking about me.)

comment:15 Changed 11 years ago by mots

it happened to me to many times. like once a day. and sometime when i had new unread message. closing the conversation with the new unread message. i had to search the logs by date to find back my message !

i would definitly put this to major !

i'll try to get some more debug logs (keeping the debug windows open until is occurrs)

comment:16 Changed 11 years ago by mots

well... debugs window crashes ! ;) so no debug logs...

comment:17 Changed 11 years ago by Daniel Beardsmore

Just use:

cd "C:\Program Files\Pidgin"
pidgin.exe -d > debug.log

to get a debug log.

comment:18 Changed 11 years ago by DeeperID

I'm also having the same issue, I've had pidgin installed (2.3.1) for about 3 days and I just noticed it today after I changed the "Escape" key to close windows in the accels file. I THINK it may have happened once before I made that change but I'm not entirely sure. This occured whilst I was browing a website (technet) on firefox... and just happened again whilst writing this post. It has happened twice now with the same AIM contact. I will post the debug for the last couple minutes.

I'm using AIM, MSN, G-Talk, IRC
I have my tabs set to display on the right side of the window (horizontal)
The AIM user in question was the tab displayed when it disappeared
The previous messages were not displayed as usual when I opened up another chat session with this user
New Conversations (Interface Tab in preferences) is set to "Last created window"
Hide new IM conversations is set to "Always"
Close IMs immediately when the tab is closed is UNCHECKED
Minimize new conversation windows is UNCHECKED

Plugins Enabled:
Buddy List Options 2.2.0
Buddy State Notifications 2.3.1
Conversation Colors 2.3.1
DiffTopic? 2.2.0
Extended Preferences 0.7 (Show buddy list entry in taskbar UNCHECKED)
ExtPlacement? 2.3.1
IRC Helper 2.2.0
IRC More 2.2.0
Join/Part? Hiding 2.3.1
Markerline 2.3.1 (chat windows CHECKED, IM windows UNCHECKED)
Message Notification 2.3.1 (Notify for IM windows, Chat windows CHECKED. Prepend string into window title CHECKED and set to (*), Raise conversation window CHECKED. Notification Removal all CHECKED except when conversation window receives click.
Message Timestamp Formats 2.3.1 (defaults, force 24-hour CHECKED show dates in conversations and message logs both set to FOR DELAYED MESSAGES)
Mystatusbox 2.2.0 (hide icon-selectors CHECKED)
Nicksaid 2.2.0
Pidgin GTK+ Theme Control 2.3.1
Psychi Mode 2.3.1 (Disable when away and Display notification message in conversations both CHECKED)
Release notification 2.3.1
Transparency 2.3.1
Windows Pidgin Options 2.3.1 (Dockable Buddy List CHECKED, Keep Buddy List window on top ONLY WHEN DOCKED, Flash window when chat messages are received CHECKED)

I'm using Windows XP SP2

Hope that helps!

Changed 11 years ago by DeeperID

close window debug

comment:19 Changed 11 years ago by xamphear

This is happening to me also, on both PCs i have Pidgin installed on. Both are XP SP2. I can't describe how frustrating it is after about the 3rd time.

comment:20 Changed 11 years ago by bayashi

This is happening to me as well. Only on my Windows PC. Not my Linux box.

How do I track this bug log for changes and fixes?

comment:21 follow-up: Changed 11 years ago by shs_bulldog

Happening to me as well. Only started happening on this new version.

comment:22 in reply to: ↑ 21 ; follow-up: Changed 11 years ago by shs_bulldog

Replying to shs_bulldog:

Happening to me as well. Only started happening on this new version.

I have turned all my plugins off and will run for a few weeks to see if its a plugin issue or something in pidgin itself.

comment:23 in reply to: ↑ 22 ; follow-up: Changed 11 years ago by shs_bulldog

Replying to shs_bulldog:

Replying to shs_bulldog:

Happening to me as well. Only started happening on this new version.

I have turned all my plugins off and will run for a few weeks to see if its a plugin issue or something in pidgin itself.

Confirmed. Even with all plugins turned off, conversation window still closed.

comment:24 in reply to: ↑ 23 ; follow-up: Changed 11 years ago by DeeperID

Replying to shs_bulldog:

Replying to shs_bulldog:

Replying to shs_bulldog:

Happening to me as well. Only started happening on this new version.

I have turned all my plugins off and will run for a few weeks to see if its a plugin issue or something in pidgin itself.

Confirmed. Even with all plugins turned off, conversation window still closed.

Did you make any modifications to the accels file as mentioned in my post above?

comment:25 in reply to: ↑ 24 Changed 11 years ago by shs_bulldog

Replying to DeeperID:

Replying to shs_bulldog:

Replying to shs_bulldog:

Replying to shs_bulldog:

Happening to me as well. Only started happening on this new version.

I have turned all my plugins off and will run for a few weeks to see if its a plugin issue or something in pidgin itself.

Confirmed. Even with all plugins turned off, conversation window still closed.

Did you make any modifications to the accels file as mentioned in my post above?

No I did not.

comment:26 follow-up: Changed 11 years ago by bconway

Glad I found this ticket. I've been using 2.3.1 compiled against Debian 4.0/Etch for many weeks (and versions prior to that) without any problems listed above.

Then in the past week, I was doing some reading on the various mailing list archives, and unchecked "Close IMs immediately when the tab is closed" at the same time as turning on the History plugin. I now see this disappearing window issue at least once a day, sometimes more. I'm primarily using AIM and have separate conversation windows enabled. I haven't made any accels edits.

I've re-checked the "Close IMs immediately" option and left the History plugin on to see if my disappearing windows problem goes away. Thanks.

comment:27 in reply to: ↑ 26 ; follow-up: Changed 11 years ago by shs_bulldog

Replying to bconway:

Glad I found this ticket. I've been using 2.3.1 compiled against Debian 4.0/Etch for many weeks (and versions prior to that) without any problems listed above.

Then in the past week, I was doing some reading on the various mailing list archives, and unchecked "Close IMs immediately when the tab is closed" at the same time as turning on the History plugin. I now see this disappearing window issue at least once a day, sometimes more. I'm primarily using AIM and have separate conversation windows enabled. I haven't made any accels edits.

I've re-checked the "Close IMs immediately" option and left the History plugin on to see if my disappearing windows problem goes away. Thanks.

That's it!!!!! That is what's causing it. I played with that by turning it on as well and that is what broke it. So I guess the bug is that once you turn it on, you can never turn it off.

comment:28 in reply to: ↑ 27 Changed 11 years ago by DeeperID

Replying to shs_bulldog:

Replying to bconway:

Glad I found this ticket. I've been using 2.3.1 compiled against Debian 4.0/Etch for many weeks (and versions prior to that) without any problems listed above.

Then in the past week, I was doing some reading on the various mailing list archives, and unchecked "Close IMs immediately when the tab is closed" at the same time as turning on the History plugin. I now see this disappearing window issue at least once a day, sometimes more. I'm primarily using AIM and have separate conversation windows enabled. I haven't made any accels edits.

I've re-checked the "Close IMs immediately" option and left the History plugin on to see if my disappearing windows problem goes away. Thanks.

That's it!!!!! That is what's causing it. I played with that by turning it on as well and that is what broke it. So I guess the bug is that once you turn it on, you can never turn it off.

Excellent find fellas! I'll try turning that off and keep the history enabled and see if this stops the problem, I'll post back in a few days with my results also.

comment:29 follow-up: Changed 11 years ago by bconway

Since re-checking "Close IMs immediately" (and leaving the History plugin on), I have not seen this behavior again. But I will report back it that changes, thanks.

comment:30 Changed 11 years ago by Daniel Beardsmore

The History plugin in totally unacceptable to me because it involves a ton of disc grinding and graunching to open a tab with anyone -- something about scouring the entire log directory like a detective in a murder case just to fetch the most recent log file. I have to put up with this to manually browse logs, but it really slows down opening new tabs.

The new feature simply brings back data already held in memory, making it instantaneous, which is far better.

I would love it if the History plugin was actually usable, but it drove me batty and I turned it off. I don't necessarily blame the Pidgin guys, as Explorer is exactly te same, so they -- or the GTK+ team -- may be unwisely relying on some bad API calls. The Windows command line doesn't have all these problems, so there are certainly much faster ways to fetch a list of folders and files than whatever Pidgin and Explorer are doing.

comment:31 in reply to: ↑ 29 ; follow-up: Changed 11 years ago by DeeperID

Replying to bconway:

Since re-checking "Close IMs immediately" (and leaving the History plugin on), I have not seen this behavior again. But I will report back it that changes, thanks.

I also have not seen this behavior after re-checking "Close IMs immediately" and I haven't lost a conversation window since (It's been a few days).

comment:32 in reply to: ↑ 31 Changed 11 years ago by shs_bulldog

Replying to DeeperID:

Replying to bconway:

Since re-checking "Close IMs immediately" (and leaving the History plugin on), I have not seen this behavior again. But I will report back it that changes, thanks.

I also have not seen this behavior after re-checking "Close IMs immediately" and I haven't lost a conversation window since (It's been a few days).

Me as well. Its been more than a week and no windows vanishing.

comment:33 Changed 11 years ago by XBit

Is this fixed in 2.4.0?

comment:34 Changed 11 years ago by datallah

  • Milestone set to 2.4.0
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in 2.4.0

comment:35 Changed 11 years ago by Kyrra

I just had a XMPP conversation window close on me in the middle of talking with someone (the same way it was with 2.3.1). It doesn't seem this issue is resolved.

Pidgin 2.4.0, GTK+ 2.12.8 rev a

comment:36 Changed 11 years ago by mhersher

I have had XMPP conversations close both while focused and unfocused on 2.4.0. It seems this bug should be reopened.

comment:37 Changed 11 years ago by Kyrra

I would like to restate, if you enable (check) the "Close IMs immediately when the tab is closed" option, this behavior does not happen. This applies to 2.4.0 as well it seems.

If you disable this feature (so IM conversations are remembered for a brief time) the bug shows back up.

comment:38 Changed 11 years ago by DeeperID

I'm also seeing this issue again with 2.4.0 GTK+ 2.12.8 rev a. I unchecked the option "Close IMs immediately when the tab is closed" today then noticed an AIM window close unexpectedly. I have rechecked "Close IMs immediately when the tab is closed" and haven't noticed it since.

comment:39 Changed 11 years ago by datallah

  • Milestone 2.4.0 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 2.3.1 to 2.4.0

comment:40 follow-ups: Changed 11 years ago by Daniel Beardsmore

I might be daydreaming, but I get the distinct impression that it just closed a tab spontaneously. Not the whole window, just an unfocused tab ... Weird. (2.4.0)

Anyone else seen just one tab disappear?

comment:41 in reply to: ↑ 40 Changed 11 years ago by Kyrra

Replying to Daniel Beardsmore:

I might be daydreaming, but I get the distinct impression that it just closed a tab spontaneously. Not the whole window, just an unfocused tab ... Weird. (2.4.0)

Anyone else seen just one tab disappear?

Yes, that's mostly what happens to me. If I have multiple tabs open, it will close my active one at random. If I only have 1 conversation going, it will close the window.

Go re-enable the "Close IMs immediately when the tab is closed" option and the problem goes away. It's at least a workaround for now.

comment:42 in reply to: ↑ 40 Changed 11 years ago by DeeperID

Replying to Daniel Beardsmore:

I might be daydreaming, but I get the distinct impression that it just closed a tab spontaneously. Not the whole window, just an unfocused tab ... Weird. (2.4.0)

Anyone else seen just one tab disappear?

Aye, It has happened to me on unfocused tabs and focused ones.

comment:43 Changed 11 years ago by kobedf

Is happening to me too on Linux using 2.4.0 and Yahoo.

Seems random and it closes the window if there is one conversation, or otherwise an unfocused tab

comment:44 Changed 11 years ago by fishpool

just discovered this but it happened to me using AIM with one person open. glad to see i'm not the only one with the random window closing. using 2.4.0

comment:45 follow-up: Changed 11 years ago by kobedf

Still there in 2.4.1 By the way....with this bug...if you leave your computer for a few minutes...you can't even be certain you see the messages you received.

comment:46 in reply to: ↑ 45 Changed 11 years ago by Kyrra

Replying to kobedf:

Still there in 2.4.1 By the way....with this bug...if you leave your computer for a few minutes...you can't even be certain you see the messages you received.

Indeed. I've long since re-enabled the "Close IMs immediately" option and haven't seen this problem in over a month. It sucks we can't take advantage of the new feature, but I'd rather live without the feature than deal with this bug.

comment:47 Changed 11 years ago by dawg

Yeah, one of the latest updates has caused this issue, and it is driving me nuts. I think the "close IMs immediately when the tab is closed" option is a new feature? I think it started once I checked that option...

It seems to occur when I close a tab, and then re-start a conversation with that person before the timer for actually closing the conversation finishes (or I receive another message before that timeout). It would seem that the IM will be closed, no matter what, when that timer finishes. I have NEVER had the bug NOT occur after having closed a tab and restarted a conversation.

Hope that helps - I don't know if anyone else covered that stuff since I really didn't read ALL of these messages.

comment:48 Changed 11 years ago by deryni

Turning on that option should prevent this bug from occuring, not having that option on is what enables the code that apparently is still broken. I thought we had tracked down and fixed this problem already, apparently not if it is still occuring in 2.4.1.

comment:49 Changed 11 years ago by dawg

Sorry for the confusion, I meant when I unchecked the option, it started the problems.

comment:50 Changed 11 years ago by deryni

I figured, I just decided to be thorough and try to make sure it was clear.

comment:51 Changed 11 years ago by Chorca

This bug is still alive and kicking! Just downloaded the latest 2.5.0 build from GetDeb?, running it on Ubuntu Hardy, and I'm experiencing the same issues with windows closing at random. Three tabs closed within one minute on me!

I've monitored the event log, run Pidgin from the command line, and nothing is reported when the closure happens, it just goes away, losing any conversation history. I've checked on Ubuntu forums, and there's been one or two others who have also commented that they're experiencing the same issue. It doesn't appear that this bug was ever truly fixed; a fix was attempted, but when that didn't work, it was left alone.

I'm willing to do bug testing for this problem, if the devels can assist me in working with some sort of debug version of the software to try and figure out where the issue is. I'm not a programmer, but I'm quite competent in the use of linux, and I think that I could be of help.

If anyone else is still having this, please let the devs know here. This is a serious problem.

comment:52 Changed 11 years ago by bconway

Still a problem, still using the workaround in comment 26. Thanks.

comment:53 Changed 11 years ago by khc

  • Component changed from winpidgin (gtk) to pidgin (gtk)
  • Owner changed from datallah to sadrul

This is not a Windows only problem, right?

comment:54 Changed 11 years ago by Chorca

Correct. This is happening in Ubuntu as well.

comment:55 Changed 11 years ago by sadrul@…

  • Milestone set to 2.5.2
  • Resolution set to fixed
  • Status changed from new to closed

(In 276af715e3b26cba28965e1fa14e8c6e5ac65a85):
Fix the conversation window closing unexpectedly. Again.

Fixes #4442.

comment:56 Changed 11 years ago by datallah

Ticket #7026 has been marked as a duplicate of this ticket.

comment:57 Changed 11 years ago by datallah

Ticket #6426 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!