Opened 8 years ago

Closed 7 years ago

#4597 closed defect (out of date)

Pidgin/Finch 2.3.1 segfault on start

Reported by: Kulrak Owned by:
Milestone: Component: libpurple
Version: 2.3.1 Keywords: segfault pidgin finch start
Cc:

Description

Pidgin is segfaulting before any gui windows come up or it does anything that I can see. Both Pidgin and Finch are doing exactly the same thing, and the backtrace on both is the same, so I'm assuming it's in libpurple. I've moved ~/.purple, and it had no effect.

Attachments (4)

pidgin-debug.log (5.7 KB) - added by Kulrak 8 years ago.
pidgin-backtrace.log (4.8 KB) - added by Kulrak 8 years ago.
pidgin-ldd-nss-info.log (4.8 KB) - added by Kulrak 8 years ago.
pidgin-deps.log (5.3 KB) - added by Kulrak 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Kulrak

Changed 8 years ago by Kulrak

comment:1 Changed 8 years ago by datallah

  • pending changed from 0 to 1

This is crashing somewhere in the NSS code.

What is odd is that you're using NSS libraries in /usr/lib/libpurple/ (/usr/lib/libpurple/libnssckbi.so) - why do those exist? Why are you not using the Pidgin and NSS packages?

comment:2 Changed 8 years ago by Kulrak

  • pending changed from 1 to 0

hmm, /usr/lib/libpurple/ doesn't exist on this machine, and my libnssckbi.so is in /usr/lib/nss/ (where the debian package put it). I ran a ldd on pidgin and libpurple, and they don't seem to be linked to that file in either location. I'll attach those outputs.

Changed 8 years ago by Kulrak

Changed 8 years ago by Kulrak

comment:3 Changed 7 years ago by anibal

The same for me, both crash at startup, even with no .purple directory. I've also commented and attached a bugreport in #8940

comment:4 Changed 7 years ago by bernmeister

Should this be made a duplicate of $8940 (or vice versa)? This ticket is quite old and refers to an old version of Pidgin...so maybe just close it outright?

comment:5 Changed 7 years ago by Kulrak

I'm now using 2.5.8, and the problem has long since resolved itself.

comment:6 Changed 7 years ago by darkrain42

  • Resolution set to out of date
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!