Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4606 closed defect (fixed)

buddies set to "show when offline" don't get shown at every startup

Reported by: richardaburton Owned by:
Milestone: 2.6.0 Component: pidgin (gtk)
Version: 2.4.1 Keywords: show offline
Cc: Luffe66, tukamhane

Description

I have contacts which have "show when offline" set on them. When I start pidgin these contacts (if they are offline) are not shown. If I enable the global "show -> offline buddies" option, and then disable it again, the buddies do correctly appear in the list.

Change History (44)

comment:1 Changed 11 years ago by varchar255

I have the same problem on Pidgin 2.3.1, Windows XP. I also had the problem using the Show Offline Buddies plugin (before it was merged into Pidgin itself).

comment:2 follow-up: Changed 11 years ago by jgxenite

I have also noticed this. It happens to me during initial start up (disabling and re-enabling the relevant account clears it) but they also sometimes seem to disappear for no obvious reason too.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 11 years ago by MMlosh

I have same problems. I clicked "Show when offline" and nothing happened, Buddy appeared after showing empty groups and stayed after hiding them. His name was darker, but now is grayed as other offline.

This buddy uses two accounts and this seems to cause another related problems. When I login into both services at one time, it si OK. But when I sign in Jabber (offline buddy appears) and then I sign in ICQ, my offline budy is gone

Maybe it will be easiest to add new IM protocol "online" which will only say thay they are online (and disabling writing to them), but now I am starting to think I suggest only temporarily and home-made fix, so do not take it seriously.

comment:4 Changed 11 years ago by paik

Same problem with Pidign 2.4.0! "Show when offline" doesn't seem to work at start up and there's another problem with hiding empty groups: Groups are hidden when nobody's online even if there are contacts with "Show when offline" enabled.

OS: Windows Vista SP1 and XP SP3 Language: German

comment:5 in reply to: ↑ 3 Changed 11 years ago by MMlosh

Oh, I forgot: I used Pidgin 2.3.1, now I am using 2.4.0.

Contact is shown, but its group is hidden (only first protocol-XMMP had set "Show when offline").

Now, with both buddy's account set to "Show when offline", it seems to be OK.

Os: Linux (*Buntu Gusty Gybon, 32bit, WM:Fluxbox)

comment:6 Changed 11 years ago by datallah

  • pending changed from 0 to 1
  • Summary changed from buddies set to "show when offline" don't get shown at startup to buddies set to "show when offline" don't get shown at startup when

I can't recreate this in 2.4.1 - can anyone?

comment:7 Changed 11 years ago by Sim-on

  • pending changed from 1 to 0
  • Version changed from 2.3.1 to 2.4.1

I can. Win XP, ICQ, Pidgin 2.4.1

comment:8 Changed 11 years ago by datallah

  • pending changed from 0 to 1
  • Summary changed from buddies set to "show when offline" don't get shown at startup when to buddies set to "show when offline" don't get shown at startup when no buddies in group are online

Please provide a recipe for recreating this.

comment:9 in reply to: ↑ description Changed 11 years ago by Sim-on

  • pending changed from 1 to 0

I did it like richardaburton explained:

  1. turn on "show offline buddies"
  2. select a buddy "show when offline"
  3. turn off "show offline buddies"
  4. close & start pidgin
  5. They dont appear in the blist
  6. turn on "show offline buddies"
  7. turn off "show offline buddies"
  8. The marked buddy should appear as offline in the blist


but I just recognized an interesting behaviour: I tested with 3 buddies. For one it works correct but not for the others?!
But you changed the summary to maybe a different problem than richardaburton had?

What i described has nothing to do with empty groups.In the group are about 20 person, 6 online and 3 should appear as offline but only one do correct at startup.

comment:10 Changed 11 years ago by richardaburton

Yes, he did change the summary to a different problem, and I'd appreciate it if it was changed back (I'd do it myself but it's really not obvious how to do that). If he has a different problem he should open a different bug. It's fine to contribute to bugs other people have opened (in fact it's a good thing) but if you start changing the definition of the problem then that's hijacking it.

Interesting to note you get some buddies show, but not all of them. I'm sure it's a timing issue. I only have one buddy with this set, sometimes she shows up, sometimes she doesn't. I guess with several buddies you could land in the middle.

comment:11 Changed 11 years ago by Sim-on

  • Summary changed from buddies set to "show when offline" don't get shown at startup when no buddies in group are online to buddies set to "show when offline" don't get shown at every startup

comment:12 Changed 11 years ago by datallah

I missed that the relevant comment came from someone other than the original reporter. Relax.

I can't recreate this.

comment:13 Changed 11 years ago by Sim-on

I still can ;)

Interesting is that i just forgot these issue and now after running pidgin 2 or 3 hours after startup, suddenly one of these buddies appeared as offline in the blist. About one minutesafter i set him to "do not show when offline" again one of the other buddies which should be all the time shown as offline appears as offline in the blist.

comment:14 Changed 11 years ago by richardaburton

I still have it on 2.4.1 as well.

Mine doesn't appear to change if I leave it like yours though. My only show-offline buddy hadn't appeared after gaim had been connected for about 2 hours, just did a show all / don't show all and now she's appeared correctly.

comment:15 follow-up: Changed 11 years ago by nosnilmot

Are the affected buddies part of a contact (with more than one buddy when you right-click and select "Expand") ?

comment:16 Changed 11 years ago by richardaburton

Never tried that before, and don't really know what it is/does. However there only appears to be one thing under the person when I expand them.

comment:17 in reply to: ↑ 15 Changed 11 years ago by Sim-on

Replying to nosnilmot:

Are the affected buddies part of a contact (with more than one buddy when you right-click and select "Expand") ?

no. I dont see any obvious difference to other buddies.

comment:18 Changed 11 years ago by nosnilmot@…

(In 9448aec0bc0e0168e10e0a3991bfbfe716de6c86):
Fix setting "show offline" for buddy list nodes so it takes immediate effect, references #4606 but I'm not sure if that's a different problem.

comment:19 Changed 11 years ago by dhanak

Same behavior here, using Pidgin 2.4.1.

Please note that this only happens when the "Show empty groups" option is off. Furthermore, turning this option on and then off again makes offline buddies marked as "show when offline" disappear again, incorrectly, unless the particular buddy is selected when the "Show empty groups" option is turned off.

Hope this helps.

comment:20 follow-up: Changed 11 years ago by magnuson

Problem still exists in 2.4.2, WinXP, AIM. Same symptoms/resolution as 04/21/2008 10:44:49 AM changed by Sim-on

comment:21 in reply to: ↑ 20 Changed 11 years ago by mstanescu

I confirm this problem 2.4.2 on gentoo. I cant belive this issue that is so annoying persists so many versions. (5 months)

Replying to magnuson:

Problem still exists in 2.4.2, WinXP, AIM. Same symptoms/resolution as 04/21/2008 10:44:49 AM changed by Sim-on

comment:22 in reply to: ↑ description Changed 11 years ago by AnD

Replying to richardaburton:

I have contacts which have "show when offline" set on them. When I start pidgin these contacts (if they are offline) are not shown. If I enable the global "show -> offline buddies" option, and then disable it again, the buddies do correctly appear in the list.

I have same problem in Pidgin-2.4.3, and it gone around by switch on option "show empty groups". After that buddies, marked to show offline are wisible on atartup.

comment:23 Changed 11 years ago by Jointy

Hi,

I'm using gentoo with pidgin 2.4.3 and have the same behaviour. Only the trick with "Show empty groups" fixed it for me.

j0inty

comment:24 Changed 11 years ago by datallah

Ticket #6812 has been marked as a duplicate of this ticket.

comment:25 Changed 11 years ago by foot

Same with 2.5.1

comment:26 Changed 11 years ago by MMlosh

Yes, still exists in 2.5.1 (Ubuntu Hardy + derivates)

It can be an multi-protocol issue on my side (ICQ logs in immediately, jabber needs ~7s)

comment:27 Changed 10 years ago by datallah

Ticket #7170 has been marked as a duplicate of this ticket.

comment:28 Changed 10 years ago by datallah

Ticket #7689 has been marked as a duplicate of this ticket.

comment:29 Changed 10 years ago by datallah

Ticket #8181 has been marked as a duplicate of this ticket.

comment:30 Changed 10 years ago by BigRedBrent

I have the same problem on Pidgin 2.5.4 on Windows XP.

comment:31 Changed 10 years ago by datallah

Ticket #8324 has been marked as a duplicate of this ticket.

comment:32 Changed 10 years ago by tukamhane

I have the same problem on Pidgin 2.5.4 on Windows XP. However I can work around this by switching the option "show empty groups" ON.

comment:33 Changed 10 years ago by backslash

The same in Pidgin 2.4.2 on Linux Only 1 of my 10 buddy offline appears. It's the only one that has into the nickname (not the lias but the nickname) its email address (with @ character) It's a stupid difference but it's the only one.

comment:34 Changed 10 years ago by kadakas

This bug also exists in Pidgin 2.5.2 + Ubuntu 8.10.

comment:35 Changed 10 years ago by chckens

This issue has been irritating me for a while, but today I think I spotted a way to reliably trigger it:

1. Start pidgin, and enable two IM accounts (accounts A and B)
2. enable "show offline buddies"
3. right click an offline buddy from account A and "show when offline"
4. disable "show offline buddies"
5. ensure there is at least one online buddy from account B in the same group as that visible offline buddy (drag one in if necessary)
6. disable account B (Accounts->"account B"->disable)
7. enable account B (Accounts->Enable Account->"account B"

For me (Pidgin 2.5.2 on Ubuntu 8.10, account A being MSN and B XMPP), this always makes the visible offline buddy from account A disappear, just before the online buddy in the same group on account B appears. It's easy to imagine how this situation could be encountered during Pidgin startup too whilst connecting to multiple accounts.

Makes me wonder, is anyone using Pidgin with only one account and still seeing this issue?

comment:36 Changed 10 years ago by backslash

Yas, it's me with Pidgin 2.4.2 on a Linux (RHEL) machine Only one account configured (MSN) and with this problem

comment:37 Changed 10 years ago by datallah

Ticket #8596 has been marked as a duplicate of this ticket.

comment:38 Changed 10 years ago by datallah

Ticket #7364 has been marked as a duplicate of this ticket.

comment:39 Changed 10 years ago by datallah

Ticket #8938 has been marked as a duplicate of this ticket.

comment:40 Changed 10 years ago by abyss.7

Pidgin 2.5.5, bug is still there.

comment:41 Changed 10 years ago by kobedf

Still there in 2.5.6 , Ubuntu 9.04

comment:42 Changed 10 years ago by qulogic@…

  • Milestone set to 2.6.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 69b3b10f3cd5853b74cace5f7247f384555cbbff):
Patch to change around some logic that should fix missing buddies that are set to "show when offline".

Fixes #9288 and #4606.

comment:43 Changed 10 years ago by QuLogic

Ticket #9573 has been marked as a duplicate of this ticket.

comment:44 Changed 10 years ago by richardaburton

Have been running 2.6.1 for a while now, and it does appear to have fixed the problem. Thanks!

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!