Opened 11 years ago

Last modified 10 years ago

#4762 new defect

IRC shows connected after failing to connect

Reported by: aredridel Owned by: elb
Milestone: Component: IRC
Version: 2.3.1 Keywords:
Cc:

Description

When connecting with the username (not screen name) "Lizagna!", our IRC server rejects it, saying "bad username". Pidgin shows the account as enabled, but as it's not connected and in proper state, it doesn't work.

Attachments (1)

ircfail.pcap (1.7 KB) - added by aredridel 10 years ago.
Trace of badly handled response.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by elb

With what numeric does it reject this? Is it a standard numeric?

comment:2 Changed 11 years ago by aredridel

461.

Seems to be stretching the idea of "too many parameters" into "bad parameters"

comment:3 Changed 10 years ago by elb

I'll need a trace of this happening to have any hope of fixing it.

comment:4 Changed 10 years ago by bernmeister

aredridel: Is this still occurring in Pidgin 2.5.8? Can you get a debug trace is so...

comment:5 Changed 10 years ago by darkrain42

aredridel, please get a packet capture of this error occurring (using tcpdump or wireshark). If you need assistance with that process, comment here or go to #pidgin on IRC.

Changed 10 years ago by aredridel

Trace of badly handled response.

comment:6 Changed 10 years ago by aredridel

The newer versions report an error when registration times out, but in the mean time show connecting and don't report the actual error.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!