Opened 11 years ago

Closed 11 years ago

#4780 closed defect (duplicate)

Log Reader plugin does not localize 'History' when looking for MSN logs.

Reported by: Psykotik Owned by:
Milestone: Component: plugins
Version: 2.3.1 Keywords: Log Reader plugin msn
Cc:

Description

Don't know if it is an attended behavior or a defect.

Pidgin log reader plugin cannot read my MSN history, which is at xml format (see the example). Nothing is displayed for my contacts.

Attachments (3)

jeamtag3341796928.xml (443 bytes) - added by Psykotik 11 years ago.
gdb-pidgin.txt (5.9 KB) - added by Psykotik 11 years ago.
debug file
debug.log (62.6 KB) - added by Psykotik 11 years ago.
debug log

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by Psykotik

comment:1 Changed 11 years ago by QuLogic

  • pending changed from 0 to 1

In which directory do you have the Log Reader plugin set to look?

Also, please attach a debug log.

comment:2 Changed 11 years ago by Psykotik

  • pending changed from 1 to 0

Well, the plugin looks in the folder where msn logs are... "/home/users/.purple/logs/msn-windows" in my case. It is a symbolic link pointing to "/media/WinXP/Documents and Settings/Psykotik/Mes? documents/Mes archives de conversations/userNUMBER/Historique". Yes, it's a bit tricky, since I link to a NTFS Windows installation. But : it does work with trillian logs, which are used in the same way, and I've already tried to actually create a real folder in .purple/logs/msn-windows (and not a symbolic link), containing all my files; no change.

If your question was more related to the files's names :

$ ls -a
.                            MessageLog.xsl
..                           missk-ssi2084313982.xml
archives tati.rar            perreta13902174589.xml
damiensorrell1251461152.xml  pizza_akira2185888532.xml
décembre 2005                sebpsg773854747609.xml
jeamtag3341796928.xml        severian427968314769.xml
jpaga19791490533564.xml      unseeen2234841286.xml
juillet 2005                 unseen.rar
juin 2005                    wanstall660499100.xml
julos1233813367970.xml

I'm attaching also the debug log, but I don't know if I was supposed to make a complementary task while debugging, since pidgin doesn't crash. Please bear with me...

Changed 11 years ago by Psykotik

debug file

comment:3 Changed 11 years ago by QuLogic

  • pending changed from 0 to 1

You've attached a backtrace, but I've asked for a debug log. Please run pidgin.exe -d > debug.log and attach debug.log.

comment:4 Changed 11 years ago by Psykotik

  • pending changed from 1 to 0

Sorry, but since the link you wrote was stipulating that this command was for windows users (I'm an ubuntu user), I followed "Others", you see... which lead me to backtrace.

I ran "pidgin -d > debug.log", hope it will be more interesting that the previous file.

Changed 11 years ago by Psykotik

debug log

comment:5 Changed 11 years ago by QuLogic

  • Summary changed from Log Reader plugin can't read msn history at xml format to Log Reader plugin does not localize 'History' when looking for MSN logs.

Oh, I missed some of what you said. The setting for the directory should be /media/WinXP/Documents and Settings/Psykotik/Mes documents/Mes archives de conversations. However, since the log reader plugin is hard-coded to use 'History', it will not find the 'Historique' folder, anyway.

Until this is fixed, I think what you can do is make a symbolic link from /home/users/.purple/logs/msn-windows/userNUMBER/History to /media/WinXP/Documents and Settings/Psykotik/Mes documents/Mes archives de conversations/userNUMBER/Historique and point the log reader plugin to /home/users/.purple/logs/msn-windows

comment:6 Changed 11 years ago by QuLogic

  • pending changed from 0 to 1

If this works for you, then I can close it as a duplicate of #4384.

comment:7 Changed 11 years ago by Psykotik

  • pending changed from 1 to 0

It perfectly works, thanks QuLogic!

Well, perfectly is not the right word, since it raised a new issue (and a new ticket).

You could close.

comment:8 Changed 11 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Of #4384, as above.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!